Autor Thema: MAXLAN aufgehangen...  (Gelesen 10659 mal)

tucka

  • Gast
MAXLAN aufgehangen...
« am: 04 Januar 2013, 18:13:51 »
Hi,

heute Mittag hat sich mein FHEM auf dem RPI aufgehangen, nachdem sich FHEM anscheinend nicht mehr mit dem CUBE verbinden konnte.

Erst nach booten des RPI und Neustart des CUBEs lief alles wieder.

Hat jemand sowas schon mal gehabt?

Anbei das Logfile:

2013.01.04 11:27:49.286 3: Opening MaxLAN device 192.168.2.107:62910
2013.01.04 11:27:49.296 3: MaxLAN device opened
2013.01.04 11:27:51.299 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:27:51.300 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.01.04 11:27:53.304 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:27:53.304 1: MAXLAN_ExpectAnswer: Error while waiting for answer M:
2013.01.04 11:27:58.551 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:00.555 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:02.559 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:04.563 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:06.567 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:08.571 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:10.575 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:12.579 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:14.583 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.04 11:28:16.587 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
.... und das geht dann alle 2 Sekunden unendlich so weiter...

Danke!
Tucka

mathias-mm

  • Gast
Aw: MAXLAN aufgehangen...
« Antwort #1 am: 15 Januar 2013, 19:08:12 »
Hallo,

genau dieses Problem habe ich auch. Nach dem Neustart der FB7390 und LanCube ging alles wieder. Ist mir jetzt innerhalb von 3 Tagen 2 mal passiert.
Hat jemand ne Idee?

Grüße

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #2 am: 15 Januar 2013, 20:50:51 »
Hallo,

ich habe das jetzt gerade das zweite mal heute, dass FHEM heute nicht mehr reagiert. Im Log finde ich nur:

2013.01.15 18:27:21 3: 1
2013.01.15 18:27:28 3: Opening ml device 192.168.1.21:62910
2013.01.15 18:27:28 3: ml device opened
2013.01.15 18:27:30 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:30 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.01.15 18:27:32 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:32 1: MAXLAN_ExpectAnswer: Error while waiting for answer M:
2013.01.15 18:27:34 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:36 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:38 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:40 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:42 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:44 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 18:27:46 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
...
2013.01.15 19:39:33 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 19:39:35 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 19:39:37 1: MAXLAN_ReadSingleResponse: timeout while reading from socket

Das hatte ich heute Nachmittag schon mal. Da half nur ein Neustart der FritzBox.

Woran kann das denn liegen? Es sieht ja so aus, als ob MAX! amok läuft. Das legt ja das komplette FHEM lahm.
Kann man das irgendwie verhindern? (außer MAX! nicht zu nutzen ;-) )
Ich habe die Cube mal vom Strom getrennt. Das half nicht. Die MAX!-Komponenten waren über die MAX!-PC-Software problemlos ansprechbar.

Danke für Hilfe.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #3 am: 15 Januar 2013, 23:52:32 »
Kam bei mir noch nicht vor. Vielleicht tritt das genau dann auf, wenn ihr die MAX! Software benutzt?
Oder wenn der Cube die Daten in die Cloud pusht? Nutzt ihr das?

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #4 am: 16 Januar 2013, 13:45:45 »
Ich nutze sowohl den Pushdienst als auch die PC-Software. Geht das überhaupt ohne (bei Cube-Nutzung)?
Mit der PC-Software konnte ich jederzit problemlos zugreifen. Auch nachdem ich die Software geschlossen habe, war der Zugriff auf FHEM nicht möglich.
Ich werde mal probieren, ob das Phänomen wieder auftritt, wenn ich die PC-Software erneut starte.
Vielleicht kann man den Fehler ja trotzdem abfangen, da es ja insb. bei der Konfiguration neuer Komponenten mal vorkommen kann, dass man die Software nutzen muss.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #5 am: 16 Januar 2013, 13:49:09 »
Damit ich den Fehler beheben kann, muss er erst mal 100% reproduzierbar sein. Also brauche ich die Schritte, die ich durchführen muss,
damit es zum Hänger kommt.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #6 am: 16 Januar 2013, 20:00:55 »
Ich habe jetzt mal versucht, parallel die MAX!-Software zu nutzen und parallel das Verhalten von FHEM beobachtet.

1. FHEM geöffnet (keine MAX!-Anwendung aktiv): Log sieht normal aus

2. MAX!-Software am PC gestartet und mit der Cube verbunden. Ab jetzt taucht im Log im 2sec.-Takt Folgendes auf:
   2013.01.16 19:44:52 3: Opening ml device 192.168.1.21:62910
    2013.01.16 19:44:52 3: Can't connect to 192.168.1.21:62910: Connection refused
    2013.01.16 19:44:52 2: MAXLAN_Connect: Could not connect
 
   FHEM reagiert noch normal.

3. Über die MAX!-PC-Software eine MAX!-Konfiguration geändert. Im Log taucht weiterhin "nur" die Fehlermeldung auf:
   2013.01.16 19:47:53 3: Opening ml device 192.168.1.21:62910
    2013.01.16 19:47:53 3: Can't connect to 192.168.1.21:62910: Connection refused
    2013.01.16 19:47:53 2: MAXLAN_Connect: Could not connect

   FHEM reagiert noch normal.
   
4. MAX!-App auf iPhone gestartet. Fehlermeldung in App, dass Gateway nicht verbunden ist. FHEM-LOg zeigt weiterhin "nur" den obig genannten Fehler.

5. Dann MAX!-PC-Software beendet. FHEM-Log liefert keine Fehler mehr.

6. MAX!-App auf iPhone: Datenupdate angefordert. iPhone wurde aktualisiert. Im FHEM-Log weiterhin keine Fehler mehr. FHEM arbeitet normal.

Komisch, damit scheint's nix zu tun zu haben.
Ich habe mir auch noch einmal das Log der MAX!-PC-Software angesehen. als die Probleme auftraten, war bei mir die MAX!-Software nicht aktiv.

Hilft das?


Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #7 am: 17 Januar 2013, 14:23:30 »
Wenn dieser Fehler auftritt, stürzt dann FHEM ab? Also existiert der Perl Prozess noch?

Oder hängt es? Und gibt es weiterhin Ausgaben im Log? Oder hören die
"2013.01.15 19:39:37 1: MAXLAN_ReadSingleResponse: timeout while reading from socket"
plötzlich auf?

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #8 am: 17 Januar 2013, 21:28:34 »
Wie kann ich denn feststellen, ob der Perl-Prozess noch läuft?
Ich bin kein Telnet/Linux Experte, darum wäre eine kurze Beschreibung toll.
Ich nutze FHEM auf der FritzBox7390.
Die Meldung scheint aber minutenlang zu kommen, solange bis ich die FritzBox neu gestartet habe.


Jetzt ist mir im Log aber gerade NOCH etwas aufgefallen:

2013.01.15 14:29:07 3: Opening ml device 192.168.1.21:62910
2013.01.15 14:29:07 3: ml device opened
2013.01.15 14:29:09 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 14:29:09 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.01.15 14:29:11 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
2013.01.15 14:29:11 1: MAXLAN_ExpectAnswer: Error while waiting for answer M:
2013.01.15 14:29:14 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
Use of uninitialized value $rmsg in concatenation (.) or string at ./FHEM/00_MAXLAN.pm line 404.
Use of uninitialized value $rmsg in substr at ./FHEM/00_MAXLAN.pm line 405.
Use of uninitialized value $rmsg in substr at ./FHEM/00_MAXLAN.pm line 406.
substr outside of string at ./FHEM/00_MAXLAN.pm line 406.
Use of uninitialized value in split at ./FHEM/00_MAXLAN.pm line 406.
Use of uninitialized value $rmsg in pattern match (m//) at ./FHEM/00_MAXLAN.pm line 159.
2013.01.15 14:29:16 1: MAXLAN_ReadSingleResponse: timeout while reading from socket
Use of uninitialized value $rmsg in concatenation (.) or string at ./FHEM/00_MAXLAN.pm line 404.
Use of uninitialized value $rmsg in substr at ./FHEM/00_MAXLAN.pm line 405.
Use of uninitialized value $rmsg in substr at ./FHEM/00_MAXLAN.pm line 406.
substr outside of string at ./FHEM/00_MAXLAN.pm line 406.
Use of uninitialized value in split at ./FHEM/00_MAXLAN.pm line 406.
Use of uninitialized value $rmsg in pattern match (m//) at ./FHEM/00_MAXLAN.pm line 159.

...

Diese Meldungen hören auch erst nach einem FritzBox Neustart auf.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #9 am: 18 Januar 2013, 13:38:22 »
Ich hab eine Änderung hochgeladen. Die kommt morgen mit dem Update.,
Guckt mal, ob der Fehler dann noch auftritt.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #10 am: 18 Januar 2013, 19:44:05 »
Ab wann wäre die Änderung morgen verfügbar?
Ich bekomme nämlich seit heute 08:16Uhr schon wieder:

MAXLAN_ExpectAnswer: Error while waiting for answer H:
MAXLAN_ReadSingleResponse: timeout while reading from socket
MAXLAN_ExpectAnswer: Error while waiting for answer M:
MAXLAN_ReadSingleResponse: timeout while reading from socket
MAXLAN_ReadSingleResponse: timeout while reading from socket
MAXLAN_ReadSingleResponse: timeout while reading from socket
...


und das Log füllt sich fleißig weiter mit
MAXLAN_ReadSingleResponse: timeout while reading from socket
und es ist jetzt 19:43Uhr.

Könnte das mit Deinem Update behoben werden?
Dann muss ich wohl die ganze FritzBox wieder neu starten, damit sich FHEM wieder berappelt, oder?
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #11 am: 20 Januar 2013, 11:28:26 »
Weiß nicht, wann die Updates verfügbar werden. Ich committe dir nur in Repository und irgendwann morgens werden die dann per fhem update verfügbar.
Die Fehlermeldungen kommen dann trotzdem noch, aber es sollte FHEM nicht mehr abstürzen.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #12 am: 20 Januar 2013, 13:13:43 »
Super, danke.
Ich habe FHEM aktualisiert. Ich werd's jetzt mal beobachten und mich noch einmal melden.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #13 am: 20 Januar 2013, 22:27:51 »
Es gibt noch immer:

2013.01.20 22:24:04 3: Opening ml device 192.168.1.21:62910
2013.01.20 22:24:04 3: ml device opened
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'WallThermostatConfig' - ignoring
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring


Ist das was Kritisches?
Und gerade war die gesamte FritzBox extrem langsam (inkl. FHEM Weboberfläche). Und nach ein paar Minuten hat sich die Box von allein neu gestartet. Komisch.
Konnte im Log aber nichts sehen.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #14 am: 20 Januar 2013, 22:31:20 »
Diese Meldungen
2013.01.20 22:24:04 3: Opening ml device 192.168.1.21:62910
2013.01.20 22:24:04 3: ml device opened
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'WallThermostatConfig' - ignoring
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring

tauchen im Minutentakt auf. Das lastet doch sicherlich unnötig aus, oder?

Außerdem gibt es immer mal wieder so etwas:

2013.01.20 13:59:23 1: MAX_01f4f1 is against deletion (HASH(0xedada8)), continuing with rereadcfg anyway
2013.01.20 13:59:23 1: MAX_011246 is against deletion (HASH(0x6f3eb0)), continuing with rereadcfg anyway
2013.01.20 13:59:23 1: MAX_006445 is against deletion (HASH(0x6f34b0)), continuing with rereadcfg anyway
2013.01.20 13:59:23 1: MAX_006d9b is against deletion (HASH(0x11ee7e8)), continuing with rereadcfg anyway
2013.01.20 13:59:23 1: MAX_0063be is against deletion (HASH(0x6f5740)), continuing with rereadcfg anyway


Ist das relevant?
Insgesamt habe ich das Gefühl, dass die MAX-Integration FHEM noch etwas instabil macht.


Zitat von: stobor schrieb am So, 20 Januar 2013 22:27
Es gibt noch immer:

2013.01.20 22:24:04 3: Opening ml device 192.168.1.21:62910
2013.01.20 22:24:04 3: ml device opened
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'WallThermostatConfig' - ignoring
2013.01.20 22:24:07 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring


Ist das was Kritisches?
Und gerade war die gesamte FritzBox extrem langsam (inkl. FHEM Weboberfläche). Und nach ein paar Minuten hat sich die Box von allein neu gestartet. Komisch.
Konnte im Log aber nichts sehen.

Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline ChrisW

  • Hero Member
  • *****
  • Beiträge: 1823
Aw: MAXLAN aufgehangen...
« Antwort #15 am: 22 Januar 2013, 08:06:26 »
Hallo,
heute morgen war mein FHEM auch abgestürzt letzer Log eintrag:
2013.01.22 02:39:37 3: ml device opened
2013.01.22 02:42:58 3: Opening ml device 192.168.2.22:62910
2013.01.22 02:42:58 3: ml device opened
2013.01.22 02:46:20 3: Opening ml device 192.168.2.22:62910
2013.01.22 02:46:20 3: ml device opened
2013.01.22 02:49:41 3: Opening ml device 192.168.2.22:62910
2013.01.22 02:49:41 3: ml device opened
2013.01.22 02:53:03 3: Opening ml device 192.168.2.22:62910
2013.01.22 02:53:03 3: ml device opened
2013.01.22 02:53:09 1: MAXLAN_ReadSingleResponse: timeout while reading from socket, disconnecting
2013.01.22 02:53:09 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
Raspberry PI3 mit allem möglichen.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #16 am: 22 Januar 2013, 11:10:41 »
Trotz des Updates von Matthias?
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline ChrisW

  • Hero Member
  • *****
  • Beiträge: 1823
Aw: MAXLAN aufgehangen...
« Antwort #17 am: 22 Januar 2013, 11:17:48 »
Da sist um 2:49 Nachts passiert. Letztes Update habe ich gestern gegen 11 Uhr gemacht.
Raspberry PI3 mit allem möglichen.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #18 am: 22 Januar 2013, 19:59:26 »
Warum wird eigentlich da sLog immer mit solchen Dingen vollgeknallt:

2013.01.22 19:52:15 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:15 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:16 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:17 2: Got message for undefined device, and failed to guess type from msg 'WallThermostatConfig' - ignoring
2013.01.22 19:52:17 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 19:52:17 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 19:52:17 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #19 am: 22 Januar 2013, 20:17:27 »
Könnte man nicht einfach unbekannte Devices ignorieren, um Systemlast zu sparen?
Ich habe das Gefühl, immer, wen MAX! in FHEM genutzt wird, reagiert FHEM deutlich langsamer.
Man sieht ja auch im Lag, dass das System mehrere sec. mit MAX! beschäftigt ist:
2013.01.22 20:11:08 3: Opening ml device 192.168.1.21:62910
2013.01.22 20:11:08 3: ml device opened
2013.01.22 20:11:12 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:12 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:12 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:12 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:13 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:14 2: Got message for undefined device, and failed to guess type from msg 'WallThermostatConfig' - ignoring
2013.01.22 20:11:14 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:14 2: Got message for undefined device, and failed to guess type from msg 'HeatingThermostatConfig' - ignoring
2013.01.22 20:11:14 2: Got message for undefined device, and failed to guess type from msg 'Error' - ignoring
2013.01.22 20:11:14 2: Got List response for undefined device with addr 008ab9
2013.01.22 20:11:14 2: Got List response for undefined device with addr 010358
2013.01.22 20:11:14 2: Got List response for undefined device with addr 007649
2013.01.22 20:11:14 2: Got List response for undefined device with addr 038f14
2013.01.22 20:11:14 2: Got List response for undefined device with addr 011246
2013.01.22 20:11:14 2: Got List response for undefined device with addr 009668
2013.01.22 20:11:14 2: Got List response for undefined device with addr 010e58
2013.01.22 20:11:14 2: Got List response for undefined device with addr 016ee4
2013.01.22 20:11:14 2: Got List response for undefined device with addr 038f2b


Ich habe jetzt nur noch die Cube und 8 Fensterkontakte definiert. Meine Thermostate sind nicht mehr in der fhem.cfg definiert:

define ml MAXLAN 192.168.1.21 60 ondemand
define MAX_00bd68 MAX Cube 00bd68
attr MAX_00bd68 alias Cube
attr MAX_00bd68 fm_name Cube
attr MAX_00bd68 room MAX
#define MAX_008ab9 MAX HeatingThermostat 008ab9
#attr MAX_008ab9 room MAX
define MAX_00701c MAX ShutterContact 00701c
attr MAX_00701c alias BadezimmerFenster
attr MAX_00701c fm_name BadezimmerFenster
attr MAX_00701c room MAX
...


Kommentiere ich generell alles MAX!-bezogene aus, läuft FHEM deutlich flüssiger.
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #20 am: 23 Januar 2013, 00:00:54 »
Wenn dir das hilft, dann kommentiere am besten MAX aus.
Ansonsten freue ich mich natürlich auch über Patches.

Offline stobor

  • Full Member
  • ***
  • Beiträge: 260
Aw: MAXLAN aufgehangen...
« Antwort #21 am: 23 Januar 2013, 06:32:46 »
Na ja, MAX wieder komplett rauszunehmen find ich nicht so toll. Ich möchte es ja schon gern nutzen. Liegt es vielleicht auch daran, dass fhem 1x pro Minute pollt?
Konnte man nicht auch MAX direkt per Funk abfragen (also ohne Cube)? Bzw. das fhem dem MAX Funkverkehr lauscht? Oder wurde/wird das wieder deaktiviert? Weiß jemand, wie das dann genau zu konfigurieren ist? Muss der CUL dafür noch verändert werden?
Intel NUC mit CUL V3.2 (Firmware 1.57 CUL868) für FS20 und CUL V3.4 (Firmware 1.57 CUL868) für HM
FS20: 1x PIRI-2, 6x PIRA, 9x ST-3, 2x DI-5, 2x HMS 100 TF, 1x FS20SM8, 1x FS20SI3
1x FS20SR, 1x FS20S20, 1x FS20S6A
HM: 1x CCU-2, 14x Fensterkontakte, 9x Heizkörperthermostate, 1x Wandthermostat

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #22 am: 24 Januar 2013, 00:22:12 »
Klar, per CUL gehts auch ohne Cube. Steht z.B. im Wiki. Das Modul dafür ist CUL_MAX.

Offline ChrisW

  • Hero Member
  • *****
  • Beiträge: 1823
Aw: MAXLAN aufgehangen...
« Antwort #23 am: 06 Februar 2013, 08:44:47 »
und heute morgen wieder im bad das Thermostat 15c Manuell ..
Denke es passietr hier durch:
2013.02.05 19:34:42 3: ml device opened
2013.02.05 19:34:45 1: MAXLAN_ReadSingleResponse: timeout while reading from socket, disconnecting
2013.02.05 19:34:45 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.02.05 19:34:47 3: Opening ml device 192.168.2.22:62910
2013.02.05 19:34:47 3: ml device opened


2013.02.06 00:26:52 1: MAXLAN_ReadSingleResponse: timeout while reading from socket, disconnecting
2013.02.06 00:26:52 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.02.06 00:26:54 3: Opening ml device 192.168.2.22:62910
2013.02.06 00:26:54 3: ml device opened
2013.02.06 00:28:35 3: Opening ml device 192.168.2.22:62910
2013.02.06 00:28:35 3: ml device opened


Er baut aber Zukünftig wie gewollt neue Verbindungen auf.Aber beim 1. mal um 19:34 schaut dann das Log was von Thermostat kommt schon komisch aus das ist NIE so ..

2013-02-05_17:37:27 MAX_Bad desiredTemperature: 24.0
2013-02-05_17:37:27 MAX_Bad valveposition: 100
2013-02-05_17:37:27 MAX_Bad 24.0 °C
2013-02-05_18:57:58 MAX_Bad mode: manual
2013-02-05_18:57:58 MAX_Bad desiredTemperature: 15.0
2013-02-05_18:57:58 MAX_Bad 15.0 °C
2013-02-05_19:01:27 MAX_Bad valveposition: 0
2013-02-05_19:01:27 MAX_Bad temperature: 24.5
2013-02-05_21:57:59 MAX_Bad valveposition: 9
2013-02-05_21:57:59 MAX_Bad temperature: 20.6
2013-02-05_22:33:30 MAX_Bad valveposition: 0
2013-02-05_22:33:30 MAX_Bad temperature: 21.8
2013-02-06_00:01:25 MAX_Bad valveposition: 9
2013-02-06_00:01:25 MAX_Bad temperature: 20.6
2013-02-06_00:37:04 MAX_Bad valveposition: 0
2013-02-06_00:37:04 MAX_Bad temperature: 21.5
2013-02-06_01:49:46 MAX_Bad valveposition: 9
2013-02-06_01:49:46 MAX_Bad temperature: 20.4
2013-02-06_02:33:44 MAX_Bad valveposition: 0
2013-02-06_02:33:44 MAX_Bad temperature: 21.5
2013-02-06_03:39:40 MAX_Bad valveposition: 9
2013-02-06_03:39:40 MAX_Bad temperature: 20.5
2013-02-06_04:37:10 MAX_Bad valveposition: 1
2013-02-06_04:37:10 MAX_Bad temperature: 21.3
2013-02-06_04:49:00 MAX_Bad valveposition: 0
2013-02-06_04:49:00 MAX_Bad temperature: 21.4
2013-02-06_05:39:44 MAX_Bad valveposition: 8
2013-02-06_05:39:44 MAX_Bad temperature: 20.4
2013-02-06_06:25:29 MAX_Bad valveposition: 0
2013-02-06_06:25:29 MAX_Bad temperature: 21.7
2013-02-06_06:30:33 MAX_Bad mode: auto
2013-02-06_06:30:33 MAX_Bad desiredTemperature: 30.0
2013-02-06_06:30:33 MAX_Bad valveposition: 100
2013-02-06_06:30:33 MAX_Bad temperature: 21.3
2013-02-06_06:30:33 MAX_Bad 30.0 °C
2013-02-06_07:25:12 MAX_Bad desiredTemperature: 14.0
2013-02-06_07:25:12 MAX_Bad valveposition: 0
2013-02-06_07:25:12 MAX_Bad temperature: 22.4
2013-02-06_07:25:12 MAX_Bad 14.0 °C
2013-02-06_07:56:31 MAX_Bad mode: manual
2013-02-06_07:58:35 MAX_Bad temperature: 21.4


Das komisch 7:56 habe ich ECO gesetzt !!! Aber er schreibt manual rein ?? Früher stand doch da immer ECO seit dem 30.1. aber nicht mehr ?? Verstehe da snicht es liegt nun 2-3 Tage alles rund jetz wieder so was wer soll das noch verstehen.
Raspberry PI3 mit allem möglichen.

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #24 am: 06 Februar 2013, 17:46:15 »
Da stand noch nie "eco", weil "eco" kein Modus, sondern eine Temperatur ist.

Offline ChrisW

  • Hero Member
  • *****
  • Beiträge: 1823
Aw: MAXLAN aufgehangen...
« Antwort #25 am: 06 Februar 2013, 19:29:45 »

2013-01-15_19:40:29 MAX_Bad desiredTemperature eco
2013-01-15_19:40:31 MAX_Bad 17.0 °C

So war es damals ;D
Raspberry PI3 mit allem möglichen.

Offline Matthias Gehre

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 707
Aw: MAXLAN aufgehangen...
« Antwort #26 am: 06 Februar 2013, 21:57:42 »
  2013-01-15_19:40:29 MAX_Bad desiredTemperature eco
ist kein Readings, sondern das Echo des Set-Befehls
  set MAX_Bad desiredTemperature eco

In "mode" stand wirklich noch nie "eco".

 

decade-submarginal