Autor Thema: Fehlersuche nanoCUL  (Gelesen 369 mal)

Offline Chillkroete1206

  • Jr. Member
  • **
  • Beiträge: 62
Fehlersuche nanoCUL
« am: 06 Mai 2019, 21:13:13 »
Hallo zusammen,

ich habe seit langem einen Selbstbau CUL mittels Ardurino und CC1101 868MHz im Einsatz. Hat alles soweit funktioniert, nur dass mir das ständige Abbrechen der Spiralantenne ziemlich auf die Nerven gegangen ist. Also habe ich eine SMA Buchse an einen neuen CC1101 gelötet und eine entsprechende Antenne mit relativ starker Richtwirkung angebracht. Neu geflasht habe ich nicht, da dies nach meinem Verständnis nicht notwendig ist.

Die ganzen Gerätschaften zeigen auch brav "Initialized", Kommandos an die Thermostate gehen aber trotzdem nicht durch und die Credits sind ständig verbraucht (was ja zusammenhängt, wie ich mir das denke).

Jetzt weiß ich nicht, an welcher Stelle ich suchen soll:
- Muss ich den Chip neu flashen? (Habe ich bisher vermieden, da nach meinem Verständnis nicht notwendig - passiver Chip und "Never change a running system!)
- Können die Lötkontankte fehlerhaft sein? Habe alles nach bestem Wissen und Gewissen überprüft. Durchgangsmessungen sind aber ja nicht an allen pins möglich.
- Liegt es ggf. an der Abstrahlrichtung der Antenne? Das nächste Thermostat ist aber nur 3m entfernt.

Im Event Monitor fällt folgendes auf:
2019-05-06 21:10:05 CUL_MAX cm packetsLost: 28023
Wäre super, wenn ihr einige Tipps zur Suche der Fehlerquelle hättet!

Danke und Gruß!

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3328
Antw:Fehlersuche nanoCUL
« Antwort #1 am: 06 Mai 2019, 23:20:12 »
So ganz verstehe ich nicht, was Du gemacht hast:
Zitat
ich habe seit langem einen Selbstbau CUL mittels Ardurino und CC1101 868MHz im Einsatz.
den musst Du natürlich nicht neu flashen.
Zitat
habe ich eine SMA Buchse an einen neuen CC1101 gelötet
Und den an den alten Arduino, oder wie ?  ???
Einen neuen Arduino müsstest Du halt auch neu flashen.

Ich denke, dass es an der Antenne(anschluss) liegt.
RPi3/2 Stretch-STV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)

Offline gloob

  • Hero Member
  • *****
  • Beiträge: 2736
Antw:Fehlersuche nanoCUL
« Antwort #2 am: 07 Mai 2019, 07:13:40 »
Ich denke er hat den CC1101 vom vorhanden nanoCUL entfernt und durch einen mit SMA Antennenanschluss ersetzt.
Die Firmware ist also weiterhin auf dem Arduino drauf. Sollte so also laufen.

Zeig doch bitte mal ein Bild von deinem Aufbau. Vielleicht sieht man dann mehr.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2199
  • Es begann alles so klein ;-)
Antw:Fehlersuche nanoCUL
« Antwort #3 am: 07 Mai 2019, 15:04:01 »
Gib dem cc1101 doch mal einen Werkstudent ;-)
set nanoCUL raw e
Damit die Initialen Register gesetzt werden.

Und ansonsten für uns ein Foto, dann Alternativ ist der mittlere der drei Pins des SMA Anschlusses nicht genug gelötet.

Gruß Arnd


Gesendet von iPhone mit Tapatalk
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline Chillkroete1206

  • Jr. Member
  • **
  • Beiträge: 62
Antw:Fehlersuche nanoCUL
« Antwort #4 am: 07 Mai 2019, 19:50:34 »
Hallo zusammen,

anbei die Bilder der Lötpunkte. Zugegeben: Das Werk keine Bewerbung eines professionellen Lötgenies, aber den Zugtest bestehen alle Verbindungen.
An die Antennenseite habe ich Stiftleisten angelötet und das Antennenkabel mit den Jumper-Kabeln zusammengelötet.

Ich verwende den alten (ehemals funktinierenden und geflashten) Arduino mit einem neuen CC1101 868MHz.

set nanoCUL raw e bringt keine merkbare Verbesserung.

Viele Grüße!

Offline Chillkroete1206

  • Jr. Member
  • **
  • Beiträge: 62
Antw:Fehlersuche nanoCUL
« Antwort #5 am: 07 Mai 2019, 19:52:41 »
Nächstes Bild

Offline Chillkroete1206

  • Jr. Member
  • **
  • Beiträge: 62
Antw:Fehlersuche nanoCUL
« Antwort #6 am: 07 Mai 2019, 19:53:21 »
Letztes Bild.

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2199
  • Es begann alles so klein ;-)
Antw:Fehlersuche nanoCUL
« Antwort #7 am: 07 Mai 2019, 20:15:12 »
Hi,
Na dann wundert mich nichts ;-)

Alles ist Deine Antenne! Und damit ist die Antenne verstimmt, wie eine zu lange Blöckflöte. Beginnend ab dem cc1101 ist das Jumperkabel am „strahlen“ und bis zum Ende der richtigen Antenne!
Nimm ein PCB und baue es darauf auf.
So wie hier:
(https://uploads.tapatalk-cdn.com/20190507/9e216d8685c4451bd67d48f0fa383472.jpg)
(https://uploads.tapatalk-cdn.com/20190507/8d88b274b4be44719abdbda576090ace.jpg)
Soll ich Dir eins für den SMD cc1101 zusenden?

Gruß Arnd


Gesendet von iPhone mit Tapatalk
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline gloob

  • Hero Member
  • *****
  • Beiträge: 2736
Antw:Fehlersuche nanoCUL
« Antwort #8 am: 07 Mai 2019, 20:49:45 »
Und wieder zeigt sich, Bilder sagen mehr als 1000 Worte.

Du kannst das Coax-Kabel auch direkt an den CC1101 anlöten, dann brauchst du nicht umbedingt eine Adapterplatine.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline Chillkroete1206

  • Jr. Member
  • **
  • Beiträge: 62
Antw:Fehlersuche nanoCUL
« Antwort #9 am: 07 Mai 2019, 21:04:09 »
Je mehr ich drüber nachdenke, desto mehr Sinn ergibt das ;)

Das Dranlöten des Coax-Kabels geht bestimmt schief, das war schon eine tierische Frickelei das an die Jumperkabel zu bekommen :)

Soll ich Dir eins für den SMD cc1101 zusenden?

Wenn du so ein Ding zuhause rumfiegen hast und das Verschicken keinen Stress ist, nehme ich das gerne. Ansonsten kann ich die Dinger ja auch für ein paar Euro bei einschlägigen Shops bestellen. Ich bräuchte für meine Antenne allerdings eine SMA Buchse, hast du die auch da?

Beste Grüße!

 

decade-submarginal