Autor Thema: FHZ1300/USB instabil im RasPi Container  (Gelesen 1447 mal)

Offline Mickey Mouse

  • Full Member
  • ***
  • Beiträge: 155
FHZ1300/USB instabil im RasPi Container
« am: 12 Mai 2019, 12:45:15 »
vorneweg: ich weiß nicht, ob ich hier richtig bin, bitte entsprechend verschieben

seitdem ich meinen RasPi3 neu aufgesetzt und FHEM in einem Docker Container laufen habe, funktioniert die FHZ1300 nicht mehr richtig :(

das log ist voll mit:
2019.05.12 12:28:38 1: USB device /dev/ttyUSB0 disconnected, waiting to reappear
2019.05.12 12:28:43 1: USB device /dev/ttyUSB0 reappeared
2019.05.12 12:28:45 1: USB device /dev/ttyUSB0 disconnected, waiting to reappear
2019.05.12 12:28:50 1: USB device /dev/ttyUSB0 reappeared
2019.05.12 12:28:52 1: USB device /dev/ttyUSB0 disconnected, waiting to reappear
2019.05.12 12:28:57 1: USB device /dev/ttyUSB0 reappeared
2019.05.12 12:28:59 1: USB device /dev/ttyUSB0 disconnected, waiting to reappear
2019.05.12 12:29:04 1: USB device /dev/ttyUSB0 reappeared
2019.05.12 12:29:06 1: USB device /dev/ttyUSB0 disconnected, waiting to reappear
...

getestet mit 2 verschiedenen RasPis und 2 Netzteilen. "Nativ" funktioniert alles, im Container s.o.
Unterschied ist: das Image mit Docker boote ich von USB Stick, das "native" von SD Karte.
als Basis Image im Container läuft "fhem/fhem:latest" und als Basis dient das aktuelle "Raspbian GNU/Linux 9 (stretch)"

alles was ich zu diesem Thema gefunden habe, passt nicht so richtig zu meinem Problem (keine "sporadischen" Aussetzer, sondern "ständig")
das lustige ist, in den jeweils 2s zwischen dem "disconnected" und "reappeared" funktioniert es, es dauert nur alles etwas...
über Nacht hat autocreate alls gefunden was in das Muster passt: all HMS und FHTs und auch die FS20 Devices, die häufiger mal laut von sich geben (z.B. Bewegungsmelder).

irgendwelche Idee?

Offline Mickey Mouse

  • Full Member
  • ***
  • Beiträge: 155
Antw:FHZ1300/USB instabil im RasPi Container
« Antwort #1 am: 12 Mai 2019, 13:17:00 »
ich glaube, das Thema kann gelöscht werden, aber falls es jemanden interessiert:

autocreate scheint schon eine FHZ_0 erstellt zu haben und ich habe manuell "meine" FHZ_1 (ebenfalls auf ttyUSB0) definiert.
Automatismus ist schön, man muss aber auch daran denken ;)

 

decade-submarginal