Autor Thema: #gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr  (Gelesen 846 mal)

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5478
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #15 am: 17 Mai 2019, 09:45:10 »
Wobei der Output von netstat schon gepostet hatte (habe es übersehen) und dort auch fhem läuft ... irgendetwas blockiert das System. Deshalb ... wirklich mal iptables aufrufen ...

OT
@KolnSolar:
netstat kann noch viieiel mehr, aber jeder Admin merkt sich so "die eine Wichtige Schalterstellung" ... bei mir eben lntp.
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 90
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #16 am: 17 Mai 2019, 10:21:18 »
Hallo,

Grund für:
Zitat
schmeiß doch bitte noch mal pihole runter und mach dann den netstat -lntp nochmal
ist,
MichaelO hat noch mehrere Dinge installiert wie owhttpd - 1-Wire Webserver.
Ich weis aber nicht ob der auf lighttpd aufdetzt, kann dazu nichts finden.
Wäre auch Interessant was auf Port 8088 , 8181 läuft. vielleicht gibts noch einen proxy oder so.
Ist aber alles nur Glaskugel...
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5478
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #17 am: 17 Mai 2019, 10:40:07 »
Mann könnte anhand der PID rausfinden, welches Programm sich hinter den Ports befindet.

z.B.
tcp        0      0 0.0.0.0:8083            0.0.0.0:*               LISTEN      910/perDann würde ergeben:
ps aux | grep 910
das dahinter fhem läuft ....

P.S. ps kann auch selber nach PIDs filtern, ich finde die Ausgabe nur nicht so "schön":
ps u -p 910
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline MichaelO

  • Full Member
  • ***
  • Beiträge: 316
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #18 am: 17 Mai 2019, 17:35:59 »
So, wieder zu Hause. Erstmal danke für die vielen Antworten soweit.

iptables -L auf dem pi mit deinstalliertem pihole (also dem, auf dem fhem jetzt läuft)

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Der gleiche Output kommt auch auf dem zweiten pi, auf dem pihole jetzt läuft.

netstat auf dem pi mit fhem

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:4711            0.0.0.0:*               LISTEN      924/perl       
tcp        0      0 0.0.0.0:2120            0.0.0.0:*               LISTEN      707/owftpd     
tcp        0      0 127.0.0.1:42281         0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:2121            0.0.0.0:*               LISTEN      700/owhttpd     
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      848/smbd       
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      597/lighttpd   
tcp        0      0 0.0.0.0:4304            0.0.0.0:*               LISTEN      509/owserver   
tcp        0      0 0.0.0.0:8083            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:8084            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:8181            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:8085            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      477/sshd       
tcp        0      0 0.0.0.0:36727           0.0.0.0:*               LISTEN      924/perl       
tcp        0      0 0.0.0.0:43479           0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:33625           0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      805/exim4       
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      848/smbd       
tcp        0      0 0.0.0.0:7072            0.0.0.0:*               LISTEN      815/perl       
tcp        0      0 0.0.0.0:45477           0.0.0.0:*               LISTEN      924/perl       
tcp6       0      0 :::139                  :::*                    LISTEN      848/smbd       
tcp6       0      0 :::80                   :::*                    LISTEN      597/lighttpd   
tcp6       0      0 :::22                   :::*                    LISTEN      477/sshd       
tcp6       0      0 ::1:25                  :::*                    LISTEN      805/exim4       
tcp6       0      0 :::445                  :::*                    LISTEN      848/smbd

und auf dem mit pihole

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      520/pihole-FTL     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      403/sshd           
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      520/pihole-FTL     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      430/lighttpd       
tcp6       0      0 :::53                   :::*                    LISTEN      520/pihole-FTL     
tcp6       0      0 :::22                   :::*                    LISTEN      403/sshd           
tcp6       0      0 ::1:4711                :::*                    LISTEN      520/pihole-FTL     
tcp6       0      0 :::80                   :::*                    LISTEN      430/lighttpd

Hilft das schon weiter? Wie gesagt hab ich lighttpd auf dem pi mit fhem nicht deinstalliert, nachdem während pihole-uninstall fhem plötzlich wieder lief. Das war meiner Meinung nach aber vorher nicht drauf und wurde durch pihole mit installiert. Anscheinend schadet es aber keinem anderen Prozess.
« Letzte Änderung: 17 Mai 2019, 17:38:20 von MichaelO »

Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 90
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #19 am: 17 Mai 2019, 21:17:09 »
Hallo,

Was läuft denn da jetzt von Perl aus auf Port 4711 ?
Wenn pihole installiert ist, läuft auf dem Port zwingend die FTL und scheint die jetzige laufende Anwendung wegzudrücken....
Mach mal
ps aux | grep 924
Oder
ps u -p 924
Und suche mal in diese Richtung...
Da der lighttpd auf Port 80 noch läuft kannst du auch zusätzlich mal einen Browser nehmen
und die Seite  http://ipdesrpi   aufrufen und schauen ob sich hier noch was meldet...

MfG
« Letzte Änderung: 18 Mai 2019, 12:35:31 von my-engel »
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

Offline MichaelO

  • Full Member
  • ***
  • Beiträge: 316
Antw:FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #20 am: 18 Mai 2019, 10:48:10 »
Na das ist ja interessant... was man da so alles rausfinden kann  :o

fhem       924  2.2  5.4  92264 51960 ?        Sl   Mai16  53:58 /usr/bin/perl ./FHEM/00_SONOS.pm 4711 0 0 startedbyfhem
pi       17860  0.0  0.1   4292  1856 pts/0    S+   10:11   0:00 grep --color=auto 924

Port 80 liefert nur ein 404 not found.

Ich habe das Sonos-Device dann auf Port 4712 gelegt, fhem neu gestartet und testweise pihole installiert. Jetzt läuft beides parallel und ohne Probleme  ;D

1000 Dank für die Hilfe, ich hatte mir das mit den Ports fast gedacht, aber leider keine Ahnung, wie man bei der Fehlersuche vorgeht. Mal sehen, ob ich den Hinweis irgendwie ins Sonos-Wiki bekomme. Es könnte ja durchaus auch andere betreffen, und die "Anleitung" erstellt das Sonos-Device immer auf 4711.

Nochmals danke  8)

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3496
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #21 am: 18 Mai 2019, 11:26:46 »
Zitat
Na das ist ja interessant... was man da so alles rausfinden kann  :o
Wohl wahr.  :) Daher nochmal meinerseits eine OT-Frage:
Auf diesen Port kann ich mir keinen Reim machen
tcp        0      0 127.0.0.1:34513         0.0.0.0:*               LISTEN      569/perl

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
fhem       569 30.3 11.8 121428 112592 ?       R    May10 3541:51 perl fhem.pl fhem.cfg
Hat dazu noch jemand eine Idee, wie ich das "Lauschermodul"/device identifizieren kann ?
Grüße Markus
RPi3/2 Stretch-STV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)

Offline reibuehl

  • Sr. Member
  • ****
  • Beiträge: 633
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #22 am: 18 Mai 2019, 13:20:38 »
Laut dem Beitrag https://forum.fhem.de/index.php/topic,10033.msg299199.html#msg299199 scheint der Port 34513 auch irgendwie mit dem Sonos Modul zusammenzuhängen.
Reiner.

Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 90
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #23 am: 18 Mai 2019, 15:40:53 »
Hall Markus

da bin ich jetzt auch überfragt aber mit:
lsof -i | grep -e LISTENoder
lsof -n -i | grep 34513bekommst du noch heraus welcher Benutzer / Partner dies ausgelöst hat.
Die Ausgabe ist dann sortiert nach:
COMMAND     PID        USER   FD   TYPE  DEVICE SIZE/OFF NODE NAME

die 127.0.0.1 bedeutet aber das es eine interne Abfrage ist (wie es auch zB ein SQL tut) halt aber auf einem anderen Port

MfG
Uwe
« Letzte Änderung: 18 Mai 2019, 15:58:39 von my-engel »
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3496
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #24 am: 20 Mai 2019, 09:44:36 »
Danke Euch beiden,
leider funktioniert lsof bei mir und stretch nicht. Allerdings weiß ich ja schon, dass es von fhem genutzt/ausgelöst ist.

SONOS habe ich nicht im Einsatz. Wohl aber den DLNA_Renderer, der die selbe UPnP-Lib benutzt. Und da hab ich tatsächlich noch ein device, das möglicherweise einen offenen Port hat. Da gucke ich mal.

Zitat
die 127.0.0.1 bedeutet aber das es eine interne Abfrage ist (wie es auch zB ein SQL tut) halt aber auf einem anderen Port
Da kommt mir zumindest nichts in den Sinn, was ich "intern" hätte.
Alexa/echodevice ?
Grüße Markus
RPi3/2 Stretch-STV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5478
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #25 am: 20 Mai 2019, 11:30:15 »
lsof funktioniert nicht?

Hat Nix mit Debian/Ubuntu oder sonstigen Distris/Versionen zu tuen. Wenn es nicht läuft, hast Du ein Grunbsätzliches heftiges Problem (oder nicht mit root-Rechten Probiert)
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3496
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #26 am: 20 Mai 2019, 16:38:09 »
Zitat
Hat Nix mit Debian/Ubuntu oder sonstigen Distris/Versionen zu tuen. Wenn es nicht läuft, hast Du ein Grunbsätzliches heftiges Problem (oder nicht mit root-Rechten Probiert)
Hmm, hab dann jetzt mal tiefer geguckt. Das Paket lsof ist nicht installiert. Aber auch ein apt-get dist-upgrade will es mir nicht (automatisch) installieren. Mit apt-get install kann ich es nachinstallieren. Heftige Probleme sehe ich daher nicht...

Ich habe jetzt rausgefunden, wo der unbekannte Port herkommt: steht im Log nach jedem restart: ::)
2019.05.20 13:59:13 3: telnetForBlockingFn_1558353553: port 34513 openedDie Port-Nr. ist generisch, also bei jedem Neustart anders. Erklärt hat André die Meldung(und damit die Herkunft des Ports) hier
RPi3/2 Stretch-STV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5478
Antw:#gelöst# FHEM und pihole... kein Zugriff auf fhemweb mehr
« Antwort #27 am: 20 Mai 2019, 21:28:37 »
O.K."nicht installiert" ist eine andere Aussage als "funktioniert nicht" ...

Viele Standardinstallationen (egal ob Debian, Ubuntu oder andere Distri), installieren heute Basis-Tools für Serveranalyse nicht mehr.
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html