Autor Thema: Attribute, die XML-Tags enthalten, blockieren die weitere Anzeige in FHEMWEB  (Gelesen 1552 mal)

Offline Reinerlein

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2030
Hallo zusammen,

ich mal wieder :-)
Ich habe bei meinen Devices ein Attribut, welches als Inhalt XML-ähnliche Tags verwendet. Das funktioniert auch alles soweit ganz gut. Die Definition in der Datei und die Ausführung von FHEM selbst haben damit keine Probleme.

Nur die Weboberfläche zeigt "nach" dem ersten solchen Attribut nichts mehr weiter an. Normalerweise werden da ja noch diese "Probably associated with"-Sachen angezeigt. Diese sehe ich dort dann nicht mehr, auch nicht mehr den Link zum Löschen des Attributs, sowie noch nicht mal den Inhalt des Attributs (wird wahrscheinlich vom Browser als HTML interpretiert und dann nicht dargestellt).

Nachvollziehen kann man das an folgendem kurzen Beispiel.

Dieses Attribut läuft problemlos:
attr WEB comment <Title></Title>

Dieses Attribut verursacht das beschriebene Problem:
attr WEB comment <Title />

Leider benutze ich beide Schreibweisen, damit das Attribut am Ende nicht aus allen Nähten platzt (Ausserdem habe ich keinen kompletten XML-Parser gebaut, sondern verwende der Einfachheit halber nur diese Notation)

Kann man da in FHEMWEB etwas anpassen, damit er bei der Ausgabe nicht aufhört?
Danke schon mal...

Grüße Reinerlein

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21227
Habs gefixed, jetzt werden solche Daten in FHEMWEB sogar angezeigt, und man damit weniger Unsinn treiben :)

 

decade-submarginal