Autor Thema: deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update  (Gelesen 601 mal)

Offline Christian80

  • New Member
  • *
  • Beiträge: 6
Hallo zusammen,

ich betreibe einen deCONZ Stick mit FHEM und einigen Xiaomi Temperatursensoren und Bewegungsmeldern.

Am 30.05. habe ich ein Update gemacht mit nachfolgenden Versionen:

deCONZ
30_HUEBridge.pm:0.194780/2019-05-28

Xiaomi Temp Sensor / Xiaomi Bewegungsmelder
31_HUEDevice.pm:0.194840/2019-05-29


Seitdem habe ich folgende Probleme:
1) Die Temperatursensoren senden keine Temperaturen an FHEM
2) Die Bewegungsmelder senden keine Helligkeitswerte an FHEM, motion funktioniert weiterhin.

Im deCONZ Gateway werden alle Daten aktualisiert. Also liegt das Problem an FHEM bzw. dem letzten FHEM Update!?

Ich habe einen Temperatursensor gelöscht und neu angelegt. Das Problem konnte dadurch allerdings nicht gelöst werden

Danke und schöne Grüße
Christian

Offline cyablo

  • Jr. Member
  • **
  • Beiträge: 66
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #1 am: 01 Juni 2019, 23:01:07 »
Ist bei Hue Bewegungsmeldern am Hue Gateway leider das gleiche Problem.

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 20721
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #2 am: 02 Juni 2019, 07:52:45 »
Da die zuständigen Module im Beleuchtungs Forum besprochen werden, schlage ich vor den Thread dahin zu verschieben. Das Problem ist bekannt.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://www.paypal.me/MOldenburg
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6356
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #3 am: 02 Juni 2019, 08:22:14 »
Da die zuständigen Module im Beleuchtungs Forum besprochen werden, schlage ich vor den Thread dahin zu verschieben. Das Problem ist bekannt.
Laut https://fhem.de/MAINTAINER.txt ist für 30_HUEBridge.pm und 31_HUEDevice.pm das richtige Board "Zigbee"; damit kein Grund zum Verschieben.

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 20721
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #4 am: 02 Juni 2019, 08:38:54 »
Guten Morgen Christian,

So ein Mist Du hast Recht. Ich war da noch auf einem sehr alten Wissensstand. Danke Dir.
Dann verschieben ich meines mal.


Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://www.paypal.me/MOldenburg
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer

Offline Xaser

  • New Member
  • *
  • Beiträge: 38
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #5 am: 03 Juni 2019, 21:08:38 »
Der Fehler ist bei mir auch.

Offline hdk

  • Newbie
  • Beiträge: 1
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #6 am: 03 Juni 2019, 23:33:44 »
Au fein ... dann wird das bestimmt bald wieder besser.

Bei mir aktualisiert es nur die Licht-Daten (dark, daylight, lightlevel, lux) nicht.

VG,
H.

Offline fiesta-tuner

  • New Member
  • *
  • Beiträge: 4
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #7 am: 05 Juni 2019, 21:12:54 »
Bei mir gibt es gar keine Readings, jemand ne Idee?
Gruß Jan

Offline binford6000

  • Tester
  • Sr. Member
  • ****
  • Beiträge: 851
  • 🏠⚙️💡🛠📱
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #8 am: 05 Juni 2019, 21:29:31 »
FHEM 5.9 in Proxmox-LXC, IOserver für deconz sowie für alle CULs via ser2net, Testumgebung: docker pull fhem/fhem
Homematic, EnOcean, IT, HUE + Nanoleaf Aurora, SONOS, alexa-fhem, homebridge, TelegramBot mit msgDialog, livetracking

Offline fiesta-tuner

  • New Member
  • *
  • Beiträge: 4
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #9 am: 05 Juni 2019, 21:45:17 »
Dasist Super  ;D
Danke
Gruß Jan

Offline flummy1978

  • Jr. Member
  • **
  • Beiträge: 64
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #10 am: 12 Juni 2019, 02:36:49 »
Holla,

ich kann mir fast nicht vorstellen, dass ich der Einzige bin, der davon noch betroffen ist, dass das trotz Update immernoch nicht geht ? *grübel*  ??? :o
Ich hatte die letzten Tage wenig Gelegenheit mich um die Bewegungsmelder zu kümmern, daher weiss ich nicht seit wann das so ist (Update hab ich grad noch mal gezogen)

Bei mir geht es in erster Linie um XIAOMI Bewegungssensoren.... Diese liefern seit ein paar Tagen sehr sehr unzuverlässige Werte. Wenn ich mich vor dem Sensor bewege / ihn aktiviere, wird Helligkeit sofort generiert (sogar mehrmals während der Bewegung hin und her) aber die Bewegungserkennung funktioniert wie sie lustig ist. Mal geht es beim ersten mal direkt, dann wiederum 10 mal hintereinander nicht ( ja ich weiss, sie haben eine totzeit - Ich hab von den Sensoren ja einige in Betrieb sie funktionierten auch soweit einwandfrei .... Nur jetzt eben nicht.

Vielleicht hat jemand Tipps für  mich wie ich mich da rantasten kann, woran es liegt ;(

Edith hat noch einen Nachtrag:

Ich hab auch teilweise das Gefühl, dass das Device normal bearbeitet wird, aber das Reading bleibt nicht bei der Änderung. Beispiel:

illuminance  1  2019-06-12 02:38:11
linkquality 23   2019-06-12 02:38:11
occupancy  false  2019-06-12 02:38:11

Also als ich mal die Hand davor gehalten habe, hat er die Helligkeit mit 1 angezeigt, linkquality ist klar, aber auch occupancy wurde scheinbar geschrieben, ohne dass sich der Zustand geändert hat, weil die Zeit ja die Gleiche ist *verwirrtguck*

Vielen Dank im Voraus
Grüße
Andreas
« Letzte Änderung: 12 Juni 2019, 02:42:12 von flummy1978 »

Offline flummy1978

  • Jr. Member
  • **
  • Beiträge: 64
Antw:deCONZ: keine Werte von Xiaomi Sensoren nach FHEM Update
« Antwort #11 am: 12 Juni 2019, 10:58:36 »
Das hat mir nach der Nacht natürlich keine Ruhe gelassen:

Alle Bewegungsmelder die Standardmäßig eingebunden sind, funktionieren einwandfrei. Aber laut zigbee2MQTT kann man für einige Geräte die Config anpassen. Das habe ich bei 2 Bewegungsmeldern gemacht (einen im Flur auf 70 Sek und einen modifiziertern, der dann auch Bewegungen unter 60 Sek erkennt - Was ja grundsätzlich auch geht, sonst würde der das Event für Helligkeit ja nicht jedes mal senden, wenn man sich nach 20 Sek noch mal um den Sensor bewegt)

Flur:
  'xxxxxx':
    friendly_name: 'xxxxxx'
    retain: false
    occupancy_timeout: 70
    no_occupancy_since:
      - 10
      - 60
TestPIR:
  'xxxxx':
    friendly_name: 'xxxx'
    occupancy_timeout: 20
    no_occupancy_since: [10, 20]

Genau diese beiden Bewegungsmelder funktionieren eben nicht mehr (zuverlässig).  Dummerweise führt auch ein verlernen, neu Anlernen oder löschen dieser Option nicht dazu, dass diese wieder einwandfrei funktionieren ;(

Wäre nett, wenn sich das jemand anschauen könnte ... oder mir sagt, wie ich es ggf selbst beheben kann  ;)

Grüße
Andreas