FHEM - Hausautomations-Systeme > Homematic

Rolladen auf x% setzen

(1/2) > >>

bugster_de:
Hallo,

zuerst mal guten Tag. Ich bin Neuling bei FHEM und finde wirklich klasse, was das Ding kann !

Allerdings blicke ich es als Neuling grad nicht und hoffe ihr könnt mir helfen:

mein Setup:
fhem auf der Fritzbox 7390 mit HM-LAN
mehrere HM-LC-Bl1PBU-FM Unterputz Rolladenaktoren hinter der Jung ST550 Schalterserie

Alle Rolläden kann ich per FHEM schalten und sie fahren zeitgesteuert abends zu und morgens wieder auf. Perfekt !
Nun möchte ich aber, dass im Schlafzimmer der Rolladen nicht komplett zu macht sondern nur zur Hälfte. Sprich er soll zeitgesteuert abends ca. 50% schliessen. Und genau das geht nicht.

In den Aktoren sind standardmässig 50 sec Schaltzeit einprogrammiert. Die 50% beziehen sich demnach dann wohl auf 50% der Schaltzeit sprich 25 sec. Meine Rolladen laufen aber nur 33 sec von auf bis zu. Somit läuft die Soll- und die reale Ist-Position nach ein paar Schaltvorgängen auseinander und 50% sind dann halt irgendwas aber nix definiertes. Ich hoffe ihr versteht was ich meine?

Mittels der Homematic Konfog Software kann ich zwar die Laufzeit verändern, aber zum Wieder Pairen mit der FHEM muß ich die Aktoren resetten und dann sind sie wieder auf 50 sec.

Deshalb meine Frage, wie ich das lösen kann
- kann ich den Sollwert des Aktors auch per FHEM setzen? Und wenn ja wie?
- oder kann ich per Homematic SW den Wert setzen und wieder mit FHEM pairen OHNE zu resetten? Wie wäre hier der Ablauf?

Danke und viele Grüße
Markus

MisterEltako:
Hi!

Stand zuletzt vor dem selben Problem, aber dank der Fhem-Community wurde mir schnell geholfen:

Stopp die Zeiten die dein Rollladen für Auf und Zu jeweils brauch. Dann gibst du einmalig in der Kommandozeile nachfolgende
Zeilen mit deinen gemessenen Zeiten ein.

set <Aktorname> regSet driveDown 33
set <Aktorname> regSet driveUp 35
set <Aktorname> regSet driveTurn 0

Dann kommen 50% in etwa hin.
Als Empfehlung Rollladen nie mit "on" zufahren lassen sondern mit "1%", sonst ist 50% an anderer Position, wenn Rollladen von "oben" kommt, als wenn er von "unten" kommt.

MfG, MisterEltako

bugster_de:
Hi,

Danke für die schnelle Antwort. Mit den Befehlen hatte ich gestern auch schon rumproboiert. War jetzt aber auf Grund deinr Antwort scwer motiviert und habe es nochmal probiert. Geht nicht. Eher per Zufall scheine ich das Problem nun aber einkreisen zu können. Der Rolladen läuft z.B. nach unten 30 sec. Interessanterweise scheint er diese Zeiten zwar anzunehmen aber immer mit einem kleinen Offset zu versehen. Der Rolladen fährt z.B. runter und sobald er ganz zugefahren ist (was er nicht soll) hört man den Homematic Schalter ca. 5 sec danach klackern (sprich das Relais fällt ab).

Nun habe ich spasseshalber den Wert für die Laufzeit mal deutlich zu klein gewählt (15 sec). Es zeigt sich keine Veränderung. Wenn ich den Wert aber größer mache, dann wird die Zeit, bis das Relais abfällt wieder länger. Scheint also so zu sein, dass FHEM den Parameter zwar setzen kann, es aber eine untere Grenze gibt, unter der das Modul die Werte nicht annimmt. Kann das sein?

VG

bugster_de:
ach so: woran sehe ich eigentlich ob der Befehl erfolgreich abgesetzt wurde? Sobald ich das Register setze und save drücke geht FHEM in den Startbildschirm (alles leer). Auch im Log File ist nichts drin.

martinp876:
Hallo Markus,

die Daten (register) werden im device gespeichert, nicht in FHEM. FHEM hat nur eine kopie. Um die 'kopie" zu erstellen must du lesen gehen:

set <dev> getConfig

nun hast du die kopie - jetzt willst du die lesen also

get <dev> reg all

ein "save" nutzt dir nichts, da dies nur die FHEM settings speichert.
Du kannst - nach dem erstellen einer kopie - die Daten eines Device mit
get <dev> saveConfig <filemane> speichern

Gruss
Martin

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln