Autor Thema: Tradfri: Weißspektrum-Leuchtmittel lässt die Farbtemperatur nicht auslesen  (Gelesen 1080 mal)

Offline Yokohama

  • New Member
  • *
  • Beiträge: 7
Ein nächtlicher Gruß in die Runde.

Ich habe mir vor einer Woche sechs Weißspektrum-E27-Leuchtmittel bei Ikea gekauft, alle mit der modelid "TRADFRI bulb E27 WS opal 1000lm". Ich habe FHEM auf einem Raspberry Pi laufen und diese Leuchtmittel mittels eines ConBee-USB-Sticks von Dresden Elektronik (Phoscon) eingebunden.

Drei von diesen Leuchtmitteln geben in ihren READINGS "colormode": "ct" an, die anderen drei "colormode": "xy". Alle sechs lassen sich per "set device color" und "set device bri" in der Farbtemperatur und Helligkeit steuern. Soweit, so gut.

Die drei Exemplare mit "colormode": "xy" lassen sich allerdings nicht bezüglich der Farbtemperatur auslesen. Unabhängig von der gerade eingestellten Farbtemperatur geben sie stets ein "rgb": "000000" und ein "ct": "370 (2702K)" zurück, eine Ausgabe des Wertepaares "xy" wie z.B. hier https://dresden-elektronik.github.io/deconz-rest-doc/lights/#getall aufgezeigt, erfolgt nicht. Auf gut Deutsch: Die Farbtemperatur dieser drei Leuchtmittel lässt sich wie bei den übrigen drei setzen, aber nicht auslesen. Auch "ph get /lights" auf der Konsole bringt bei den betroffenen Leuchtmitteln keine weiteren Erkenntnisse.

Ich habe stark den colormode als Schuldigen in Verdacht, habe aber nach bisherigen Recherchen den Eindruck, dass sich dieser nicht verändern lässt. Oder sehe ich das falsch? Und wenn das so ist, kann ich dann wenigstens irgendwie das "xy"-Wertepaar auslesen? Dann könnte ich das ja ggfls. umrechnen.

Hat jemand eine Idee?