Autor Thema: Probleme beim DOIF mit dem Reading Sonos  (Gelesen 202 mal)

Offline Abercrombie1892

  • Full Member
  • ***
  • Beiträge: 162
Probleme beim DOIF mit dem Reading Sonos
« am: 23 Juli 2019, 23:06:18 »
Hallo,

ich muss mir ein DOIF basteln, womit ich bei meinem Receiver die Soundeinstellungen umschalten muss, jenachdem ob der Sonos Connect alleine läuft oder im Multiroombetrieb

([Sonos_Wohnzimmer:ZoneGroupNameDetails] ne "+ Küche/+ Bad/+ Schlafzimmer") (set WZDENON surroundMode Multichannel_Stereo)
##
DOELSEIF
([Sonos_Wohnzimmer:ZoneGroupNameDetails] eq "+ Küche/+ Bad/+ Schlafzimmer") (set WZDENON surroundMode Auto)

Als Reading kommt, wenn Wohnzimmer alleine spielt kein Reading bei ZoneGroupNameDetails, wenn nun eine Gruppe erstellt wird kommen halt die entsprechenden Raumnamen dazu.
Wenn Wohnzimmer der Master ist, steht immer ein + vor jedem Raumnamen der dazu kommt.


Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 13836
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:Probleme beim DOIF mit dem Reading Sonos
« Antwort #1 am: 23 Juli 2019, 23:17:25 »
Hi,

Und was genau ist Deine Frage?

Ich denke man muss es so in der Art machen:
([Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Bad" and [Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Küche" and [Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Schlafzimmer") (set WZDENON surroundMode Multichannel_Stereo) DOELSE (set WZDENON surroundMode Auto)
oder wolltest Du es einfach so?
([Sonos_Wohnzimmer:ZoneGroupNameDetails] ne "") (set WZDENON surroundMode Multichannel_Stereo) DOELSE (set WZDENON surroundMode Auto)

Gruß Otto
« Letzte Änderung: 24 Juli 2019, 00:06:25 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline Abercrombie1892

  • Full Member
  • ***
  • Beiträge: 162
Antw:Probleme beim DOIF mit dem Reading Sonos
« Antwort #2 am: 24 Juli 2019, 14:43:48 »
Hi,

Und was genau ist Deine Frage?

Ich denke man muss es so in der Art machen:
([Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Bad" and [Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Küche" and [Sonos_Wohnzimmer:ZoneGroupNameDetails] =~ "Schlafzimmer") (set WZDENON surroundMode Multichannel_Stereo) DOELSE (set WZDENON surroundMode Auto)
oder wolltest Du es einfach so?
([Sonos_Wohnzimmer:ZoneGroupNameDetails] ne "") (set WZDENON surroundMode Multichannel_Stereo) DOELSE (set WZDENON surroundMode Auto)

Gruß Otto

Vielen Vielen Dank

das untere funktioniert bestens bei mir und schaltet nun sauber durch. Damit hab ich dann keine Latenz im Multiroombetrieb.