Autor Thema: [gelöst] Problem mit ZWave FIBARO System FGBS222 Smart Implant  (Gelesen 7040 mal)

Offline jhs

  • Jr. Member
  • **
  • Beiträge: 76
Hallo,
ich habe Probleme mit der Konfiguration eines Fibaro-Sensors in unterschiedlichen Bauformen, speziell mit dem Auslesen der Readings (2x Kontakte und 1x Temperatur )

[size=8pt]# www.fibaro.com/de/products/smart-implant/
model FIBARO System FGBS222 Smart Implant
modelConfig fibaro/fgbs222.xml
modelId 010f-0502-1000[/size]


Dieses Modul ist wohl als compatible+NewFeatures Nachfolger (?) des bisherigen UNIVERSAL BINARY SENSOR FGBS-321 zu sehen.
model FIBARO System FGBS001 Universal Binary Sensor
modelConfig fibaro/fgbs001.xml
modelId 010f-0501-1002

Die bisherigen "UNIVERSAL BINARY SENSOR FGBS-321" arbeiten unter Fhem so, wie ich es erwarte, d.h. ich kann den Status der Kontakte und des angeschlossenen Temp.sensors problemlos auslesen und nutzen.


Mein Problem:
jetzt mit dem "Nachfolger" erscheinen keine Messwerte von Kontakten bzw. der Temperatur in irgendwelchen readings.

Frage: was mach ich falsch oder ist der Baustein in der neuen Bauform noch nicht in Fhem implentiert ?

Vielen Dank für jede Hilfe.

Gruss jhs


Zur Erläuterung füge ich mal die readings des devices ein:

1. NEU: model FIBARO System FGBS222 Smart Implant

CMD ZW_APPLICATION_UPDATE
associatedWith ZWave_SENSOR_NOTIFICATION_81.01,ZWave_SENSOR_NOTIFICATION_81.02,ZWave_SENSOR_MULTILEVEL_81.03,ZWave_SENSOR_MULTILEVEL_81.04,ZWave_SWITCH_BINARY_81.05,ZWave_SWITCH_BINARY_81.06,ZWave_SENSOR_MULTILEVEL_81.07,ZWave_SENSOR_MULTILEVEL_81.08
mcCapability_01 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO ALARM SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_02 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO ALARM SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_03 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO SENSOR_MULTILEVEL SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_04 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO SENSOR_MULTILEVEL SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_05 ZWAVEPLUS_INFO SWITCH_BINARY ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO PROTECTION SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_06 ZWAVEPLUS_INFO SWITCH_BINARY ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO PROTECTION SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_07 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO SENSOR_MULTILEVEL ALARM SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcCapability_08 ZWAVEPLUS_INFO ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO SENSOR_MULTILEVEL ALARM SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
mcEndpoints total 8, different
model FIBARO System FGBS222 Smart Implant
modelConfig fibaro/fgbs222.xml
modelId 010f-0502-1000
state associationAdd 1 1
timeToAck 0.217
transmit OK


2. ALT model FIBARO System FGBS001 Universal Binary Sensor

UNPARSED BASIC 0c200d03033105014400000840
associatedWith zw_fibaroFGBS001_02_dual_binary_temp_sensor_02_01,zw_fibaroFGBS001_02_dual_binary_temp_sensor_02_02,zw_fibaroFGBS001_02_dual_binary_temp_sensor_02_03
basicSet 0
mcCapability_01 SENSOR_BINARY SENSOR_ALARM
mcCapability_02 SENSOR_BINARY SENSOR_ALARM
1 Änderung; vor #139  vor 2 Sekunden                          47,1          69%
« Letzte Änderung: 18 Juli 2019, 10:02:26 von jhs »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21257
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #1 am: 14 Juli 2019, 15:21:14 »
"in FHEM nicht implementiert" ist unwahrscheinlich, eher ist das Geraet selbst (oder die einzelnen Kanaele?) nicht so konfiguriert, dass sie Daten an FHEM sendet/senden.

Offline jhs

  • Jr. Member
  • **
  • Beiträge: 76
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #2 am: 15 Juli 2019, 09:18:35 »
Hallo,
danke für die schnelle Antwort.
Leider haben mir auch die weiteren Versuche anhand Fibaro Dokumentation keinerlei weitereren Ergebnisse geliefert, um Werte als Readings von  dem "FIBARO System FGBS222 Smart Implant" auszulesen, und wie gesagt, mit dem Vorgänger "FIBARO System FGBS001 Universal Binary Sensor" gibt es diese Probleme bei Fhem nicht.

Natürlich hatte ich auch Google befragt: Konfiguration  FIBARO  FGBS222 Smart Implant -shop
Interessant beim Suchergebnis:
dieses Problem ist auch bei den anderen Lösungen für SmartHome zu finden, mit zumindest einer Ausnahme, denn da funktioniert es - getestet - ohne Wenn&Aber: www.indigodomo.com (Apple-HW)

Meine Sofort-Lösung (=keine Lösung auf Dauer): Hardware-Bausteine getauscht ("Neu-gegen-Alt" ) mit einem Nutzer von www.indigodomo.com
Damit kann ich die Zeit überbrücken, bis sich eine richtige Lösung für die neue Baustein-Generation findet (ein Stück Neue Hardware habe ich noch behalten für den nächsten Versuch).

Gruss
jhs

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #3 am: 15 Juli 2019, 10:23:39 »
Hallo jhs!

Zitat
dieses Problem ist auch bei den anderen Lösungen für SmartHome zu finden,
Dass andere das nicht können, bedeutet lange noch nicht, dass FHEM das nicht kann.  :)
Ich erkenne anhand der Datenblätter des Fibaro zunächst keinen Hinderungsgrund.

Man bräuchte unter anderem Infos zur Assoziation und Konfiguration des Senors um eventuelle Probleme zu erkennen.

Laut Fibaro-Handbuch muss die Inklusion nach Anschluss der Sensoren erfolgen. Wurde das beachtet?
Zudem ist die Konfiguration je nach angeschlossenen Sensoren/Anschlussvariante anzupassen. Wurde das beachtet?

Danach
Zitat
Meine Sofort-Lösung (=keine Lösung auf Dauer): Hardware-Bausteine getauscht ("Neu-gegen-Alt" ) mit einem Nutzer 
befürchte ich, dass eine Lösungssuche nicht mehr möglich ist, oder?

Gruß, Christian

Offline mfgx

  • New Member
  • *
  • Beiträge: 11
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #4 am: 15 Juli 2019, 18:15:24 »
Hi,

Habe exakt das selbe Problem. Versuche seit zwei Wochen das Samart implant zum laufen zu bekommen in FHEM, leider bin ich nicht ganz so Zwave Software versiert.

Was bereits geht:
Output kanal 1 schalten
Interne Temperatur des Smart implants lesen. (wird aber immer 35°C angezeigt, keine Ahnung wie die Temp im Gerät wirklich ist, muss ich mal im Gefrieschrank gegenchecken ;) )

Was nicht geht:
Input Kanäle einlesen
Output Kanal 2 schalten
Externe Temperatur/Luftfeuchte Sensor einlesen (Ja der Sensor wurde vor dem einlernen angeschlossen und auch ein reset des smart implant versucht)

Hier ein Log des Smart implant Hauptkanals (die logs aller childs sind leer):

2019-06-12_18:39:24 ZWave_SENSOR_NOTIFICATION_42 associationAdd 1 1
2019-06-12_18:39:24 ZWave_SENSOR_NOTIFICATION_42 mcCreateAll
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 modelId: 010f-0502-1000
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 modelConfig: fibaro/fgbs222.xml
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 model: FIBARO System FGBS222 Smart Implant
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 mcEndpoints: total 9, different
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 mcCapability_01: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:28 ZWave_SENSOR_NOTIFICATION_42 mcCapability_02: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:29 ZWave_SENSOR_NOTIFICATION_42 mcCapability_03: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:29 ZWave_SENSOR_NOTIFICATION_42 mcCapability_04: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:29 ZWave_SENSOR_NOTIFICATION_42 mcCapability_05: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:29 ZWave_SENSOR_NOTIFICATION_42 mcCapability_06: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:29 ZWave_SENSOR_NOTIFICATION_42 mcCapability_07: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:30 ZWave_SENSOR_NOTIFICATION_42 mcCapability_08: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:39:30 ZWave_SENSOR_NOTIFICATION_42 mcCapability_09: ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
2019-06-12_18:40:07 ZWave_SENSOR_NOTIFICATION_42 version: Lib 3 Prot 6.02 App 5.1 HW 2 FWCounter 0
2019-06-12_18:40:14 ZWave_SENSOR_NOTIFICATION_42 off
2019-06-12_18:40:14 ZWave_SENSOR_NOTIFICATION_42 reportedState: off
2019-06-12_18:40:18 ZWave_SENSOR_NOTIFICATION_42 temperature: 35.0 C
2019-06-12_18:40:25 ZWave_SENSOR_NOTIFICATION_42 powerlvl: current 0 remain 0
2019-06-12_18:41:03 ZWave_SENSOR_NOTIFICATION_42 on
2019-06-12_18:41:06 ZWave_SENSOR_NOTIFICATION_42 off
2019-06-12_18:41:45 ZWave_SENSOR_NOTIFICATION_42 on
2019-06-12_18:41:47 ZWave_SENSOR_NOTIFICATION_42 off
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configAnalogInputsMinimalChangeTo63: 5
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configAnalogInputsPeriodicalReports: 0
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configExternalSensorsMinimalChangeTo67: 5
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configExternalSensorsPeriodicalReports: 0
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configInput1DelayOfAlarmCancellation: 0
2019-06-12_18:45:36 ZWave_SENSOR_NOTIFICATION_42 configInput1OperatingMode: MonostableButton
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput1Sensitivity: 10
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput1SentScenes: 0
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput1ValueSentTo2ndAssociation47: 255
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput1ValueSentTo2ndAssociation49: 0
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput2DelayOfAlarmCancellation: 0
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput2OperatingMode: MonostableButton
2019-06-12_18:45:37 ZWave_SENSOR_NOTIFICATION_42 configInput2Sensitivity: 10
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInput2SentScenes: 0
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInput2ValueSentTo3rdAssociation52: 255
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInput2ValueSentTo3rdAssociation54: 0
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInputsOrientation: DefaultIN11stInputIN22ndInput
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInternalTemperatureSensor66: 0
2019-06-12_18:45:38 ZWave_SENSOR_NOTIFICATION_42 configInternalTemperatureSensorMinimal65: 5
2019-06-12_18:45:39 ZWave_SENSOR_NOTIFICATION_42 configOutput1AutoOff: 0
2019-06-12_18:45:39 ZWave_SENSOR_NOTIFICATION_42 configOutput1LogicOfOperation: contactsNormallyOpen
2019-06-12_18:45:39 ZWave_SENSOR_NOTIFICATION_42 configOutput2AutoOff: 0
2019-06-12_18:45:39 ZWave_SENSOR_NOTIFICATION_42 configOutput2LogicOfOperation: contactsNormallyOpen
2019-06-12_18:45:39 ZWave_SENSOR_NOTIFICATION_42 configOutputsOrientation: DefaultOUT11stOutputOUT22nd0





Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #5 am: 15 Juli 2019, 20:31:11 »
Falls noch nicht getestet, bitte mit MULTI_CHANNEL_ASSOCIATION statt ASSOCIATION testen. Anhand Eurer Angaben sind die gesetzten/getesteten Assoziationen nicht erkennbar.

Achtung: Ich besitze das Gerät nicht und kann deshalb keinen Erfolg versprechen....  8)

Testweise folgende Befehle absetzen und dann Reaktionen beobachten:
set <MainDevice> associationDel 1 <ControllerNodeId>
set <MainDevice> mcaAdd 1 0 <ControllerNodeId> 0
set <MainDevice> mcaAdd 2 0 <ControllerNodeId> 1
set <MainDevice> mcaAdd 3 0 <ControllerNodeId> 2

Dann würde ich configAnalogInputsPeriodicalReports und configExternalSensorsPeriodicalReports so setzen, dass automatische periodische Reports kommen. Außerdem die anderen Parameter entsprechend Euren angeschlossenen Geräten/sensoren einstellen. Default-Werte sind nicht unbedingt optimal.

Bei @mfgx sind die gezeigten Readings mcCapability_.* mMn unvollständig; vergleiche bitte mit @jhs. Vielleicht noch einmal abrufen oder neu inkludieren. Bitte keine secure-Inklusion zum Erforschen, sondern nur "normale".

Btw. mehr Infos liefert die Ausgabe von "list", wie im oben verlinkten Wiki angegeben. Die geposteten Infos sind sehr schmal und erleichtern nicht die Hilfe; ich rate mehr.  ???

Gruß, Christian

Offline jhs

  • Jr. Member
  • **
  • Beiträge: 76
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #6 am: 16 Juli 2019, 03:01:43 »
Hallo,

danke für Eure Antworten.

Vorbemerkung:
Der Trost, dass - wie gesagt - auch Nutzer von non-Fhem-Systemen und nun auch weitere Fhem-Anwender die o.g. Probleme mit diesem Baustein melden, lässt immerhin den Schluss zu, dass wir es nicht mt defekter Hardware zu tun haben.

Zitat
Dass andere das nicht können, bedeutet lange noch nicht, dass FHEM das nicht kann.  :)
Ich erkenne anhand der Datenblätter des Fibaro zunächst keinen Hinderungsgrund.

Das war von mir in keinster Weise als Kritik an Fhem&Co gemeint! sondern eher als Feststellung, dass aus meiner Sicht die OpenSource-Entwickler von den Herstellern nicht so unterstützt werden, wie man sich das wünscht. Es bleibt der nur mühsame Weg  von reverse engineering. Über die vielen Vorteile von Fhem könnte ich gerne einen neuen Thread aufmachen.

Zum weiteren Vorgehen

Zitat
Danach ... befürchte ich, dass eine Lösungssuche nicht mehr möglich ist, oder?

Doch,
Natürlich habe ich in der Fibaro Beschreibung gelesen, aber da fehlt mir wohl zur richtigen Konfiguration noch 'ne ganze Menge an Hintergrundwissen.
Meine testweisen Einstellungen haben bisher nicht ansatzweise was gebracht. Deswegen habe ich den Baustein wieder exkludiert und mich hier an das Forum gewendet.

Ich bin mit meinen Kenntnissen zu weit entfernt, um die o.g. die technischen Tipps so nachvollziehen zu können, dass sich weitere Erkenntnisse daraus ergeben
könnten, bzw. es besteht die Gefahr, dass mein (Produktiv!-) System durch laienhaftes debuggen verschlimmbessert wird...
Zitat
Achtung: Ich besitze das Gerät nicht und kann deshalb keinen Erfolg versprechen....  8)
Wenn es hilft, kann ich @krikan den neuen Baustein leihweise (Versandkostenfrei, ggf. Adresse etc. PM) zur Verfügung stellen.
Ich denke, das wird am ehesten und schnellsten weiterhelfen,  und zwar allen, die diesen Baustein unter Fhem einsetzen wollen.
Noch habe ich den Baustein und noch muss ich o.g. Tauschware nicht abgeben!


Vielen Dank für die Unterstützung.

Gruss
jhs

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #7 am: 16 Juli 2019, 08:21:21 »
Das war von mir in keinster Weise als Kritik an Fhem&Co gemeint!
Hatte ich so auch nicht aufgefasst und selbst wenn, würde es mich nicht stören.  :)

Anders als manche andere ZWave-Software ist FHEM bei der Einbindung von neuen Geräten unabhängig von angepassten Config-Files. Dafür sind manchmal mehr Aktionen/manuelle Anpassungen durch den Nutzers notwendig.

Wenn ich dem Internet glauben darf, gibt es selbst mit dem Fibaro Homecenter noch Probleme:
Zitat
FIB_HOMEC2   4.530   5.0   teilweise kompatibel   Sensoreingänge werden nicht ausgelöst
FIB_FGHCL   4.530   5.0   teilweise kompatibel   Sensoreingänge werden nicht ausgelöst
aus Kompatibilitätsinfo bei home4u-shop.de

Zitat
mich hier an das Forum gewendet.
Sollst/Darfst Du auch.  :)
 
Zitat
.Wenn es hilft, kann ich @krikan den neuen Baustein leihweise (Versandkostenfrei, ggf. Adresse etc. PM) zur Verfügung stellen.
Danke für das Angebot. An Testgeräte käme ich selbst relativ zügig, da ist ein Versand nicht notwendig. Nur fehlt mir momentan die Zeit für Tests.

Vielleicht findet sich jemand, der das Gerät entsprechend lauffähig eingebunden hat oder mit den genannten Befehlen testen möchte.

Gruß, Christian

Offline jhs

  • Jr. Member
  • **
  • Beiträge: 76
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #8 am: 16 Juli 2019, 11:18:28 »
Hallo,

danke für die schnelle Antwort. Noch eine Info mehr,
Zitat
Wenn ich dem Internet glauben darf, gibt es selbst mit dem Fibaro Homecenter noch Probleme: ...
die auf gewisse Probleme mit diesem Baustein hinweist; ich kam mir schon recht blöd vor ;-)

Da ich meinen FGBS222-ZWave-Baustein noch ein paar Tage behalten darf, habe ich das Teil doch noch mal angeschlossen und die Schritte aus ... nachvollzogen:
Zitat
wiki.fhem.de/wiki/Z-Wave#Welche_Infos_sollten_Anfragen_im_ZWave-Forum_enthalten

Ergebnisse in Kurzform hier:

1. Neu-Inkludieren ... problemlos WebGUI / room / ZWave
Zitat
ZWave_SENSOR_NOTIFICATION_86
ZWave_SENSOR_NOTIFICATION_86.01
ZWave_SENSOR_NOTIFICATION_86.02
ZWave_SENSOR_MULTILEVEL_86.03
ZWave_SENSOR_MULTILEVEL_86.04
ZWave_SWITCH_BINARY_86.05 on off
ZWave_SWITCH_BINARY_86.06 on off
ZWave_SENSOR_MULTILEVEL_86.07
associationAdd 1 1 on off


2. list (1) des jeweiligen FHEM-Devices (Ausgabe von list <device>)
Zitat
list ZWave_SENSOR_NOTIFICATION_86
list ZWave_SENSOR_NOTIFICATION_86.01
list ZWave_SENSOR_NOTIFICATION_86.02
list ZWave_SENSOR_MULTILEVEL_86.03
list ZWave_SENSOR_MULTILEVEL_86.04
list ZWave_SWITCH_BINARY_86.05
list ZWave_SWITCH_BINARY_86.06
list ZWave_SENSOR_MULTILEVEL_86.07


UND

3. list (2) des jeweiligen FHEM-Devices (Ausgabe von list <device>) wie unter 2 aber gem.
Zitat
Bitte vor Aufruf des list-Befehls -wenn vorhanden/möglich- folgende Befehle ausführen und Ergebnis abwarten:

get <device> associationAll
get <device> configAll
get <device> versionClassAll
get <device> mcaAll
get <device> wakeupInterval (nur bei batteriebetriebenen Geräten)

zunächst ausgeführt für die devices/channels
list ZWave_SENSOR_NOTIFICATION_86
list ZWave_SENSOR_NOTIFICATION_86.01

4. TBD, wenn dafür noch Bedarf besteht ...
Zitat
passender Ausschnitt aus dem Logfile (siehe Link im FHEM-Menü links) generiert mit den gesetzten Attributen

attr <ZWDongle> verbose 5 und
attr global mseclog 1


Die ausführlichen Ausgaben habe ich in der Datei 2019-07-16-1_fhem_zwave_debug_blog_FGBS222.txt (im Anhang) erfasst, um den Beitrag hier nicht unnötig aufzublähen.
Vielleicht kann ich mit dieser Info den Experten helfen bei der Klärung der Frage, warum dieser Baustein solche Probleme macht.

Vielen Dank für jede Hilfe

Gruss
jhs

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #9 am: 16 Juli 2019, 13:07:40 »
Bitte setze der Reihe nach folgende Befehle ab und kontrolliere erfolgreiche Verarbeitung im Gerät:

set ZWave_SENSOR_NOTIFICATION_86 associationDel 1 1
set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 1 0 1 0
set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 2 0 1 1
set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 3 0 1 2
set ZWave_SENSOR_NOTIFICATION_86 configAnalogInputsPeriodicalReports 60
set ZWave_SENSOR_NOTIFICATION_86 configExternalSensorsPeriodicalReports 60

Anschließend bitte beobachten/testen, ob und was sich ändert.

Offline jhs

  • Jr. Member
  • **
  • Beiträge: 76
Antw:Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #10 am: 16 Juli 2019, 20:49:01 »
Hallo,
um das Ergebnis gleich vorwegzunehmen: ES FUNKTIONIERT NUN !!!

Nach ersten Tests sieht es so aus, dass mit den o.g. Konfig-Tipps "set ... " von
@krikan von heute 2019-07-16 um 13:07:40 »
die Lösung des Problems erreicht wird, d.h. der Baustein "FIBARO System FGBS222 Smart Implant" kann damit auch innerhalb von Fhem benutzt werden.


1.1  Eingabe der o.g. 'set ...'  commands
     Keinerlei Meldungen oder Fehlermeldungen an der Console dabei.


1.2 zugehoerige Eintraege im Fhem Logfile

tail -f /opt/fhem/log/fhem-2019-07.log

2019.07.16 19:16:28 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 associationDel 1 1
2019.07.16 19:16:42 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 1 0 1 0
2019.07.16 19:17:10 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 2 0 1 1
2019.07.16 19:17:22 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 mcaAdd 3 0 1 2
2019.07.16 19:17:37 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 configAnalogInputsPeriodicalReports 60
2019.07.16 19:17:51 3: ZWave set ZWave_SENSOR_NOTIFICATION_86 configExternalSensorsPeriodicalReports 60


2. Ergebnis: BINGO, Es funktioniert mit der Abfrage  der Eingangs-Sensoren
Nun gibt es die entsprechenden Readings (getestet habe ich nur die beiden digitalen Eingaenge)

ZWave_SWITCH_BINARY_86.05  je nach Tasterstellung am Eingang GELB
        state off 2019-07-16 19:39:24
        state on 2019-07-16 19:40:27
 ZWave_SWITCH_BINARY_86.06  je nach Tasterstellung am Eingang GRUEN
        state off 2019-07-16 19:41:17
        state on  2019-07-16 19:42:30


3. Nachtrag
Zitat
Laut Fibaro-Handbuch muss die Inklusion nach Anschluss der Sensoren erfolgen. Wurde das beachtet?
Zudem ist die Konfiguration je nach angeschlossenen Sensoren/Anschlussvariante anzupassen. Wurde das beachtet?

Ja/1, das wusste ich noch von dem "alten" Vorgänger-Bausteintyp: die Temperatursensoren müssen _vor_ der Inklusion verdrahtet sein.
Ja/2, ich hatte mit den Parametern configInput*OperatingMode "rumgespielt", aber damit keinerlei Ergebnisse erzielt.

Und ehrlich, Deine Konfig-Befehle habe ich stumpf eingegeben, im Wissen, die kommen vom Fachmann, ohne deren Bedeutung und Auswirkung zu kennen. Sorry, so tief stecke ich _der_ Materie nicht drin.
Wenn ich jetzt noch irgendwas an Debugdaten mit diesem Baustein ermitteln soll, lass es mich wissen.
Aber vielleicht kann @mfgx noch melden, ob sein Problem mit Deinen Konfig-Tipps auch gelöst ist.
Ansonsten würde ich den Thread erst einmal auf gelöst setzen.

Ich möchte mich an dieser Stelle nochmals ganz herzlich für die tolle Unterstützung bedanken, bei Dir, den vielen Autoren von Fhem und den helfenden Gurus aus diesem Forum !

Gruss
jhs
« Letzte Änderung: 17 Juli 2019, 08:11:29 von jhs »

Offline mfgx

  • New Member
  • *
  • Beiträge: 11
Antw:[gelöst] Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #11 am: 18 Juli 2019, 21:10:03 »
Hi,

Ich habe jetzt das Device excludiert und ohne security eingebunden.
Nach den Befehlen von krikan hat es nun endlich funktioniert. Vielen Dank an krikan!

Da ich das Gerät zum Türöffnen und die Eingänge für die Alarmanalage nutzen will würde ich jedoch gerne verschlüsselt kommunizieren.
Daher wieder excludiert, secure includiert und die Befehle von krikan eingegeben.
Jetzt funktioniert das Lesen der externen und internen Temperaturen und die Schaltzustände der Eingänge werden angezeigt.
Allerdings kann ich die Ausgänge nicht schalten. Es werden bei den SWITCH_BINARY keine on/off buttons angezeigt und auch wenn man webcommand on/off hinzufügt kommt nur die Fehlermeldung "
Unknown argument on, choose one of secSupportedReport "

Vielleicht jemand eine Idee wie man die switches zum laufen bekommt?


Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:[gelöst] Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #12 am: 18 Juli 2019, 21:30:40 »
Zeige bitte einmal die Ausgabe von "list <device>" für das Hauptgerät und einen betroffenen Unterkanal.

Getippt und unspezifisch: Ergänze bitte die Attribute zu den Classes um eventuell fehlende Command Class SWITCH_BINARY und teste.

Gruß. Christian

Offline mfgx

  • New Member
  • *
  • Beiträge: 11
Antw:[gelöst] Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #13 am: 22 Juli 2019, 00:30:20 »
Hi,

Danke Christian, hat geholfen SWITCH_BINARY im attribut Classes hinzuzufügen. Jetzt erscheinen on/off buttons und funktionieren auch.
Nur der Status wird nie in FHEM geändert. Es wird immer als on angezeigt.

Hier die list des Hauptgeräts und des Binary switches:

Internals:
   CFGFN     
   CHANGED   
   DEF        dd44e2dc 46
   FUUID      5d30b93f-f33f-5903-af7c-e64b80c3bc309254
   IMAGE     
   IODev      ZWDongle_0
   LASTInputDev ZWDongle_0
   MSGCNT     23074
   NAME       ZWave_SENSOR_NOTIFICATION_46
   NR         403
   STATE      on
   TYPE       ZWave
   ZWDongle_0_MSGCNT 23074
   ZWDongle_0_RAWMSG 0004002e1e988113bd20d105628d85aac9e59b103f1fce8e2dc5f002a423fb1aec9d2d
   ZWDongle_0_TIME 2019-07-22 00:28:34
   ZWaveSubDevice no
   cmdsPending 0
   endpointChildren ZWave_SENSOR_NOTIFICATION_46.01,ZWave_SENSOR_NOTIFICATION_46.02,ZWave_SENSOR_MULTILEVEL_46.03,ZWave_SENSOR_MULTILEVEL_46.04,ZWave_SWITCH_BINARY_46.05,ZWave_SWITCH_BINARY_46.06,ZWave_SENSOR_MULTILEVEL_46.07,ZWave_SENSOR_MULTILEVEL_46.08,ZWave_SENSOR_MULTILEVEL_46.09
   homeId     *gelöscht*
   isWakeUp   
   lastMsgSent 1563748114.12961
   nodeIdHex  2e
   secTime    1563748114.12895
   READINGS:
     2019-07-18 20:24:05   SECURITY        ENABLED
     2019-07-18 20:37:15   SEND_DATA       failed:00
     2019-07-18 20:24:06   UNPARSED        SECURITY 03980500
     2019-07-18 20:24:30   associatedWith  ZWave_SENSOR_NOTIFICATION_46.01,ZWave_SENSOR_NOTIFICATION_46.02,ZWave_SENSOR_MULTILEVEL_46.03,ZWave_SENSOR_MULTILEVEL_46.04,ZWave_SWITCH_BINARY_46.05,ZWave_SWITCH_BINARY_46.06,ZWave_SENSOR_MULTILEVEL_46.07,ZWave_SENSOR_MULTILEVEL_46.08,ZWave_SENSOR_MULTILEVEL_46.09
     2019-07-18 20:32:35   configAnalogInputsMinimalChangeTo63 5
     2019-07-18 20:32:36   configAnalogInputsPeriodicalReports 60
     2019-07-18 20:32:36   configExternalSensorsMinimalChangeTo67 5
     2019-07-18 20:32:37   configExternalSensorsPeriodicalReports 60
     2019-07-18 20:32:38   configInput1DelayOfAlarmCancellation 0
     2019-07-18 20:32:38   configInput1OperatingMode NormallyClosedAlarmInput
     2019-07-18 20:32:39   configInput1Sensitivity 10
     2019-07-18 20:32:40   configInput1SentScenes 0
     2019-07-18 20:32:41   configInput1ValueSentTo2ndAssociation47 255
     2019-07-18 20:32:41   configInput1ValueSentTo2ndAssociation49 0
     2019-07-18 20:32:42   configInput2DelayOfAlarmCancellation 0
     2019-07-18 20:32:43   configInput2OperatingMode NormallyClosedAlarmInput
     2019-07-18 20:32:43   configInput2Sensitivity 10
     2019-07-18 20:32:44   configInput2SentScenes 0
     2019-07-18 20:32:45   configInput2ValueSentTo3rdAssociation52 255
     2019-07-18 20:32:45   configInput2ValueSentTo3rdAssociation54 0
     2019-07-18 20:32:46   configInputsOrientation DefaultIN11stInputIN22ndInput
     2019-07-18 20:32:47   configInternalTemperatureSensor66 60
     2019-07-18 20:32:48   configInternalTemperatureSensorMinimal65 5
     2019-07-18 20:32:48   configOutput1AutoOff 0
     2019-07-18 20:32:49   configOutput1LogicOfOperation contactsNormallyOpen
     2019-07-18 20:32:50   configOutput2AutoOff 0
     2019-07-18 20:32:51   configOutput2LogicOfOperation contactsNormallyOpen
     2019-07-18 20:32:51   configOutputsOrientation DefaultOUT11stOutputOUT22nd0
     2019-07-18 20:24:25   mcCapability_01 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:26   mcCapability_02 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:26   mcCapability_03 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:27   mcCapability_04 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:28   mcCapability_05 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:28   mcCapability_06 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:29   mcCapability_07 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:30   mcCapability_08 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:31   mcCapability_09 ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2
     2019-07-18 20:24:24   mcEndpoints     total 9, different
     2019-07-18 20:24:23   model           FIBARO System FGBS222 Smart Implant
     2019-07-18 20:24:23   modelConfig     fibaro/fgbs222.xml
     2019-07-18 20:24:23   modelId         010f-0502-1000
     2019-07-22 00:27:00   state           on
     2019-07-22 00:28:34   timeToAck       0.035
     2019-07-22 00:28:34   transmit        OK
   secMsg:
   secNonce:
Attributes:
   IODev      ZWDongle_0
   classes    ZWAVEPLUS_INFO SWITCH_BINARY ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO TRANSPORT_SERVICE VERSION MANUFACTURER_SPECIFIC DEVICE_RESET_LOCALLY POWERLEVEL SECURITY SECURITY_S2 CENTRAL_SCENE SENSOR_MULTILEVEL MULTI_CHANNEL CONFIGURATION CRC_16_ENCAP ALARM PROTECTION FIRMWARE_UPDATE_MD SUPERVISION APPLICATION_STATUS
   room       ZWave
   secure_classes SWITCH_BINARY ASSOCIATION MULTI_CHANNEL_ASSOCIATION ASSOCIATION_GRP_INFO VERSION MANUFACTURER_SPECIFIC DEVICE_RESET_LOCALLY POWERLEVEL CENTRAL_SCENE SENSOR_MULTILEVEL MULTI_CHANNEL CONFIGURATION ALARM PROTECTION FIRMWARE_UPDATE_MD
   vclasses   ALARM:8 APPLICATION_STATUS:1 ASSOCIATION:2 ASSOCIATION_GRP_INFO:2 CENTRAL_SCENE:3 CONFIGURATION:1 CRC_16_ENCAP:1 DEVICE_RESET_LOCALLY:1 FIRMWARE_UPDATE_MD:4 MANUFACTURER_SPECIFIC:2 MULTI_CHANNEL:4 MULTI_CHANNEL_ASSOCIATION:3 POWERLEVEL:1 PROTECTION:2 SECURITY:1 SECURITY_S2:1 SENSOR_MULTILEVEL:11 SUPERVISION:1 SWITCH_BINARY:1 TRANSPORT_SERVICE:2 VERSION:2 ZWAVEPLUS_INFO:2

Internals:
   CFGFN     
   DEF        dd44e2dc 11781
   FUUID      5d30b95c-f33f-5903-c149-1bc5a3a491c37533
   IODev      ZWDongle_0
   NAME       ZWave_SWITCH_BINARY_46.05
   NR         429
   STATE      on
   TYPE       ZWave
   ZWaveSubDevice yes
   endpointParent ZWave_SENSOR_NOTIFICATION_46
   homeId     dd44e2dc
   isWakeUp   
   nodeIdHex  2e05
   READINGS:
     2019-07-18 20:24:30   associatedWith  ZWave_SENSOR_NOTIFICATION_46
     2019-07-22 00:24:39   reportedState   on
     2019-07-22 00:24:39   state           on
Attributes:
   IODev      ZWDongle_0
   classes    ZWAVEPLUS_INFO SUPERVISION APPLICATION_STATUS SECURITY SECURITY_S2 SWITCH_BINARY
   room       ZWave

schöne Grüße,
Hans

Offline krikan

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 6624
Antw:[gelöst] Problem mit ZWave FIBARO System FGBS222 Smart Implant
« Antwort #14 am: 22 Juli 2019, 08:19:45 »
Jetzt erscheinen on/off buttons und funktionieren auch.
Freut mich. Ursache des fehlenden Eintrags kenne ich leider nicht.

Zitat
Nur der Status wird nie in FHEM geändert. Es wird immer als on angezeigt.
Wird es vielleicht im falschen Device gemeldet?
Um das im Detail nachvollziehen zu können, bräuchte man wohl ein verbose 5 - Log eines Schaltvorgangs. Bei Security-Logs bin ich selbst bei Detailanalysen leider raus.

Gruß, Christian

 

decade-submarginal