Autor Thema: FHEM, piVCCU und ioBroker auf Raspberry 3b  (Gelesen 326 mal)

Offline JörgK

  • New Member
  • *
  • Beiträge: 8
FHEM, piVCCU und ioBroker auf Raspberry 3b
« am: 15 August 2019, 17:52:48 »
Hallo Leute,
heute wende ich mich an euch, weil ich gerade etwas verzweifelt bin.
Ein Update von piVCCU hat mein System zerschossen in das ich schon viel Zeit investiert hatte.

Kurz die Ausgangslage:
Auf einem Raspberry 3B mit RPI-RF-MOD für Homematic läuft FHEM für Signalduino, piVCCU für Heizthermostatsteuerung unter HM und der ioBroker für die Integration aller Komponenten.
eth0: 192.168.x.n Heimnetzwerk IP über DHCP
br0: 192.168.x.o läuft gerade nicht.
wlan0: 192.168.y.m WLAN für zusätzliche Sensoren und Aktoren. DHCP-Server läuft für WLAN dem auf Raspberry.

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

#auto br0
iface br0 inet dhcp
bridge_ports eth0
bridge_hw 5B:03:AD:D2:28:AB
#bridge_ports none
#bridge_fd  5
#address 192.168..
#netmask 255.255.255.0

# WLAN-Interface
allow-hotplug wlan0
iface wlan0 inet static
address 192.168.y.o
netmask 255.255.255.0



Bei einem SW-Update lief allerdings leider etwas mit der HM-Instanz schief.
Ich hatte keinen Zugang mehr über ssh und eth0. Auch die Web-Instanzen von FHEM, iobroker und HM waren nicht erreichbar. :-[
Nach der Deaktivierung der Bridge für die HM-SW piVCCU bootete der Raspberry wieder normal und ich konnte wieder über Netzwerk per ssh zugreifen.
In diesem Zustand läuft auch FHEM und ioBroker normal.

Ich habe auch schon mehrfach piVCCU neu installiert, aber jedesmal wenn ich die Bridge aktiviere, gehen alle anderen Verbindungen flöten.
Lokal sind die IP's zwar vorhanden und sehen unter ifconfig gut aus aber sonst geht nichts. Die Datei interfaces.d habe ich auch schon mehrfach angepasst.
Da ich die Bridge auch ohne piVCCU nicht zum Läufen bekomme, tippe ich auf ein Problem in der Netzwerkkonfiguration. Routing, Portweiterleitung?

Ich wäre echt froh, wenn ich hm wieder zum Laufen bekommen würde.

Und für alle die sagen wollen, mach alles platt und installiere neu (Das habe ich oft genug als Lösung in den Foren gelesen!), kann ich gleich sagen, dann ist das gewählte Konzept, dass mehrere Instanzen auf einem Rechner laufen, nicht sinnvoll und unbrauchbar. Folge wäre für mich je ein Raspberry für FHEM, iobroker und HM, was ich natürlich vermeiden will.

Vielen Dank schon mal für eure Ansätze.

Gruß
Jörg





Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5518
Antw:FHEM, piVCCU und ioBroker auf Raspberry 3b
« Antwort #1 am: 16 August 2019, 08:25:13 »
Kleine Zusatzfragen:
- hast Du Grafischen Pi oder "Minimal-Installation"?
- NetworkManager?
- Du kommst für ssh, http, ping über eth0 normalerweise rein?
- Hat es wirklich mal so funktioniert?

Du legst auf eth0 ein bridge-device (nur auf eine Netzwerkschnitstelle?) und damit wird eigentlich eth0 für die config eth0 deaktiviert. Also eigentlich ist das jetzige Verhalten das "richtige".

Was willst Du eigentlich mit dieser bridge erreichen?
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline JörgK

  • New Member
  • *
  • Beiträge: 8
Antw:FHEM, piVCCU und ioBroker auf Raspberry 3b
« Antwort #2 am: 16 August 2019, 17:09:12 »
Hi,
gerne bringe ich Licht ins Dunkel :-)

Kleine Zusatzfragen:
- hast Du Grafischen Pi oder "Minimal-Installation"?
Nein, ich habe nur die Minimalinstallation ohne GUI. Diese reicht für mich, da er sowieso nur als Server läuft.

- NetworkManager?
Nein, alles recht schlank.
Heimnetz(mit Internet) über eth0
WLAN vom Raspberry als Router mit Subnetz (DHCP-Server auf Raspbery). (wlan0)
Kein Routing zwischen eth0 und wlan0 -> D.h. meine Aktoren (z.B. Shelly's) sind von FHEM und ioBroker erreichbar aber sind trotzdem entkoppelt vom Heimnetz und www.

- Du kommst für ssh, http, ping über eth0 normalerweise rein?
Wenn die Bridge aktiviert wird, bin ich nicht mehr über eth0 draufgekommen.

- Hat es wirklich mal so funktioniert?
Eigentlich schon! Das WLAN habe ich erst seit einem Monat am Laufen. Die Homematic-Installation hatte ich schon vorher zerschossen  :'(


Du legst auf eth0 ein bridge-device (nur auf eine Netzwerkschnitstelle?) und damit wird eigentlich eth0 für die config eth0 deaktiviert. Also eigentlich ist das jetzige Verhalten das "richtige".

Was willst Du eigentlich mit dieser bridge erreichen?
Das war jetzt wohl der richtige Hinweis. Das Update hatte eth0 aktiviert mit "auto eth0". Dies hat sich wohl gebissen mit der Bridge.
Nach endlosem Neuinstallieren und rumexperimentieren an der interfaces.d läuft es jetzt wieder.

Mit einer Netzwerkbridge habe ich in meinen 20 Jahren Linux auch noch nicht gearbeitet, deshalb ist mir das Konzept nicht so geläufig.
Die Bridge ist der Standardinstallitionsweg für piVCCU. Die Homematic CCU läuft per piVCCU in einem Container und dieser fungiert wie ein separates Gerät im Netzwerk. Ich bekomme dabei auch eine eigene IP.
So habe ich alle drei Anwendungen unabhängig voneinander auf einem Rechner (Homematic, FHEM und ioBroker)
Und da die Sensoren und Aktoren keinen Zugang zum Internet haben, ist es mir egal wenn sie nach Hause telefonieren wollen  ;)

Jetzt muss ich nur noch HM neu einrichten und ein ordentliches Backup machen. :P

Vielen Dank

Wenn noch Fragen sind, dann bitter her damit. Vielleicht ist mein Weg nicht so häufig, aber ich bin auch noch in der Findungsphase nach dem Optimum.

Gruß,
Jörg

 

decade-submarginal