Autor Thema: Kein Zugang seit Update auf Fritz!OS 5.50  (Gelesen 9771 mal)

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Kein Zugang seit Update auf Fritz!OS 5.50
« am: 05 Januar 2013, 19:55:20 »
Hallo Leute,

ich habe (erst) heute bei meiner Fritz!Box das Firmwareupdate 84.05.50 eingespielt (FRITZ!OS 05.50). Seit dem kann ich mich nicht mehr über den Browser oder per Telnet bei meinem Fhem Server anmelden.

Hier im Forum habe ich dazu bereits einen Hinweis gefunden Link.
Ich weiss aber nicht genau was ich wo ändern muss. Kann das bitte noch mal jemand einem Anfänger etwas genauer erklären?

Gruß euer Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline UliM

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2711
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #1 am: 05 Januar 2013, 20:09:08 »
Zitat von: Twinsen schrieb am Sa, 05 Januar 2013 19:55
Hallo Seit dem kann ich mich nicht mehr über den Browser oder per Telnet bei meinem Fhem Server anmelden.


Was passiert denn bzw passiert niicht?äFalls ein login- popup kommt müsste das passwort deiner fritzbox funktionieren.

Gruß Uli
RPi4/Raspbian, CUL V3 (ca. 30 HomeMatic-devices), LAN (HarmonyHub, alexa etc.).  Fördermitglied des FHEM e.V.

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #2 am: 05 Januar 2013, 23:05:15 »
Hallo Uli,

die Passwortabfrage kommt, aber das Passwort meiner Fritzbox wird seit dem Update nicht mehr angenommen. Vorher hat es einwandfrei funktioniert wenn ich das Passwort eingegeben habe.

Gruß Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #3 am: 12 Januar 2013, 13:40:48 »
Hallo Leute,

ich habe keine Lösung gefunden bezüglich des Zugriffs auf die Fitzbox, deshalb habe ich das Fhem Verzeichnis auf der Fritzbox umbenannt und die Fritzfirmware von fhem.de neu eingespielt. Leider sind jetzt alle meine Einstellungen weg und ich muss auch alle Geräte neu anlernen, aber so habe ich wenigstens wieder Zugriff auf die Fritzbox.

Gruß euer Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline UliM

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2711
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #4 am: 12 Januar 2013, 15:42:55 »
Du könntest den relevanten Teil Deiner alten fhem.cfg rüberkopieren und ggf Pfade anpassen für filelogs.
Gruß Uli
RPi4/Raspbian, CUL V3 (ca. 30 HomeMatic-devices), LAN (HarmonyHub, alexa etc.).  Fördermitglied des FHEM e.V.

Offline ThomasL

  • Jr. Member
  • **
  • Beiträge: 66
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #5 am: 13 Januar 2013, 20:59:29 »
Ich habe das gleiche Problem.
Nach dem Fritzboxupdate klappt die Anmeldung nicht mehr.
User/Passwort werden nicht mehr aktzeptiert.
Ich habe auch schon FHEM neu aufgespielt.
Keine Änderung.

Kann mir jemand helfen?

Danke
Thomas

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #6 am: 13 Januar 2013, 21:54:38 »
Hallo ThomasL,

ich fand keine Lösung außer das fhem-Verzeichnis über FritzNAS umbenennen und dann die Firmware von fhem.de noch mal flashen. Die Lösung ist nicht elegant, funktioniert aber. Und wie Uli schreibt kannst Du dann Teile Deiner fhem.cfg wieder einspielen, bis auf die mit der Passwortabfrage natürlich.

Gruß Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25403
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #7 am: 13 Januar 2013, 23:05:44 »
Problem: ab Fritz!OS 5.50 funktioniert das in dem "alten" fhem-5.3 per default aktivierte Fritzbox-Passwort-Ueberpruefung (FB_checkPw) nicht. D.h. wenn jemand erst fhem 5.3 installiert hat, und dann das Firmware auf 5.50 erneuert, der hat sich in fhem ausgesperrt.

Loesungen:
- NACH dem Fritz!OS upgrade: fhem.cfg editieren (via ftp oder Netzlaufwerk), und die basicAuth Zeilen auskommentieren.
- VOR dem Fritz!OS 5.50 firmware upgrade ein fhem "update" durchfuehren: im aktuellen fhem Version ist das Problem behoben.

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #8 am: 13 Januar 2013, 23:34:19 »
Hallo Rudolf,

also zumindest Lösung zwei hat bei mir nicht funktioniert. Ich hatte ein Update von fhem durchgeführt und war auf dem aktuellen Stand BEVOR ich Fritz!OS 5.50 geflasht hatte Anfang Januar.

Interessant wäre es auch wie ich jetzt nach dem Update die Kennwortabfrage wieder einbauen kann mit Fritz!OS 5.50.

Gruß Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline WiKa

  • Full Member
  • ***
  • Beiträge: 130
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #9 am: 13 Januar 2013, 23:41:58 »
Zitat von: Twinsen schrieb am So, 13 Januar 2013 21:54
Teile Deiner fhem.cfg wieder einspielen, bis auf die mit der Passwortabfrage natürlich.

Hallo Twinsen,
würdest Du bitte den Teil mit der Passwortabfrage hier einstellen?
Ich habe mir heute die aktuelle Version von FHEM für die FB7390 von fhem.de heruntergeladen und entpackt.
In der fhem.cfg finde ich im Bereich Passwortabfrag folgende Einträge:

#FB_checkPw does not for FB-OS > 5.22
#attr WEB basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr WEBphone basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr WEBtablet basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr telnetPort globalpassword {use FritzBoxUtils;;FB_checkPw("localhost","$password") }


Alle Passwortabfragen sind also deaktiviert.
Dieses Workaround wurde von Usern bereits hier oder in der alten Google-Mailingliste gepostet.

Hier http://forum.fhem.de/index.php?t=msg&goto=55933&rid=28&srch=basicAuth#msg_55933 schreibt Rudolf König:
Zitat von: rudolfkoenig schrieb am Sa, 05 Januar 2013 13:22
> #FB_checkPw does not for FB-OS > 5.22

Dieser Kommentar sollte nach(!) einem update hinfaellig sein, und folgendes sollte auf einem FritzBox wieder funktionieren:

attr WEB basicauth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }


Ich habe den Test in Abänderung des Originalposts mit "WEBtablet" durchgeführt.

Nach Eintrag der Änderung meckerte FHEM wg. eines durch "copy/paste" verursachten Fehlers FHEM wollte "WEB basicauth" nicht akzeptieren, sondern (zurecht) nur "WEB basicAuth".

@ Rudolf König:
Die ebenfalls geänderte startfhem wird bei einem "update" in FHEM nicht aktualisiert.
Nach manueller Kopieraktion und Neustart FHEM war nach o.g. Änderungen kein Login via Tablet mehr möglich.

Lediglich mit

attr WEBtablet basicauth { "$user:$password" eq "Benutzername:1234" }

in der fhem.cfg funktioniert die Anmeldung reproduzierbar.
Benutzername und Password müssen in der FB eingerichtet sein.
Z.B. "ftpuser:1234".

Sollten Tests zur Eingrenzung des Fehlers notwendig sein, helfe ich im Rahmen meiner Möglichkeiten gerne.

VG,
WiKa

FB7390 FW:FRITZ!OS 05.50 / RFXTRX433 FW:433_64 / ELRO AB440R (modified to IT-Code) - AB440S (IT-Code) - AB440IS (IT-Code) / Oregon THGN132N - THN132N - THGR122N / Intertechno PAR-1000 - PAR1500

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25403
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #10 am: 14 Januar 2013, 07:54:56 »
>  Ich hatte ein Update von fhem durchgeführt und war auf dem aktuellen Stand BEVOR ich Fritz!OS 5.50 geflasht hatte Anfang Januar.

Die Aenderung erfolgte laud SVN am 29.12.2012. Ich habe es gerade auf einem FB7390 mit Fritz!OS 5.50 getestet, und es funktioniert. Der Eintrag ist genauso wie im commandref.html erwaehnt:
att WEB basicAuth {use FritzBoxUtils;FB_checkPw("localhost","$password") }

Benutzername ist egal, Passwort ist der vom Anmeldung.


> Die ebenfalls geänderte startfhem wird bei einem "update" in FHEM nicht aktualisiert.

Sag ich auch.

Wishbringer

  • Gast
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #11 am: 17 Januar 2013, 09:02:26 »
Seit FritzOS 5.50 gibt es ja auch die Möglichkeit, Benutzer anzulegen, sowie Einstellungen vorzunehmen, wie die Anmeldung an der FritzBox zu erfolgen hat.
Bei mir gibt es z.B. den User ftpuser nicht mehr, die Anmeldung erfolgt über einen vordefinierten Benutzernamen und Kennwort.

Könnte man für FritzOS 5.50 nicht die Konfig so ändern, dass man einen Nutzer "FHEM" anlegt, dem man über die FritzBox ein Passwort zuordnet und dieses zur Anmeldung an FHEM nutzt?

Offline Twinsen

  • New Member
  • *
  • Beiträge: 17
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #12 am: 17 Januar 2013, 22:30:51 »
Hallo Leute,

also soweit ich es nachvollziehen kann ist das mein Auszug aus fhem.cfg nach dem FirmwareUpdate:

--------------------------------------schnipp--------------------------------------
define telnetPort telnet 7072 global
attr telnetPort password {use FritzBoxUtils;;FB_checkPw("localhost","$password") }

define WEB FHEMWEB 8083 global
attr WEB basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }

define WEBphone FHEMWEB 8084 global
attr WEBphone basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
attr WEBphone smallscreen 1

define WEBtablet FHEMWEB 8085 global
attr WEBtablet basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
attr WEBtablet touchpad 1
--------------------------------------schnapp--------------------------------------

und das ist der Inhalt der startfem-Datei nach der WiKa gefragt hat:

--------------------------------------schnipp--------------------------------------
#!/bin/sh

home=/var/InternerSpeicher/fhem

cd $home

trap "" SIGHUP
modprobe cdc_acm
modprobe ftdi_sio
sleep 2

ln -sf $home/FHEM/fhemcmd.sh /var/fhemcmd

PATH=$home:$PATH
export PATH

export LD_LIBRARY_PATH=$home/lib
export PERL5LIB=$home/lib/perl5/site_perl/5.12.2/mips-linux:$home/lib/perl5/site_perl/5.12.2:$home/lib/perl5/5.12.2/mips-linux:$home/lib/perl5/5.12.2

# let FHEM run as user boxusr80
# add user fhem with uid of boxusr80
id fhem > /dev/null 2>&1
if [ "$?" -ne "0" ]; then
  echo "user fhem does not exist. Adding it."
  echo "fhem:any:1080:0:fhem:/home-not-used:/bin/sh" >>/var/tmp/passwd
  # set files ownership
  chown -R boxusr80 ${home}/log
  chown -R boxusr80 ${home}/FHEM
fi

perl fhem.pl fhem.cfg

--------------------------------------schnapp--------------------------------------

Ich hoffe es hilft dabei nachvollziehen zu können warum bei mir die Anmeldung nicht mehr funktioniert hat.

Gruß euer Twinsen
---------------------------
Raspberry Pi 3
CUL V4 868 MHz, EnOceanPi TMC310
Debian FHEM Paket mit allen Abhängigkeiten

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25403
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #13 am: 18 Januar 2013, 09:02:31 »
>  Bei mir gibt es z.B. den User ftpuser nicht mehr, die Anmeldung erfolgt über einen vordefinierten Benutzernamen und Kennwort.

Vermutlich ist das Entfernen der "Standarduser" das Problem, da in der fhem Routine zur Passwortpruefung kein Benutzer angegeben wird. Irgendwer mit Standarduser-Loesch-Ambitionen muesste eine Methode finden, wie man FHEM/FritzBoxUtils.pm/FB_doCheckPW() aendern muss (bzw. den Aufruf von /login_sid.lua Parametrisieren muss), damit es auch ohne den Standarduser funktioniert.

Offline WiKa

  • Full Member
  • ***
  • Beiträge: 130
Aw: Kein Zugang seit Update auf Fritz!OS 5.50
« Antwort #14 am: 21 Januar 2013, 23:10:34 »
Hallo zusammen,

@Twinsen:
Danke für die Bereitstellung deiner Dateiauszüge.
Auch nach Neuinstallation von FHEM konnte ich damit keine Veränderung der Situation feststellen.
Bei dir läuft FHEM als boxuser/ftpuser, bei mir (wg. Mailversand aus der Fritzbox) als root.

@Rudolf:
Warum auch immer es bei deinem Test funktioniert hat...

Die Anmeldung in FHEM ist bei mir ja nicht unmöglich, funktioniert aber nicht mit:
attr WEB basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }


Mit folgenden zwei Versionen funktioniert die Anmeldung dagegen:

attr WEB basicAuth dXNlcjp3aWxsaXYhdA==

Siehe Commandref basicauth

attr WEB basicAuth { "$user:$password" eq "eingerichteter_benutzer:passwort_eingerichteter_benutzer" }


Es funktioniert, also kann ich den Zustand so belassen.
Mit meiner Nachfrage wollte ich nur ausschließen, dass ich mir Problemen/Nachfragen zu anderen Themen/Modulen ein exotisches FHEM betreibe.

Dank euch beiden,
VG,
WiKa

FB7390 FW:FRITZ!OS 05.50 / RFXTRX433 FW:433_64 / ELRO AB440R (modified to IT-Code) - AB440S (IT-Code) - AB440IS (IT-Code) / Oregon THGN132N - THN132N - THGR122N / Intertechno PAR-1000 - PAR1500