Autor Thema: Osram Zigbee Farbbirne  (Gelesen 557 mal)

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Osram Zigbee Farbbirne
« am: 21 September 2019, 00:12:42 »
Das Problem konnte durch einen Wechsel von MQTT auf MQTT2_Client gelöst werden.
Hier die Infos dazu
https://forum.fhem.de/index.php/topic,103762.15.html

Hallo, ich habe Probleme mit einer Osram Farbirne.

Autocreate hat funktioniert, Birne wurde erkannt, An, Aus, Brightness funktioniert, ABER die Farbe klappt nicht....

defmod 0x7cb03eaa00ae3c80 XiaomiMQTTDevice AC03645 0x7cb03eaa00ae3c80
attr 0x7cb03eaa00ae3c80 IODev MQTT
attr 0x7cb03eaa00ae3c80 alias BeneBirne
attr 0x7cb03eaa00ae3c80 room XiaomiMQTTDevice
attr 0x7cb03eaa00ae3c80 webCmd on:off:brightness
attr 0x7cb03eaa00ae3c80 widgetOverride brightness:colorpicker,BRI,0,1,254

setstate 0x7cb03eaa00ae3c80 OFF
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 brightness 254
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 color-x 0.3805
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 color-y 0.3769
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 color_mode 2
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 color_temp 300
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 linkquality 84
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 state OFF
setstate 0x7cb03eaa00ae3c80 2019-09-20 23:54:59 transmission-state incoming publish received


In einigen Diskussionsthemen wird beschrieben ein Template anzuwenden, aber dies funktioniert bei mir nicht...... warum ????
« Letzte Änderung: 26 September 2019, 08:50:07 von Müller »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #1 am: 21 September 2019, 00:17:08 »
In einigen Diskussionsthemen wird beschrieben ein Template anzuwenden, aber dies funktioniert bei mir nicht...... warum ??? ?
Das klappt deswegen nicht, weil es Templates bislang nur für die Einbindung als MQTT2_DEVICE gibt.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #2 am: 21 September 2019, 09:35:11 »
Hallo, danke für die Rückmeldung.
ich habe nach dieser Anleitung installiert:

http://wiki.gorjup.de/doku.php?id=public:fhem_zigbee_cc2531

Wenn ich es richtig verstehe, habe ich damit schon "zigbee2mqtt" installiert. In FHEM heißt es nur noch MQTT. Wo bin ich denn falsch abgebogen, bzw. was muß ich ergänzen ?

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #3 am: 21 September 2019, 10:54:29 »
Nicht falsch abgebogen, nur "anders". Siehe wiki zu MQTT bzw. Praxisbeispiele zu MQTT2_DEVICE.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #4 am: 21 September 2019, 11:28:33 »
Kann man einfach MQTT löschen (delete device) und MQTT2_server definieren, oder mache ich mir dann etwas kaputt?

Offline binford6000

  • Tester
  • Hero Member
  • ****
  • Beiträge: 1073
  • 🏠⚙️💡🛠📱
Antw:Osram Zigbee Farbbirne
« Antwort #5 am: 21 September 2019, 11:32:40 »
Ich würde noch den mosquitto daemon stoppen / deaktivieren.
VG Sebastian
FHEM 5.9 auf Ubuntu LTS-LXC unter Proxmox, IOserver für deconz + CUL via ser2net, Testumgebung: docker pull fhem/fhem
SONOS, alexa-fhem, homebridge, TelegramBot mit msgDialog, livetracking

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #6 am: 21 September 2019, 14:21:56 »
bevor ich nun das ganze umstelle.

Kann man mit dem MQTT keine Farbbefehle an die Birne schicken? (ich würde mir das ganze auch manuell einrichten, brauche nicht unbedingt ein template.)

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #7 am: 21 September 2019, 19:47:39 »
Sollte an sich gehen. Ob mit dem Modul, das du da einsetzt, kann ich nicht sagen. (Ist nicht offiziell...). Siehe Dokumentationsstruktur im wiki.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #8 am: 22 September 2019, 10:55:38 »
Also nun habe ich folgendes durchgeführt:

terminal : sudo service mosquitto stop
FHEM: define MQTT2 MQTT2_CLIENT 127.0.0.1:1883
terminal:sudo service mosquitto start

dann die alten DInge entfernt
und  MQTT2      set attrTemplate    MQTT2_CLIENT_general_bridge eingestellt.

Wenn ich nun bei meinen bisherigen zigbee Lampen bei iODev von MQTT auf MQTT2 ändere, kann ich auch die Lampen schalten. Also funktioniert die UMstellung.

ABER ich möchte ja auch die Farbfunktion nutzen, also habe ich
https://wiki.fhem.de/wiki/MQTT2-Module_-_Praxisbeispiele#Vereinzeln_der_eigentlichen_Ger.C3.A4te

die Vorgaben für die IkeaLampe genommen und meine LampenNummer eingesetzt

setList
on:noArg zigbee_pi:zigbee2mqtt/0x7cb03eaa00ae3c80/set {"state":"ON"}\
off:noArg zigbee_pi:zigbee2mqtt/0x7cb03eaa00ae3c80/set {"state":"OFF"}\
brightness:colorpicker,BRI,0,15,255 zigbee_pi:zigbee2mqtt/0x7cb03eaa00ae3c80/set {"state":"on","$EVTPART0":"$EVTPART1"}

readingList
zigbee_pi:zigbee2mqtt/0x7cb03eaa00ae3c80:.* { json2nameValue($EVENT) }
model
L_02a_zigbee2mqtt_bulb

IODev MQTT2_DEVICE
leider läßt sich hier nix schalten. Ich vermute mal dass IODev falsch sein könnte

Meine attrTemplate Liste sieht noch sehr kurz aus, muß man hier noch etwas laden ?
(L_02a_zigbee2mqtt_bulb fehlt.... )
« Letzte Änderung: 22 September 2019, 11:36:43 von Müller »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #9 am: 22 September 2019, 11:49:41 »
Da sollten mehr templates zu sehen sein, es gibt auch welche für farbige Leuchtmittel usw..

Habe vorhin eine aktualisierte Fassung der file ins svn geschubst, das ab morgen per update geladen wird. warum nur ein Teil angezeigt wird, muß ich mir noch ansehen, wenn das weiter der Fall ist (du bist einer der wenigen, die den CLIENT nutzen und wenig MQTT-Erfahrung haben. Kann gut sein, dass da noch Optimierungsmöglichkeiten bestehen...).

Das Wiki hinkt grade leicht hinter der Entwicklung her, muß ich mir auch nochmal im Detail ansehen.

Gruß, Beta-User
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #10 am: 22 September 2019, 12:10:08 »
Danke Beta user

aber an/aus sollte doch auch ohne template gehen ? welche Einstellung könnte nicht passen?

nächstes Problem. Das stateIcon wird nicht mehr aktualisiert ??? Der "STATE" wird nicht mehr aktualisiert, aber die LAmpe lässt sich noch schalten.
« Letzte Änderung: 22 September 2019, 14:10:36 von Müller »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #11 am: 22 September 2019, 18:08:35 »
Klar sollte das klappen, aber du hast recht, dass das IO falsch ist. Das heißt MQTT2 bei dir, oder? Und auch die vielen CID-Einträge kommen mir komisch vor.

Versuchs mal mit einem einfachen direkten publish über das IO:
set MQTT2 publish zigbee2mqtt/0x7cb03eaa00ae3c80/set {"state":"ON"}
(Das will ich eigentlich im Wiki dann für alle Devices empfehlen, die nicht automatisch senden: über das Bridge-Gerät abfragen, was alles da ist, und was nicht automatisch angelegt wird: publish wie oben...

Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Müller

  • Full Member
  • ***
  • Beiträge: 101
Antw:Osram Zigbee Farbbirne
« Antwort #12 am: 25 September 2019, 18:15:03 »
Hallo,

(leider war ich die Tage etwas krank und habe dies hier mal liegen lassen.)
Das mit den alten MQTT alles funktionierte außer die Farbbirne, hatte die die Umstellung nochmal zurückgestellt.

Nun möchte ich doch den Umstieg wagen.
Und bin auch noch über diesen Wiki gestolpert:
https://wiki.fhem.de/wiki/EBUS-MQTT2

Kann es sein, dass ein Teil der Templates gefehlt hatten, weil ich keinen EBUS installiert hatte? Oder das Mustertemplate nicht installiert habe?
(Die Infos im Netz sind leider etwas fragmentiert und es ist auch schwer ersichtlich, was die aktuelle empfohlene Methode ist).

Wenn ich nun nach diesem Wiki vorgehe, muß ich die einzelnen Lampen "vereinzeln" oder wurde dies zwischenzeitlich verbessert ?

Nachtrag:
Ich lese mal diesen Beitrag in Ruhe durch (und versuche ihn zu verstehen.....)
https://forum.fhem.de/index.php/topic,103762.0.html
« Letzte Änderung: 25 September 2019, 19:43:01 von Müller »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7960
  • eigentlich eher user wie "developer"
Antw:Osram Zigbee Farbbirne
« Antwort #13 am: 25 September 2019, 21:49:39 »
Ist eine gute Idee, erst mal den anderen Thread zu studieren, auch wenn der dortige TE sich erst mal noch gar nicht mit der zigbee2mqtt-Ecke befaßt hat.

Ganz kurz: Welche templates man jeweils sieht, hängt von dem jeweiligen Filter ab. Es soll tendenziell nur angezeigt werden, was auch Sinn macht. Keinen Sinn macht es z.B., für ein Device, das eine readingList hat, die für zigbee2mqtt typisch ist, dann auch alle templates anzuzeigen, die es für Tasmota- oder MiLight-Hub-Geräte gibt.

Wenn du also nicht alles siehst, ist das vermutlich darauf zurückzuführen (den jeweiligen Filter kann man aus dem Quellcode der file leicht ablesen).

Von daher ist es auch nicht erforderlich, hier nach templates zu schauen, die wieder für was völlig anderes sind (ebus).

Und es macht auch Sinn, jede Leuchte zu "vereinzeln" und extra Devices für Gruppen anzulegen usw.. Aber das Vereinzeln sollte automatisch ablaufen (erfordert aber ein autocreate-Gerät, aktiviertes autocreate am IO (was für MQTT2_CLIENT nicht ganz so einfach ist wie für MQTT2_SERVER) und ggf. beim Device, das als "Brücke" dient (das mit der bridgeRegexp); das scheinst du aber entgegen der Anleitung gar nicht angelegt zu haben (aktueller template-Name: zigbee2mqtt_bridge)).
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6817
Antw:Osram Zigbee Farbbirne
« Antwort #14 am: 26 September 2019, 16:40:08 »
Hm, eine Farbbirne ist das, was man bekommt, wenn man zu lange in der Sonne war.

LG

pah
Gefällt mir Gefällt mir x 1 Liste anzeigen