Autor Thema: MDT Glastaster 2, Probleme mit Meldung  (Gelesen 334 mal)

Offline alterSchwede

  • Newbie
  • Beiträge: 1
MDT Glastaster 2, Probleme mit Meldung
« am: 25 September 2019, 10:40:48 »
Hallo,

ich bin gerade dabei, mich in die KNX Welt einzuarbeiten. Die Ansteuerung über FHEM funktioniert schon bestens. Jetzt spiele ich mit dem MDT Glastaster Smart herum und habe ein Problem bei der Meldungsfunktion des Tasters.

Der Taster zeigt die gesendete Meldung korrekt an. Um diese Meldung nun zu löschen gibts es 2 Möglichkeiten:
1. durch berühren einer Taste
2. durch ein Telegram mit dem Inhalt 00 00 00 00 00 00 00 00 00 00 00 00 00 00 an den Meldungseingang des Taster im dpt16 Format ( auch erst möglich mit der neuen Rev 2.0 möglich)

Dieses Telegramm bekomme ich aber nicht mit dem Set Befehl des 10_KNX.pm Modul versendet, da es keine leere Eingabe akzeptiert. Mithilfe der ETS kann ich ein leeres Telegramm verschicken, sodass ich es testen konnte.

Ich habe mich etwas im 10_KNX Modul umgeschaut und bin auf einen RAW cmd gestoßen, mit dem es ja evtl möglich wäre, das benötigte Telegramm zu verfassen. Leider bin ich noch zu unerfahren um herauszufinden, wie ich diese RAW Funktion nutzen könnte.

Würde mich sehr über Hilfe freuen!

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1557
Antw:MDT Glastaster 2, Probleme mit Meldung
« Antwort #1 am: 03 Oktober 2019, 08:47:14 »
Ich habe das leider auch nur über einen Workaround mit einer externen Logikengine aktuell gelöst.
FHEM schickt "0" an eine GA, woraufhin diese dann "" auf die tatsächliche GA sendet.
Sorry, hab keine bessere Lösung aktuell.
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

 

decade-submarginal