Autor Thema: Kleine Ungenauigkeit in der Commandref devStateIcon  (Gelesen 458 mal)

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 13815
  • schon mal restore trainiert?
    • Otto's Technik Blog
Kleine Ungenauigkeit in der Commandref devStateIcon
« am: 28 September 2019, 18:00:09 »
Hallo Rudi,

ganz am Anfang heisst es:
Zitat
If the state of the device matches regexp, then icon-name will be displayed as the status icon in the room, and (if specified) clicking on the icon executes cmd. If fhem cannot find icon-name, then the status text will be displayed.
Ich habe da schon immer meine Probleme mit dem Sprachgebrauch in vielen Beschreibungen gehabt :)

STATE state State status Status Zustand usw.

Aber das erste "state" oben im Text muss doch korrekterweise "STATE" heissen oder?

Und im deutschen
Zitat
Wenn der Zustand des Gerätes mit der regexp übereinstimmt, wird als icon-name das entsprechende Status Icon angezeigt, und (falls definiert), löst ein Klick auf das Icon das entsprechende cmd aus. Wenn fhem icon-name nicht finden kann, wird der Status als Text angezeigt.
würde ich dort auch STATE schreiben.

Bei dem jeweils zweiten Begriff, naja das kann man vielleicht anders sehen. Aber ich würde dort auch STATE schreiben, da wäre es eindeutig. (und für Viele hier im Forum ist der Unterschied zwischen Groß und Klein und STATE und state und Internal und Reading alles Andere als eindeutig :))

Gruß Otto
« Letzte Änderung: 28 September 2019, 18:16:21 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 8472
  • eigentlich eher user wie "developer"
Antw:Kleine Ungenauigkeit in der Commandref devStateIcon
« Antwort #1 am: 28 September 2019, 18:07:53 »
Ähm,

der Hinweis auf STATE sollte passen, aber wenn schon, sollte man das nicht dahin konkretisieren, dass die Regex _zeilenweise_ prüft (es sind mehrere Icons möglich...)?

(Habe das nur auf die Schnelle gesehen und nicht intensiv drüber nachgedacht, kann auch sein, dass ich da falsch liege; einen konkreten Formulierungsvorschlag habe ich grade auch nicht, kann mir aber gerne Gedanken machen, wenn gewünscht).

Gruß, Beta-User
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 13815
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:Kleine Ungenauigkeit in der Commandref devStateIcon
« Antwort #2 am: 28 September 2019, 18:10:50 »
Du bist wie immer sehr schnell :)

An der Stelle (weiter hinten )  steht es doch
Zitat
Note: The above is valid for each line of STATE. If STATE (through stateFormat) is multilined, multiple icons (one per line) will be created.
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266
Zustimmung Zustimmung x 1 Liste anzeigen

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21232
Antw:Kleine Ungenauigkeit in der Commandref devStateIcon
« Antwort #3 am: 29 September 2019, 10:42:29 »
Danke fuer den Hinweis, ich habe state/status/Zustand/Status durch STATE ersetzt.