Verschiedenes > Bastelecke

MyAVR

<< < (2/2)

UweH:
Moin,

hier gibt's auch nette Spielzeuge: https://www.olimex.com/Products/PIC/Development/PIC-WEB/.
Auf Microchip kann man sich den dazugehörigen TCP/IP-Stack laden.

dougie:

...MyAVR ist ein guter Laden! Ich verwende ausschliesslich deren USB Programmer, weil ich damit gute Erfahrungen gemacht habe.

Du kannst auch direkt bei denen kaufen:

http://shop.myavr.de/index.php?sp=artlist_kat.sp.php&katID=15


VG
Ralf

PS: die TWI/I2C Module bei denen im Shop sind sogar von mir. Hab ich denen mal vor vielen Jahren zusammmen mit rudimentären AVR Assembler Bibliotheken geschenkt :-)

Puschel74:
Hallo,

ich hab die Teile dann auch bei AVR direkt bestellt - inkl. des TWI/I2C Paketes ;-)

Linux ist in der VM schon auf dem aktuellen Stand um Ethersex dann drauf zu spielen ...
wenn das Spielzeug dann endlich kommt ^^

Bin schon gespannt wie sich der myAVR neben dem NET-IO schlägt.
Wobei das ja beinahe unfair ist - am NET-IO kann man recht einfach den Atmega tauschen.

Grüße

Puschel74:
So. Mal ein kleines Update nach knapp 2 Monaten ;-)

Endlich hatte ich mal etwas Zeit und konnt mich mit meinem myEthernet mit myTWI etwas beschäftigen.

Vorweg schonmal:

Die Temperatur wird angezeigt - aber noch nicht in fhem.

Ich bin schon froh das ich endlich mal die Teile zusammen stecken und mit der beiliegenden Software resp. der myEthernet hat ja ein config-file auf der micro-SD in der nur die IP angepasst werden
braucht in Betrieb nehmen konnte.
Der Rest (html) ist dann auf der micro-SD vorhanden und lässt sich über den Browser bedienen.

So weit. So gut.
Eigentlich wollten wir ja ethersex drauf flashen.
Also Such-Riese angeworfen und siehe da - http://www.mail-archive.com/ethersex-devel@list.zerties.org/msg00594.html
Da hat es doch schon jemand geschafft ethersex für den myEthernet zu kompilieren - am 14.Juni 2010.

Also gut.
Dann werd ich mal in Tiefen der Micro-Controller abtauchen und mich mal versuchen schlau zu lesen.

Vllt. hat von Euch ja jemand einen Tipp wie es zumindest mit der Load Default Configuration in ethersex aussieht.
Der avrnetio kann es ja nicht sein also bleibt nur "other" und dann alles selbst einstellen.
Ich werd mir mal die Datenblätter zurecht legen und mich zur Not im anderen Board noch anmelden.

Bis demnächst (hoffentlich nicht in 2 Monaten)

Grüße

Edith:
Nachtrag: Der Suchriese hat mich auf die ethersex-devel gebracht und dort gibt es einen Beitrag "Gelöst Default-Image für das myAVR myEthernet".
Allerdings schon aus dem Jahre 2010.
Leider wird nicht die komplette Vorgehensweise zum kompilieren der Firmware beschrieben - ich bin mit Hr. Terpe bereits in Mail-Kontakt getreten.
Er hat mir schon mitgeteilt das Ethersex auf dem kleinen Board wunderbar funktioniert hat - er ist seine Unterlagen am zusammen suchen um mir diese
(hoffentlich) zur Verfügung zu stellen.

Edith2: Gestern habe ich eine Mail von Hr. Terpe bekommen mit der "Doku" für den myEthernet für ethersex.
Ordner control6, pinning und MyethernetVC6.config - mit dem Hinweis diese in den ethersex-Ordner zu kopieren.
Dies werde ich heute nachmittag mal machen und schauen was ethersex dazu sagt - update folgt.

Navigation

[0] Themen-Index

[*] Vorherige Sete

Zur normalen Ansicht wechseln