FHEM > Sonstiges

errors--compilation seit heute Morgen?

(1/2) > >>

dougie:
Moin zusammen,

hab heute morgen ein Update gefahren. Auf meinem RPi alles ok, nur fhem auf meiner FB kommt nicht mehr hoch.
Hab ich was kaputt gemacht? :-)

VG
Ralf

# /var/InternerSpeicher/fhem/startfhem
Type of arg 1 to keys must be hash or array (not hash element) at fhem.pl line 1
444, near "})"
BEGIN not safe after errors--compilation aborted at fhem.pl line 1574.
#

klaus.schauer:
Auch auf meiner FRITZ!Box 7390 ist das Update fehlgeschlagen. Die neue Version 2533 von fhem.pl liefert den Fehler:

Type of arg 1 to keys must be hash or array (not hash element) at fhem.pl line 1444, near "})"
BEGIN not safe after errors--compilation aborted at fhem.pl line 1574.

Mit der bisherigen Version 2505 start Fhem wieder!

rudolfkoenig:
Habs (hoffentlich) gefixed, und fuer update bereitgestellt. Ich vermute der Autor der Aenderung hat es nur mit einem "sehr" neuen perl getestet. Dass er das gar nicht getestet hat, kann ich mir gar nicht vorstellen :)

dougie:


Danke Rudolf, läuft! :-)

VG
Ralf

Dietmar63:
ich habe ein Fritzbox 7270.
FHEM 5.3 läuft schon recht lang ohne große Probleme.

ich wollte heute mal mit "update stable" die neueste Verion ziehen.

Leider bekomme ich einen Fehler:

--- Zitat ---Can't read remote Release Informations. Update canceled now

2013.01.20 22:14:42 1: update The operation was canceled, while checking the remote Release.
2013.01.20 22:14:42 3: update get http://fhem.de/fhemupdate4/stable/FHEM/FhemUtils/release.pm

--- Ende Zitat ---


Kann man die 7270 überhaupt so auffrischen? Oder handelt es sich um ein temporäres Problem?

Dietmar

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln