Autor Thema: 18B20 Sensor funktioniert über RJ 45 nicht  (Gelesen 4789 mal)

Offline mbeckerkassel

  • New Member
  • *
  • Beiträge: 16
18B20 Sensor funktioniert über RJ 45 nicht
« am: 15 Oktober 2019, 06:45:02 »
Hallo,

ich möchte der Ordnung haber meinen 1Wire Bus neu verkabeln.

Mein 18B20 Sensor selbst funktioniert (am Raspberry PI Breadboard getestet). Am gleichen bis waren auch vorher 8 Sensoren ohne Probleme. Einfach ins Breadboard gesteckt. Alles ok.

Aber über RJ45 funktioniert mein 18B20 nicht.

Dafür habe ich

20x-RJ45-Stecker-Lan-Stecker-CAT-7-6-8-zur-werkzeuglose-Montage-Knickschutz
und
PATCHPANEL 8 Mini-Patchpanel, 8-Port, Cat.5, 1 HE
https://www.reichelt.de/mini-patchpanel-8-port-cat-5-1-he-patchpanel-8-p33723.html?PROVID=2788&gclid=Cj0KCQjwuZDtBRDvARIsAPXFx3DfDJHj7nOMEzJEIH_qQq1_gKhNtqcVzBrmkKuSooXtfX_qIY9zLmwaAuZVEALw_wcB&&r=1

gekauft.

Als Kabel habe ich normales Fernmeldekabel genommen.

Im nächsten Schritt habe ich bei dem Patchpanel alle Ports gleichgeschaltet und dies mit einem Messgerät (normales Messgerät für Netzwerkkabel) durchgetestet.
Nur um sicher zu gehen das auf allen Ports, Pin 1..8 auch da ankommen wo sie sollen.

Mein 18B20 Sensor funktioniert über RJ 45 angeschlossen nicht!

Spannung zwischen (VDD und GND) / (Data / GND) stimmen auf dem Breadboard exakt mit dem über RJ45 überein.

Ich habe auf dem Breadboard, da wo vorher meine 18b20 waren ein Kabel zum Patchpanel RJ45(PIN 1 VDD, PIN 2 Data, PIN 3 GND) gesteckt.

und den Sensor
RJ45(PIN 1 VDD, PIN 2 Data, PIN 3 GND) auch ins Panel gesteckt.

Der Sensor wird nicht gefunden.

Was habe ich falsch gemacht?

Foto 1 funktioniert.

Foto 2 funktioniert nicht (das rote kabel ist mir fürs Foto abgegangen)

« Letzte Änderung: 15 Oktober 2019, 07:11:11 von mbeckerkassel »

Offline Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3736
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #1 am: 15 Oktober 2019, 06:58:22 »
Vergleiche mal die pinbelegung der rj45.
Die meisten sind nicht 12345678 sondern 12364578.

Gesendet von meinem S60 mit Tapatalk


Offline mbeckerkassel

  • New Member
  • *
  • Beiträge: 16
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #2 am: 15 Oktober 2019, 07:13:21 »
Vergleiche mal die pinbelegung der rj45.
Die meisten sind nicht 12345678 sondern 12364578.

Gesendet von meinem S60 mit Tapatalk

Ich habe Pin 1-3 genommen. Ich habe noch ein 2. Kabel wie das linke Kabel auf Bild 2 gemacht und das Ganze mit einem Voltmeter durchgemessen. Daran scheint es nicht zu liegen.

Offline Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3736
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #3 am: 15 Oktober 2019, 08:11:22 »
Grad nochmal das Bild angekuckt,
kann es sein dass bei den LSA+ leisten die Drähte nicht ganz drin sind?
man erkennt es nicht so gut da unscharf.

Offline sukram

  • New Member
  • *
  • Beiträge: 8
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #4 am: 15 Oktober 2019, 08:47:48 »
Probiere mal folgendes: ein kurzes (5-10cm) Stück von der Schwarzen Leitung der DS-Sensoren abschneiden, und mit einem Ende im RJ45 Stecker montieren. Dann am anderen Ende mal mit dem Multimeter durchpiepen, ob überhaupt Durchgang im Stecker ist. Ich denke, dass die Adern in der Leitung zu dünn sind für die Schneidklemmen der Stecker.

Ich habe mir einfache ungeschirmte RJ45 Pressstecker von Pollin (samt der billigen orangen Plastikzange...) dafür genommen und keine Probleme.

Offline mbeckerkassel

  • New Member
  • *
  • Beiträge: 16
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #5 am: 15 Oktober 2019, 10:22:19 »
Probiere mal folgendes: ein kurzes (5-10cm) Stück von der Schwarzen Leitung der DS-Sensoren abschneiden, und mit einem Ende im RJ45 Stecker montieren. Dann am anderen Ende mal mit dem Multimeter durchpiepen, ob überhaupt Durchgang im Stecker ist. Ich denke, dass die Adern in der Leitung zu dünn sind für die Schneidklemmen der Stecker.

Ich habe mir einfache ungeschirmte RJ45 Pressstecker von Pollin (samt der billigen orangen Plastikzange...) dafür genommen und keine Probleme.

Habe jetzt den Sensor an den RJ45 (Klingeldraht) per Lüsterklemme mit dem Sensor (zur Sicherheit Aderendhülsen benutzt) verbunden

Durchgang gemessen. OK (Piep). 3.31v zwischen vdd und Gnd, 3.31 v zwischen Data und Gnd. Sensor immer noch ohne Funktion!

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7221
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #6 am: 15 Oktober 2019, 16:34:57 »
Ich tippe auf einen Fehler beim Verdrahten. Einfach erst einmal aus Sicherheitsgründen die Spannungsversorgung weglassen, die Sensoren funktionieren auch parasitär.

LG

pah

Offline mbeckerkassel

  • New Member
  • *
  • Beiträge: 16
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #7 am: 21 Oktober 2019, 10:17:15 »
Hallo in die Runde,

ich habe das Problem gefunden. Es waren die werkzeuglosen RJ45 Stecker. Meine crimpbaren RF45 Stecker sind irgendwie zu klein für die Kabel. Hat hier jemand für mich eine Kaufempfehlung?

Vielen Dank nochmal für die schnelle Hilfe.

Michael

Offline maci

  • Sr. Member
  • ****
  • Beiträge: 520
  • ... und sie leben doch!
Antw:18B20 Sensor funktioniert über RJ 45 nicht
« Antwort #8 am: 02 November 2019, 19:21:18 »
Setze den Thread bitte auf gelöst!

Danke

Georg
Raspberry Pi3, UniPi Vers. 1.1 mit Raspberry Pi2, Netatmo Wetterstation + Regenmesser, Netatmo Thermostat, 1x ESP8266 1wire WLAN Bridge, HMLan, 2x HMLANGateway, Homematic, 2x owserver,