Autor Thema: [73_AutoShuttersControl.pm] Rolllos automatisiert steuern - Version 0.8.x  (Gelesen 75065 mal)

Offline --- Marko ---

  • New Member
  • *
  • Beiträge: 4
Ein Offset dürftest Du eigentlich gar nicht mehr haben wenn Das Modul aktuell bei Dir ist. Das sollte Version 0.8.12 sein.

Danke CoolTux! Das mit dem ASC_Drive_DelayStart probier ich mal.
Die aktuelle Version v0.8.12 habe ich. Jedoch gibt es im ASC-Device beide Attribute (ASC_shuttersDriveDelay und ASC_shuttersDriveOffset) zur Auswahl und aus diesem Pulldownmenü kann ich diese ja nicht so einfach entfernen, wie es bei einem Rollladen über die Userattribute gehen würde. Scheint mir so, als würde das noch fest im Modul drin stecken.

Gruß Marko

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
Danke CoolTux! Das mit dem ASC_Drive_DelayStart probier ich mal.
Die aktuelle Version v0.8.12 habe ich. Jedoch gibt es im ASC-Device beide Attribute (ASC_shuttersDriveDelay und ASC_shuttersDriveOffset) zur Auswahl und aus diesem Pulldownmenü kann ich diese ja nicht so einfach entfernen, wie es bei einem Rollladen über die Userattribute gehen würde. Scheint mir so, als würde das noch fest im Modul drin stecken.

Gruß Marko

Ah jetzt verstehe ich. OK im ASC Device selbst passt es, sorry falsch verstanden.


Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline --- Marko ---

  • New Member
  • *
  • Beiträge: 4
Wenn das Ok ist, bin ich jetzt wieder verwirrt. ;-) Wenn beim ASC-Device beide Attribute vorhanden und ok sind, wo ist da dann der Unterschied? In der CommandRef und im Wiki steht da immer die gleiche Beschreibung dazu.

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
OK bedeutet ich habe mir geschaut und das selbe festgestellt. Ich werde mir also heute anschauen müssen welches genau wie verwendet wird. Aktuell gehe ich von einem Fehler aus.

Aber davon ab brauchst Du die Attribute im ASC Device für Dein Vorhaben nicht. Mach die Einstellungen im Rollo Device und gut ist.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 316
Und wie schaut es aus?
Hallo
Wie es aussieht geht es nun bzw das Rollo bleibt in der Lüftung.
Schönen Sonntag
VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
OK bedeutet ich habe mir geschaut und das selbe festgestellt. Ich werde mir also heute anschauen müssen welches genau wie verwendet wird. Aktuell gehe ich von einem Fehler aus.

Aber davon ab brauchst Du die Attribute im ASC Device für Dein Vorhaben nicht. Mach die Einstellungen im Rollo Device und gut ist.

Ich habe eben geschaut und es war eine Art Bug. Ich hatte vergessen zu dokumentieren das ASC_shuttersDriveOffset obsolet ist.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline hartwiga

  • New Member
  • *
  • Beiträge: 25
Moin,

bei mir funktionier der external Trigger nicht. Ich habe mal in den Quellcode gesehen und glaube das Problem könnte in der Funktion 'CreateNewNotifyDev' liegen, da hat sich scheinbar beim external Trigger irgendwie der  'ASC_BrightnessSensor' eingeschlichen. Vielleicht magst Du es Dir mal bei Gelegenheit ansehen :-)

DANKE

Gruss Andreas


AddNotifyDev( $hash, AttrVal( $_, 'ASC_ExternalTrigger', 'none' ),
            $_, 'ASC_BrightnessSensor')
          if ( AttrVal( $_, 'ASC_ExternalTrigger', 'none' ) ne 'none' );
« Letzte Änderung: 12 Januar 2020, 10:20:04 von hartwiga »

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
Moin,

bei mir funktionier der external Trigger nicht. Ich habe mal in den Quellcode gesehen und glaube das Problem könnte in der Funktion 'CreateNewNotifyDev' liegen, da hat sich scheinbar beim external Trigger irgendwie der  'ASC_BrightnessSensor' eingeschlichen. Vielleicht magst Du es Dir mal bei Gelegenheit ansehen :-)

DANKE

Gruss Andreas


AddNotifyDev( $hash, AttrVal( $_, 'ASC_ExternalTrigger', 'none' ),
            $_, 'ASC_BrightnessSensor')
          if ( AttrVal( $_, 'ASC_ExternalTrigger', 'none' ) ne 'none' );

Hallo Andreas,

Vielen lieben Dank für die tolle Bugmeldung. Ich habe das gleich mal gefixt und ein Update kommt dann ab morgen früh 8 Uhr.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline hartwiga

  • New Member
  • *
  • Beiträge: 25
Hallo Andreas,

Vielen lieben Dank für die tolle Bugmeldung. Ich habe das gleich mal gefixt und ein Update kommt dann ab morgen früh 8 Uhr.

Super, perfekt... DANKE

Offline hartwiga

  • New Member
  • *
  • Beiträge: 25
Hallo,

bei mir verhält sich die Steuerung morgens so, dass wenn nach einen "timer privacy day open" ein "selfDefense absent active" kommt, die Rollläden zwar wie gewollt heruntergefahren werden, diese dann aber mit dem kurz danach folgenden "day open" wieder geöffnet werden. Ich hätte gehofft, dass diese dann geschlossen bleiben, bis sich der Hausstatus wieder auf "home" ändert !????

Gruß Andreas

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
Hallo,

bei mir verhält sich die Steuerung morgens so, dass wenn nach einen "timer privacy day open" ein "selfDefense absent active" kommt, die Rollläden zwar wie gewollt heruntergefahren werden, diese dann aber mit dem kurz danach folgenden "day open" wieder geöffnet werden. Ich hätte gehofft, dass diese dann geschlossen bleiben, bis sich der Hausstatus wieder auf "home" ändert !????

Gruß Andreas

Das ist ein alter Bug. Welche Version verwendest Du?


Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
Ich habe im Git im devel Branch eine Version mit einer SummaryFn. Dies ermöglicht es die zuvor benutze GetShuttersInformation ab zu lösen.
Bedeutet aber auch das alle weblink Instanzen welche GetShuttersInformation aufrufen entfernt werden sollten da es sonst eine Fehlermeldung gibt.

Anbei ein Screenshot und hier der Link zum Git
 https://github.com/fhem/AutoShuttersControl

Vielleicht mag der ein oder andere mal testen.

Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline xerion

  • Full Member
  • ***
  • Beiträge: 250
Ich habe im Git im devel Branch eine Version mit einer SummaryFn. Dies ermöglicht es die zuvor benutze GetShuttersInformation ab zu lösen.
Bedeutet aber auch das alle weblink Instanzen welche GetShuttersInformation aufrufen entfernt werden sollten da es sonst eine Fehlermeldung gibt.

Anbei ein Screenshot und hier der Link zum Git
 https://github.com/fhem/AutoShuttersControl

Vielleicht mag der ein oder andere mal testen.
Das kommt mir genau passend wollte mir gerade readings groups anlegen. Werde ich heute Abend versuchen einzuspielen.

Gesendet von meinem JSN-L21 mit Tapatalk


Offline hartwiga

  • New Member
  • *
  • Beiträge: 25
Das ist ein alter Bug. Welche Version verwendest Du?


Grüße

Ich nutze die Version v0.8.11


Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 23694
Ich nutze die Version v0.8.11

Bitte Update durchführen
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

 

decade-submarginal