Autor Thema: Anschluss S0-Stromzähler an 1W Zählermodul (Gelöst!)  (Gelesen 24538 mal)

Offline thomasg

  • New Member
  • *
  • Beiträge: 29
Anschluss S0-Stromzähler an 1W Zählermodul (Gelöst!)
« am: 22 November 2019, 07:41:13 »
Hi Zusammen,

ich die im Anhang gezeigte Kombination aus Zähler mit S0-Ausgang und 1W-S0-Zählermodul.
  • Der Stromzähler hat als S0-Ausgang + und -  - ich habe 2 Stück davon
  • Das 1W-Zählermodul hat Eingänge wie auf dem Bild gekennzeichnet sind mit A1, B1, C1?, ......

Wie Schließe ich da jetzt meine Stromzähler an? Habe leider keine Dokumentation.

Danke für Tipps
« Letzte Änderung: 24 November 2019, 11:52:32 von thomasg »

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4651
  • Are we just self-replicating DNA?
Antw:Anschluss S0-Stromzähler an 1W Zählermodul
« Antwort #1 am: 23 November 2019, 08:48:03 »
Hallo,

Du fragst sicher, weil es das Modul nicht mehr im Shop gibt und Du keine Anleitung hast.

Ich würde an Deiner Stelle im Shop fragen, ob Du noch eine Anleitung bekommen kannst.

Ansonsten würde ich raten: das Modul hat vier Zählereingänge und Du musst immer einen S0-Geber an A1/Masse, B1/Masse, A2/Masse, B2/Masse anschließen.

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline thomasg

  • New Member
  • *
  • Beiträge: 29
Antw:Anschluss S0-Stromzähler an 1W Zählermodul
« Antwort #2 am: 23 November 2019, 10:33:50 »
Hi,

ja - genau. Mangels Anleitung habe ich gefragt - ich dachte, es wäre ein Dual Counter = 2 Eingänge. Aber offensichtlich gibt es auf der Platine vier.

Ich habe das Modul jetzt in Betrieb genommen und meine Beiden Zähler (SDM120-PLS) angecshlossen. Und zwar so

A1/Masse --> S0 Zähler 1
B1/Masse --> S0 Zähler 2

Für den Zähler selbst habe ich noch ein passenderes Bild für die Anschlüsse gefunden (Siehe Anhang).

FHEM hat für den Zähler automatisch zwei OWCOUNT-Devices nach diesem Muster angelegt:

defmod OWX_1D_2FE084000003 OWCOUNT DS2423 2FE084000003
attr OWX_1D_2FE084000003 IODev 1wire
attr OWX_1D_2FE084000003 model DS2423
attr OWX_1D_2FE084000003 room OWX


 Allerdings bekomme ich beim auslesen der Zählerstände immer eine Fehlermeldung (Anhang). Auch im Fhem-Log werden komische Sachen bzgl OWX angezeigt:

2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 11 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 12 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 20 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 12 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:02 1: OWX_SER::Query 1wire:  0 of 11 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 10 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 11 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 12 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 20 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:03 1: OWX_SER::Query 1wire:  0 of 10 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:04 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:04 1: OWX_SER::Query 1wire:  0 of 19 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:04 1: OWTHERM: OWX_28_28E084000003 has returned invalid data of length 0
2019.11.23 10:31:04 1: OWXTHERM_BinValues:  OWX_28_28E084000003: invalid data length, 0 instead of 9 bytes,  0
2019.11.23 10:31:04 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:04 1: OWX_SER::Query 1wire:  0 of 10 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:05 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:05 1: OWX_SER::Query 1wire:  0 of 19 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 10:31:05 1: OWTHERM: OWX_28_26E084000003 has returned invalid data of length 0
2019.11.23 10:31:05 1: OWXTHERM_BinValues:  OWX_28_26E084000003: invalid data length, 0 instead of 9 bytes,  0

Wäre es besser alles auf OWSERVER umzustellen?

Viele Grüße


PS:

Ich habe mal noch etwas rumprobiert - sobald ich den Counter anschließe scheint mein 1W Bus zusammenzubrechen. Dann lassen sich auch keine anderen Temperaturfühler mehr auslesen - kommt immer irgendeine Fehlermeldung
« Letzte Änderung: 23 November 2019, 11:16:50 von thomasg »

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4651
  • Are we just self-replicating DNA?
Antw:Anschluss S0-Stromzähler an 1W Zählermodul
« Antwort #3 am: 23 November 2019, 11:23:52 »
Hallo,

sieht nach einem Busproblem aus.

Du hast die Spannung an V, Datenleitung an W1 und Masse an das Masse-Symbol angeschlossen?

Viele Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline thomasg

  • New Member
  • *
  • Beiträge: 29
Antw:Anschluss S0-Stromzähler an 1W Zählermodul
« Antwort #4 am: 23 November 2019, 11:37:20 »
Hi,

ja - habe ich. Ich habe jetzt einmal meinen 1W-Bus von meinem Denkovi-Adapter abgeklemmt und nur den Counter angeschlossen. Zwischen Counter und USB 1-W Adapter sind dann nur ca 2 Meter Kabel.

Das Abrufen des Counters hat einmal geklappt - jetzt bekomme ich immer die Meldung:

OWCOUNT: get OWX_1D_2EE084000003 counters failed, reason: OWCOUNT: Could not get values from device OWX_1D_2EE084000003, reason: 1D.2EE084000003.89 has returned invalid data of length 2OWCOUNT: Could not get values from device OWX_1D_2EE084000003, reason: 1D.2EE084000003.89 has returned invalid data of length 2


Außerdem bekomme ich im Log immer solche Meldungen - das könnte aber auch daran liegen, dass meine anderen 1W Devices jetzt vom Bus abgeklemmt sind aber nach wie vor in FHEM als Devices angelegt.

2019.11.23 11:38:26 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 11:38:26 1: OWX_SER::Query 1wire:  0 of 54 bytes in last attempt and state opened, this is an unrecoverable error
2019.11.23 11:38:26 1: OWX_SER::Query 1wire:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error

Hmmm .... Evtl hat das Kabel ja einen Knacks. Ich ersetzte das Teilstück mal durch ein anderes


Update - Habe jetzt mal OWSF konfiguriert - hier kann ich zumindest ohne Fehlermeldung einmal durchklicken. Allerdings ist der angezeigte Counterwert konstant was mich etwas irritiert.

« Letzte Änderung: 23 November 2019, 12:07:57 von thomasg »

Offline thomasg

  • New Member
  • *
  • Beiträge: 29
Antw:Anschluss S0-Stromzähler an 1W Zählermodul
« Antwort #5 am: 23 November 2019, 14:28:58 »
Ich habe es gecshafft .. ich kann jetzt Impulse empfangen. An der Seite des Zählers war ein Anschlussbild für zwei Impulsarten, das nicht mit dem aus dem Internet korrespondiert hat.

1: 1000imp/Exp kWh --> Hier hatte ich das Zählermodul erst angeschlossen ... Hierrüber gab es keine Impulse
2: 1000imp/Imp kWh  --> Nachdem ich den Counter hier angeschlossen hatte, ging es fleißig mit der Impulszählerei los

Jetzt hatte ich zwischenzeitlich auf OWServer umgestellt. Ist das notwendig, oder sollte ich wieder auf die 1Wire-Module aus FHEM gehen? Welchen Vorteil hat OWServer?

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7210
Antw:Anschluss S0-Stromzähler an 1W Zählermodul (Gelöst!)
« Antwort #6 am: 26 November 2019, 18:34:35 »
Ist Geschmackssache. OWCOUNT läuft sowohl mit OWServer, als auch mit OWX.


LG

pah