Autor Thema: Didn't get a Session ID Meldung (FRITZBOX Modul) bei Repeatern 1750e  (Gelesen 848 mal)

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 199
Hi,

habe leider auch immer wieder diese Logfiles in fhem habe.
Ich habe 3 von diesen Repeatern und alle haben das selbe verhalten.
Habe mal verbose auf 4 gemacht:

2019.11.29 10:59:38 4: FRITZBOX WZ.FritzRepeater: Readout_Start.718 Fork process FRITZBOX_Readout_Run_Web
2019.11.29 10:59:38 4: FRITZBOX WZ.FritzRepeater: Readout_Run_Web.1302 Prepare query string for luaQuery.
2019.11.29 10:59:38 4: FRITZBOX WZ.FritzRepeater: Web_OpenCon.4521 Open Web connection to 192.168.10.3
2019.11.29 10:59:43 4: FRITZBOX WZ.FritzRepeater: Web_OpenCon.4525 Web session opened with sid 24b43ed4814e1cdd
2019.11.29 10:59:44 4: FRITZBOX WZ.FritzRepeater: Readout_Run_Web.1751 Captured 96 values
2019.11.29 10:59:44 4: FRITZBOX WZ.FritzRepeater: Readout_Done.1770 Back at main process
2019.11.29 10:59:44 4: FRITZBOX WZ.FritzRepeater: Readout_Process.1792 Processing 88 readouts.
2019.11.29 10:59:44 4: FRITZBOX WZ.FritzRepeater: Readout_Process.1917 88 values captured in 6.00 s
2019.11.29 11:12:58 4: FRITZBOX WZ.FritzRepeater: Readout_Start.718 Fork process FRITZBOX_Readout_Run_Web
2019.11.29 11:12:58 4: FRITZBOX WZ.FritzRepeater: Readout_Run_Web.1302 Prepare query string for luaQuery.
2019.11.29 11:12:58 4: FRITZBOX WZ.FritzRepeater: Web_OpenCon.4521 Open Web connection to 192.168.10.3
2019.11.29 11:13:04 1: PERL WARNING: Use of uninitialized value $data in pattern match (m//) at FHEM/FritzBoxUtils.pm line 51.
2019.11.29 11:13:04 1: PERL WARNING: Use of uninitialized value $sid in pattern match (m//) at FHEM/FritzBoxUtils.pm line 52.
2019.11.29 11:13:04 2: FRITZBOX WZ.FritzRepeater: Web_OpenCon.4529 Web connection could not be established. Please check your credentials (password, user).
2019.11.29 11:13:04 2: FRITZBOX WZ.FritzRepeater: Readout_Run_Web.1376 Error: Didn't get a session ID
2019.11.29 11:13:04 4: FRITZBOX WZ.FritzRepeater: Readout_Done.1770 Back at main process
2019.11.29 11:13:04 4: FRITZBOX WZ.FritzRepeater: Readout_Process.1792 Processing 2 readouts.
2019.11.29 11:13:04 4: FRITZBOX WZ.FritzRepeater: Readout_Process.1801 Reset SID
2019.11.29 11:13:04 1: PERL WARNING: Use of uninitialized value $data in pattern match (m//) at FHEM/FritzBoxUtils.pm line 51.
2019.11.29 11:13:04 1: PERL WARNING: Use of uninitialized value $sid in pattern match (m//) at FHEM/FritzBoxUtils.pm line 52.


Das komische ist das es nicht immer dazu kommt. Ich kann alles Steuern und bekomme auch Meldungen aus dem Repeater, aber zwischendurch kommt eben diese Fehlermeldungen die mein Logfile zuspammen.

Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Eltako Enocean FGW14-USB / FAM14 / FTD 14 / FTS14TG / FSB14 / FSSA-230V
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
1-Wire Ds18b20, SIGNALduino, KNX

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5591
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul) bei Repeatern 1750e
« Antwort #1 am: 29 November 2019, 12:41:59 »
??? Verstehe ich richtig, dass Du den Repeater fragst, und erwartest, dass er genau so wie eine Fritzbox reagiert?
Warum fragst Du nicht direkt die FritzBox?
FHEM 5.9 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 199
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul) bei Repeatern 1750e
« Antwort #2 am: 29 November 2019, 12:47:30 »
Hi,

es hat immer geklappt bis diese in das Mesh system aufgenommen wurden.
Das hat den Grund das die Repeater auf verschiedenen Etagen sind und ich diese unterschiedlich schalte.
zB bei abwesendheit werden die oberen Etagen abgeschaltet und im EG nur das 5Ghz Wlan da der Signalduino sonst Probleme macht,
über die Fritzbox kann ich nur alles oder nichts.

Gruß
Porsti

PS: So sehe ich auch ob eine Probleme macht und vielleicht nicht online ist.

Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Eltako Enocean FGW14-USB / FAM14 / FTD 14 / FTS14TG / FSB14 / FSSA-230V
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
1-Wire Ds18b20, SIGNALduino, KNX

Offline FHEM_Mike

  • New Member
  • *
  • Beiträge: 4
Hi,

es hat immer geklappt bis diese in das Mesh system aufgenommen wurden.
Das hat den Grund das die Repeater auf verschiedenen Etagen sind und ich diese unterschiedlich schalte.
zB bei abwesendheit werden die oberen Etagen abgeschaltet und im EG nur das 5Ghz Wlan da der Signalduino sonst Probleme macht,
über die Fritzbox kann ich nur alles oder nichts.

Gruß
Porsti

PS: So sehe ich auch ob eine Probleme macht und vielleicht nicht online ist.

Gruß
Porsti

Hallo Porsti

Hast du dieses Problem inzwischen gelöst ? Ich habe sporadisch das gleiche Problem mit den 1750e Repeatern. Das Problem dabei ist,
dass wenn die Meldungen anfangen, der Repeater quasi aus dem Mesh "gekickt" wurde. Wenn ich in der Fritzbox ins Mesh schaue, ist
das Mesh Symbol bei dem entsprechenden Repeater verschwunden. Der Repeater funktioniert dann auch nicht mehr richtig, und man
kann nicht mehr per IP auf ihn zugreifen. Ein Neustart des Repeaters behebt das Problem. Wenn man wie ich eine Presence Erkennung
über WLAN macht, reicht es leider nicht nur die Fritzbox auszuwerten. Man muss dann auch die Repeater abfragen (meine Erfahrung).
Wenn ich den Repeater aus FHEM entferne, läuft er ohne Probleme und Ausfälle durch.

Gruß
Michael
 

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 199
Hallo Michael,

leider habe immer noch das problem und ich muss sagen das ich aufgegeben habe eine Lösung zu finden.
Ich dachte das ich nur dieses Problem habe und bei mir was nicht stimmt. Bis jetzt bist du ja hier erst der 2. der das gleiche Problem meldet.


Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Eltako Enocean FGW14-USB / FAM14 / FTD 14 / FTS14TG / FSB14 / FSSA-230V
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
1-Wire Ds18b20, SIGNALduino, KNX

Offline awel

  • Full Member
  • ***
  • Beiträge: 192
es hat immer geklappt bis diese in das Mesh system aufgenommen wurden.

Wenn man wie ich eine Presence Erkennung über WLAN macht, reicht es leider nicht nur die Fritzbox auszuwerten. Man muss dann auch die Repeater abfragen

Hallo Porsti und FHEM_Mike,
wir hatten das Problem schon vor einem Jahr im Thread FRITZ!WLAN Repeater 1750E -> Didn't get a session ID.

Meine Konfiguration besteht (inzwischen) aus der 6590 und zwei Repeatern 1750E in zwei Etagen mit aktueller Firmware.
Die Fritzbox läuft als Mesh-Master, die Repeater übernehmen automatisch alle Einstellungen aus dem Mesh, haben eigentlich keine individuellen Einstellungen.

Seit ich die drei Geräte permanent in einem stabilen Mesh habe, gibt es bei mir auch mit der Anwesenheitserkennung über WLAN keine Probleme mehr.
Ich werte auch nur die 6590 aus, die Repeater werden nicht abgefragt, da sie im Mesh absolut zuverlässig die Infos an die Basis liefern.

Ich schalte allerdings auch nicht Repeater im laufenden Betrieb ein und aus und habe (dadurch?) bei allen Geräten ein stabiles Mesh-Symbol.
Da muss also irgndetwas an eurer Installation oder eurer Nutzung nicht optimal sein.

Gruß
Achim
« Letzte Änderung: 25 Januar 2020, 12:41:46 von awel »

 

decade-submarginal