Autor Thema: Geplante Wartungsarbeiten am 15.12.2019  (Gelesen 7232 mal)

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3650
Geplante Wartungsarbeiten am 15.12.2019
« am: 02 Dezember 2019, 17:35:13 »
Hallo zusammen,

am Sonntag den 15.12.2019 wird die FHEM Infrastruktur zwischen 10:00 und 12:00 Uhr nur eingeschränkt zur Verfügung stehen aufgrund von anstehenden Wartungsarbeiten.

In diesem Zeitraum kann es zu Einschränkungen und temporärer Nichterreichbarkeit beim Zugriff auf FHEM-Dienste wie Forum, SVN, Wiki,  fhem.de sowie dem Alexa FHEM Connector kommen.

Für evtl. Fragen/Probleme steht dieser Thread allen zur Verfügung.

Wir bitten um euer Verständnis

Viele Grüße

Markus
« Letzte Änderung: 02 Dezember 2019, 21:15:55 von Markus Bloch »
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline Wzut

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3493
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #1 am: 02 Dezember 2019, 17:38:57 »
am Donnerstag den 15.12.2019
nach meinem Kalender : Sonntag :)
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline Amenophis86

  • Hero Member
  • *****
  • Beiträge: 2665
  • Anti-Statement befreite Zone ;)
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #2 am: 02 Dezember 2019, 20:35:47 »
Betreffen solche Arbeiten auch den Connector für Alexa?
FHEM auf Raspberry3, Betriebssystem Jessy, HMLan, HM Komponenten, LD382A, H801, Sonoff, Harmony Hub und vieles mehr. Einfach ein tolles universelles System

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22292
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #3 am: 02 Dezember 2019, 21:07:14 »
Ja.

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3650
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #4 am: 02 Dezember 2019, 21:14:11 »
Betreffen solche Arbeiten auch den Connector für Alexa?

Ja, leider. Wir werden den Server einmal durchstarten. Dadurch kommt es zu einer kurzen Unterbrechnung (wenige Minuten) der Alexa Tunnel.
« Letzte Änderung: 02 Dezember 2019, 21:17:54 von Markus Bloch »
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3650
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #5 am: 02 Dezember 2019, 21:15:05 »
nach meinem Kalender : Sonntag :)

Copy-Paste Fehler 8)  Danke Dir.

Gruß
Markus
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline Amenophis86

  • Hero Member
  • *****
  • Beiträge: 2665
  • Anti-Statement befreite Zone ;)
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #6 am: 03 Dezember 2019, 17:04:38 »
Sehe ihr habt es auch in die Meldung oben aufgenommen. Denke das macht Sinn, auch, wenn es nur kurz sein wird.
FHEM auf Raspberry3, Betriebssystem Jessy, HMLan, HM Komponenten, LD382A, H801, Sonoff, Harmony Hub und vieles mehr. Einfach ein tolles universelles System

Offline rakete123

  • Full Member
  • ***
  • Beiträge: 139
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #7 am: 11 Dezember 2019, 12:43:53 »
Etwas Off-Topic aber:
Mir ist aufgefallen, das ihr noch TLS 1.0 und TLS 1.1 anbietet. Ggf. sollte das abgeschaltet werden.
Dabei auch gleich die Cipher Suites für TLS 1.2 prüfen.

Siehe auch: https://wiki.mozilla.org/Security/Server_Side_TLS

Viele Grüße
Marcel
Zwave: ZMEEUZB1 (Fibaro, Aeotec, diverse)
Zigbee: Conbee (HUE, Xiaomi, osram)
Homematic: HM-MOD-RPI-PCB + diverse HM-CC-RT-DN
Sonstiges: Harmony, Android, Netatmo, Jabber (talk2fhem)
https://resize2fs.de

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3650
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #8 am: 15 Dezember 2019, 12:40:18 »
Hallo Marcel,

vielen Dank für den Hinweis. Habe ich im Rahmen der Arbeiten ebenfalls mit angepasst. TLSv1 sowie TLSv1.1 sind deaktiviert und die Ciphers wurden auf aktuell sichere geändert. Hoffen wir mal, dass es keine Klagen gibt ;-)

Viele Grüße

Markus
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22292
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #9 am: 15 Dezember 2019, 12:44:08 »
Vielen Dank fuer die Aktualisierung, aus meiner Sicht schaut alles gut aus.

Offline suchard

  • New Member
  • *
  • Beiträge: 14
Update-Probleme
« Antwort #10 am: 15 Dezember 2019, 13:16:41 »
Hallo,

kann leider keinen Update mehr durchführen:

2019.12.15 13:12:57 1 : https://fhem.de/fhemupdate/controls_fhem.txt: Can't connect(2) to https://fhem.de:443: SSL connect attempt failed error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Kann dies mit den Wartungsarbeiten in Zusammenhang stehen?
FHEM ist auf Raspberry installiert, dieser ist up-to-date.
Bin für Hinweise dankbar.

Viele Grüße

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3650
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #11 am: 15 Dezember 2019, 15:09:57 »
Hallo Suchard,

im Rahmen der Wartungsarbeiten wurden für sichere HTTP-Verbindungen (HTTPS) als unsicher geltende Protokollversionen (TLS 1.0/1.1) deaktiviert.

FHEM ist auf Raspberry installiert, dieser ist up-to-date.

Das muss ich leider bezweifeln. Offenbar benutzt du eine recht veraltete Version von Raspbian für die es wohl keine Updates für openssl gibt, welches TLS 1.2 unterstützt. Welche Raspbian Version genau benutzt du denn?

Ich selber habe auf meinem Raspberry Raspbian 8 (jessie) installiert. Ist zwar auch nicht mehr taufrisch, aber kann problemlos auf https://fhem.de/ zugreifen.

Viele Grüße

Markus
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline CarlosTT

  • New Member
  • *
  • Beiträge: 35
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #12 am: 15 Dezember 2019, 15:13:09 »
Ja, hab die gleiche Fehlermeldung. Hab zwar auch gestern fhem auf eine andere Diskstation umgezogen, aber da ich mit Ubuntu mit VMM arbeite, konnte es damit wohl weniger zusammenhängen.
Unter Ubuntu 16.04 tritt er auch auf.

Webbrowser Zugriff in Ubuntu funktioniert auch problemlos.
« Letzte Änderung: 15 Dezember 2019, 15:15:13 von CarlosTT »

Offline suchard

  • New Member
  • *
  • Beiträge: 14
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #13 am: 15 Dezember 2019, 15:16:48 »
Hallo Suchard,

im Rahmen der Wartungsarbeiten wurden für sichere HTTP-Verbindungen (HTTPS) als unsicher geltende Protokollversionen (TLS 1.0/1.1) deaktiviert.

Das muss ich leider bezweifeln. Offenbar benutzt du eine recht veraltete Version von Raspbian für die es wohl keine Updates für openssl gibt, welches TLS 1.2 unterstützt. Welche Raspbian Version genau benutzt du denn?

Ich selber habe auf meinem Raspberry Raspbian 8 (jessie) installiert. Ist zwar auch nicht mehr taufrisch, aber kann problemlos auf https://fhem.de/ zugreifen.

Viele Grüße

Markus



PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian


Linux RaspberryPi3 4.19.42-v7+ #1219 SMP Tue May 14 21:20:58 BST 2019 armv7l GNU/Linux



Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4333
Antw:Geplante Wartungsarbeiten am 15.12.2019
« Antwort #14 am: 15 Dezember 2019, 15:50:30 »
relativ aktuelles Raspbian stretch buster macht keine Probleme.
Edit: sollte buster heißen. Muss ich mich noch dran gewöhnen.  ::)
« Letzte Änderung: 15 Dezember 2019, 15:53:46 von KölnSolar »
RPi3/2 buster/stretch-SamsungAV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)-PCA301(S'duino)-Deebot(mqtt2)

 

decade-submarginal