Autor Thema: [Gelöst] Keine Verbindung zu FHEM  (Gelesen 1783 mal)

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
[Gelöst] Keine Verbindung zu FHEM
« am: 08 Dezember 2019, 11:52:17 »
Morgen Syrex-o

ich versuche mich gerade an FhemNative.
Ich bin nach deiner Anleitung https://github.com/Syrex-o/FhemNative#external-websocket-installation.
Aktuell habe ich den Zustand, dass beim Starten der App gesagt wird "Verbindung zu FHEM hergestellt"
aber das Widget (Button) sagt mit "Keine Verbindung zu FHEM, ..:"

Habe ich debug-Möglichkeiten um das Problem bei mir zu lokalisieren.

Ich hatte vor 2 Wochen schon mal getestet und da wurden alle Räume gelesen und ein Button hat funktioniert.
Jetzt geht es irgend wie nicht mehr.

Zwischendurch gefühlt nur ein fhem Update gemacht.
In Android und Windows gleiches Verhalten

Gruß
Michael
 
« Letzte Änderung: 06 Januar 2020, 17:42:07 von MichaelT »
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline Syrex-o

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 602
  • FhemNative
Antw:Keine Verbindung zu FHEM
« Antwort #1 am: 09 Dezember 2019, 12:31:05 »
Morgen Syrex-o

ich versuche mich gerade an FhemNative.
Ich bin nach deiner Anleitung https://github.com/Syrex-o/FhemNative#external-websocket-installation.
Aktuell habe ich den Zustand, dass beim Starten der App gesagt wird "Verbindung zu FHEM hergestellt"
aber das Widget (Button) sagt mit "Keine Verbindung zu FHEM, ..:"

Habe ich debug-Möglichkeiten um das Problem bei mir zu lokalisieren.

Ich hatte vor 2 Wochen schon mal getestet und da wurden alle Räume gelesen und ein Button hat funktioniert.
Jetzt geht es irgend wie nicht mehr.

Zwischendurch gefühlt nur ein fhem Update gemacht.
In Android und Windows gleiches Verhalten

Gruß
Michael

Hey,

Der Port ist richtig?
Hast du die richtige websocket in der App ausgewählt?
Die externe websocket läuft korrekt?

Beste Grüße

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
Antw:Keine Verbindung zu FHEM
« Antwort #2 am: 09 Dezember 2019, 19:23:18 »
Hi,

danke für deinen schnellen Support!

Port sollte richtig sein.
Internals:
   CONNECTS   18
   DEF        8080 global
   FD         42
   FUUID      5dd2e638-f33f-a152-ca3a-d43ab8ef56f935b1
   NAME       wsPort
   NOTIFYDEV  global
   NR         489
   NTFY_ORDER 50-wsPort
   PORT       8080
   STATE      Initialized
   TYPE       websocket
   global     global
   port       8080
   READINGS:
     2019-12-01 16:41:41   state           Initialized
   onclose:
     HASH(0x50e6978):
       arg:
         FUUID      5dd2e651-f33f-a152-f9f9-1d984e19b9b27c4b
         IODev      wsPort
         NAME       wsPort_json
         NOTIFYDEV 
         NR         490
         NTFY_ORDER 50-wsPort_json
         STATE      ???
         TYPE       websocket_json
         resource   /
         typeSubscriptions:
         websockets:
   onopen:
     HASH(0x50e6978):
       arg:
         FUUID      5dd2e651-f33f-a152-f9f9-1d984e19b9b27c4b
         IODev      wsPort
         NAME       wsPort_json
         NOTIFYDEV 
         NR         490
         NTFY_ORDER 50-wsPort_json
         STATE      ???
         TYPE       websocket_json
         resource   /
         typeSubscriptions:
         websockets:
Attributes:
   room       GUI
   verbose    0

Seltsam ist für mich, dass am Anfang die Meldung kommt, "Verbindung hergestellt..".
Websocket ist in fhemNative eingestellt.
Bei Anlegen eines Widgets ist Device und Reading grün.

Kann ich den Websocket testen?

Gruß
Michael
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline Syrex-o

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 602
  • FhemNative
Antw:Keine Verbindung zu FHEM
« Antwort #3 am: 10 Dezember 2019, 10:04:31 »
Hi,

danke für deinen schnellen Support!

Port sollte richtig sein.
Internals:
   CONNECTS   18
   DEF        8080 global
   FD         42
   FUUID      5dd2e638-f33f-a152-ca3a-d43ab8ef56f935b1
   NAME       wsPort
   NOTIFYDEV  global
   NR         489
   NTFY_ORDER 50-wsPort
   PORT       8080
   STATE      Initialized
   TYPE       websocket
   global     global
   port       8080
   READINGS:
     2019-12-01 16:41:41   state           Initialized
   onclose:
     HASH(0x50e6978):
       arg:
         FUUID      5dd2e651-f33f-a152-f9f9-1d984e19b9b27c4b
         IODev      wsPort
         NAME       wsPort_json
         NOTIFYDEV 
         NR         490
         NTFY_ORDER 50-wsPort_json
         STATE      ???
         TYPE       websocket_json
         resource   /
         typeSubscriptions:
         websockets:
   onopen:
     HASH(0x50e6978):
       arg:
         FUUID      5dd2e651-f33f-a152-f9f9-1d984e19b9b27c4b
         IODev      wsPort
         NAME       wsPort_json
         NOTIFYDEV 
         NR         490
         NTFY_ORDER 50-wsPort_json
         STATE      ???
         TYPE       websocket_json
         resource   /
         typeSubscriptions:
         websockets:
Attributes:
   room       GUI
   verbose    0

Seltsam ist für mich, dass am Anfang die Meldung kommt, "Verbindung hergestellt..".
Websocket ist in fhemNative eingestellt.
Bei Anlegen eines Widgets ist Device und Reading grün.

Kann ich den Websocket testen?

Gruß
Michael

Liegt es nur am Button? Hast du schon andere Komponenten versucht?

Du kannst die Logging Funktion mal verwenden, jedoch scheint alles gut zu sein, wenn alles akzeptiert wird und das device und reading gefunden wird.

Beste Grüße

Offline sinus61

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Keine Verbindung zu FHEM
« Antwort #4 am: 12 Dezember 2019, 14:44:53 »
Ich würde ja einfach mal FHEMWEB nutzen. Das läuft bei mir bestens, zumindest solange man nicht beim Start alle Geräte laden lässt sondern nur diejenigen die man in Komponenten nutzt.

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
Antw:Keine Verbindung zu FHEM
« Antwort #5 am: 15 Dezember 2019, 22:26:49 »
Sorry, kann aktuell nicht testen. Melde mich wieder.
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline nanocosmos

  • Full Member
  • ***
  • Beiträge: 236
Antw:Keine Verbindung zu FHEM
« Antwort #6 am: 16 Dezember 2019, 15:48:44 »
Habe auch Probleme beim Verbinden.
Fhem läuft bei mir in einem Docker Container.
SSL (selbst erstelltes Zertifikat) und basic Auth ist an.
Fhem Native verbindet sich mit fhem und dann kommt direkt ein Timeout Fehler.

Hat jemand vielleicht eine Idee?

Besten Dank und viele Grüße
Daniel

Offline sinus61

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Keine Verbindung zu FHEM
« Antwort #7 am: 17 Dezember 2019, 15:33:39 »
War es nicht so, dass SSL trotz der vorhandenen Option derzeit noch nicht funktioniert?

Offline Syrex-o

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 602
  • FhemNative
Antw:Keine Verbindung zu FHEM
« Antwort #8 am: 18 Dezember 2019, 07:34:24 »
War es nicht so, dass SSL trotz der vorhandenen Option derzeit noch nicht funktioniert?

Korrekt. Ich weiß noch nicht, wann ich das einbauen werde/kann.

Beste Grüße

Offline nanocosmos

  • Full Member
  • ***
  • Beiträge: 236
Antw:Keine Verbindung zu FHEM
« Antwort #9 am: 18 Dezember 2019, 10:39:16 »
Korrekt. Ich weiß noch nicht, wann ich das einbauen werde/kann.

Beste Grüße
Ok, danke für die Info!
So erklärt sich für mich warum es nicht geht. [emoji4]

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
Antw:Keine Verbindung zu FHEM
« Antwort #10 am: 18 Dezember 2019, 19:09:50 »
Hallo Syrex-o,

mit einem Thermostat das gleiche!
Hab mal ein Bild mit der Meldung angehangen.

Gruß
Michael
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
Antw:Keine Verbindung zu FHEM
« Antwort #11 am: 18 Dezember 2019, 19:18:46 »
Im Logging steht nichts drin.
Um 13:11 habe ich einmal die IP-Setting erneuert.
Verbindung wurde kurz unterbrochen, dann wieder aufgebaut (Connect sieht man im Log nicht)
zwischen 13:11 und 14:18 habe ich ein Thermostat angelegt. Readings grüm - aber Ergebnis siehe Bild von gerade

Michael


Wed Dec 18 2019 19:12:45 GMT+0100 (Mitteleuropäische Normalzeit) INFO: Logging started
Wed Dec 18 2019 19:13:11 GMT+0100 (Mitteleuropäische Normalzeit) ERROR: Error: Fhem: Verdindung zu Fhem getrennt.
Wed Dec 18 2019 19:14:18 GMT+0100 (Mitteleuropäische Normalzeit) INFO: Logging ende
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline niklas

  • New Member
  • *
  • Beiträge: 10
Antw:Keine Verbindung zu FHEM
« Antwort #12 am: 30 Dezember 2019, 22:25:57 »
Hallo zusammen,

an alle, bei denen zwar eine Fhem Verbindung aufgebaut wird, aber die Komponenten nach dem Erstellen keine Verbidung herstellen:
habt ihr mal versucht in den Settings den Menüpunkt "Load all Fhem devices" zu deaktivieren und dann im Menüpunkt darunter die erste Option zu wählen?
Bei mir läuft FhemNative nur mit diesen Einstellungen, seitdem aber durchwegs flüssig.
Gefällt mir Gefällt mir x 1 Hilfreich Hilfreich x 2 Liste anzeigen

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 190
Antw:Keine Verbindung zu FHEM
« Antwort #13 am: 05 Januar 2020, 19:28:36 »
So, konnte wieder ein wenig testen.
Der Vorschlag von niklas hat bei mir auch zum Erfolg geführt.

Wenn ich "Load all Fhem devices" deaktiviere funktioniert es bei mir - egal ob erste oder zweite Option bei "Geräte laden definieren" angewählt wurde.

Syrex-o, kannst du da was mit anfangen, was bewirken die Optionen genau?

Gruß Michael
Großes Mischmasch aus HM, Philips, WLAN und Eigenprojekte.
ABER alles mit FHEM.

Offline Syrex-o

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 602
  • FhemNative
Antw:Keine Verbindung zu FHEM
« Antwort #14 am: 06 Januar 2020, 07:26:43 »
So, konnte wieder ein wenig testen.
Der Vorschlag von niklas hat bei mir auch zum Erfolg geführt.

Wenn ich "Load all Fhem devices" deaktiviere funktioniert es bei mir - egal ob erste oder zweite Option bei "Geräte laden definieren" angewählt wurde.

Syrex-o, kannst du da was mit anfangen, was bewirken die Optionen genau?

Gruß Michael

Hey,

Genau das ist der Sinn dieser Einstellungen.
Per Default sendet FhemNative eine Anfrage für alles was in Fhem existiert. Das macht wenig Sinn, wenn man sehr viele Geräte, Notifys, etc. in FHEM hat.
Deshalb die Einstellungen:
  • 1. FhemNative fragt nut nach der Liste an Geräten, die in Komponenten verwendet werden. Neue Geräte werden dann nach bedarf hinzugefügt.
  • 2. 1. + Geräte die in Fhem der Gruppe mit dem Namen FhemNative zugeordnet sind.

Beste Grüße

EDIT:
Ich würde dieses Verhalten außerdem nicht als Workaround bezeichnen sondern als Lösung, da diese Einstellung nur aus diesem Grund existiert.
« Letzte Änderung: 06 Januar 2020, 07:43:28 von Syrex-o »

 

decade-submarginal