Autor Thema: RPI mit Buster => FHEM über WEB nicht erreichbar  (Gelesen 277 mal)

Offline cs-online

  • Hero Member
  • *****
  • Beiträge: 1036
RPI mit Buster => FHEM über WEB nicht erreichbar
« am: 25 Dezember 2019, 19:24:07 »
Hallo,

der Weihnachtsmann hat den neuen RPI 4 mit 4GB gebracht. Im Vorfeld habe ich mit einem 2B Buster neu aufgesetzt, damit es danach nicht mehr so lange dauert, bis ich den einsetzen kann. Auf dem 4er lief das System gleich an, kurz update und upgrade nochmal laufen lassen. Aber: laut

sudo service fhem status läuft FHEM auch, aber mit dem WEBend dreht und dreht das, aber die Seite kommt nicht. FHEM-Log über VNC aufgerufen zeigt zwar eine Menge, was mir sagt, dass FHEM wirklich läuft, aber keine Fehler, die einen Hinweis geben könnten. Dann

sudo service fhem stop

dauert recht lange (geschätzt mal eine Minute), bis der Promt wieder kommt.

sudo service fhem start

das geht dann relativ schnell und dann voila, geht WEB auch und ist dann auch rappelfix... Wenn ich dann ein sudo reboot absetze, kann auch auch nach dem Neustart FHEM über WEB aufrufen. Nur, wenn ich den vom Strom nehme und dann neu starte, leider nicht.

Hat jemand eine Idee, was das sein kann ?

Grüße und schöne Restweihnachten

Christian
FHEM auf RPI 4 4GB, HM-CFG-USB-2, HM-WLAN-Gateway, einige HM-Aktoren,  2x EBUSD an Heizung und Solar, ESP8266 am Strom-, Gas- , Wasserzähler, in WLAN-Steckdosen und Relaisleisten, Sonoff S20, Lacrosse-Gateway und Sensoren, Signalduino, Alexa-Fhem... und alles auf einem RPI und da geht noch mehr...

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21624
Antw:RPI mit Buster => FHEM über WEB nicht erreichbar
« Antwort #1 am: 25 Dezember 2019, 19:46:49 »
Zitat
Hat jemand eine Idee, was das sein kann ?
Vermutlich steht die Ursache im FHEM-Log, wenn man vorher "attr global verbose 5" gesetzt hat.

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 14554
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:RPI mit Buster => FHEM über WEB nicht erreichbar
« Antwort #2 am: 25 Dezember 2019, 20:26:19 »
Hi,

es gibt diesen Artikel: https://wiki.fhem.de/wiki/FHEM_startet_nicht_-_Tipps_zur_Fehlersuche
Mein Schuss in Blaue: attr intialUsbCheck disable 1  oder alle USB Sticks abziehen.

Aber wie Rudi sagt: die letzen Zeilen vom Log ;)

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

 

decade-submarginal