Autor Thema: [patch] Fix für falsche WU-URL - 50_HP1000.pm  (Gelesen 1730 mal)

Offline pldemon

  • New Member
  • *
  • Beiträge: 27
[patch] Fix für falsche WU-URL - 50_HP1000.pm
« am: 03 Januar 2020, 19:04:51 »
Hallo,

die Weather Undergrund URL in 50_HP1000.pm, die zum Senden der Daten an WU (oder beispielsweise an weewx) erstellt wird, hat zwei Probleme:
  • Zum einen steht am Ende der Url ein "&", obwohl danach keine Option mehr kommt. Das bringt den WeeWX-Parser durcheinander
  • Der Zweite Fehler betrifft das Enkodieren des Datums. Hier werden innerhalb von urlEncode() auch die Zeichen ":" encodiert, was aber nicht korrekt ist und zu einem Fehler beim Zugriff auf das WU-API führt
Anbei eine kurze Korrektur.

Gruß
« Letzte Änderung: 03 Januar 2020, 19:13:13 von pldemon »

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3753
  • ~ Challenging Innovation ~
Antw:[patch] Fix für falsche WU-URL - 50_HP1000.pm
« Antwort #1 am: 04 Januar 2020, 11:50:05 »
Kannst du den Patch bitte hier einreichen:

https://github.com/fhem/mod-HP1000
Hat meine Arbeit dir geholfen? ⟹ https://paypal.me/pools/c/8gDLrIWrG9

Maintainer:
FHEM-Docker Image, https://github.com/fhem, Astro(Co-Maintainer), ENIGMA2, GEOFANCY, GUEST, HP1000, Installer, LaMetric2, MSG, msgConfig, npmjs, PET, PHTV, Pushover, RESIDENTS, ROOMMATE, search, THINKINGCLEANER

Offline pldemon

  • New Member
  • *
  • Beiträge: 27
Antw:[patch] Fix für falsche WU-URL - 50_HP1000.pm
« Antwort #2 am: 04 Januar 2020, 15:18:55 »
Erledigt. Zwei Commits sind als Pull-Request raus:
https://github.com/fhem/mod-HP1000/pull/1

Habe dabei auch gleich eine kleine Verbesserung dem Request beigefügt. Darin wird die Variable "wu_pushURL" eingeführt. Mittels der Änderung ist es möglich, die fest codierte URL innerhalb des Moduls durch eine eigene zu ersetzen. Interessant für Leute, die ihre Daten nicht an WU senden wollen, sondern an einen eigenen Server, ohne, dass die mit DNS-Einträgen herumspielen müssen.

Gruß
Mirko

Offline Rainerlan_2

  • New Member
  • *
  • Beiträge: 19
Antw:[patch] Fix für falsche WU-URL - 50_HP1000.pm
« Antwort #3 am: 22 Dezember 2021, 13:42:09 »
Ich habe immernoch das selbe Problem wie hier beschrieben:
https://forum.fhem.de/index.php/topic,44022.msg1169251.html#msg1169251
Der Timestamp kommt von meiner WH2600 wohl im falschen format.
Nachdem das Modul 50_HP1000 aktualisiert wurde, ist mein lokaler Patch überschrieben.

Da vermutlich meine WH2600 nicht die einzige Wetterstation dieser Bauart ist, die eine "flasche" Timestamp liefert:
Wäre es möglich den "Patch" über eine Konfiguration ins Modul einzupfelgen?

Zeile 1430:
while ( my ( $key, $value ) = each %{$webArgs} ) {
    $value = urlEncode($value)
    if ( $key =~ /^(softwaretype|dateutc)$/i );
    if ( $key eq "dateutc" ) {
        $value = urlEncode(strftime "%F %H:%M:%S", localtime);
    }
...

Offline pldemon

  • New Member
  • *
  • Beiträge: 27
Antw:[patch] Fix für falsche WU-URL - 50_HP1000.pm
« Antwort #4 am: 22 Januar 2022, 17:57:19 »
Ja. Habe das Modul vor knapp 3 Monaten kurz getestet und es hatte immer noch etliche Fehler. Setze deshalb notgedrungen eine lokale Version in meiner Umgebung ein :(

 

decade-submarginal