Autor Thema: Busware COC-Modul wird nicht erkannt  (Gelesen 10878 mal)

oneted

  • Gast
Aw: Busware COC-Modul wird nicht erkannt
« Antwort #15 am: 13 Januar 2013, 22:02:13 »
Hallo Gelbwichtel,

Seitens busware (Tostmann) bekommt man leider nur schnippische Antworten...
"Dieses Produkt als auch OpenSource scheint für Sie nicht geeignet, da Sie ein reiner Konsument sind. Bitte schicken Sie das COC schnellstens zurück - wir geben solchen Kunden wie Ihnen sehr gern Ihr Geld wieder ..."

?!? Anscheinend läuft das Geschäft zu gut ...  (Die wiki Seite könnte jedoch besser dokumentiert sein, da hier nicht auf die unterschiedlichen Raspberry Rev. eingegangen wird)

schönen Abend...


Offline gelbwichtel

  • Jr. Member
  • **
  • Beiträge: 98
COC-Modul funktioniert
« Antwort #16 am: 15 Januar 2013, 21:40:28 »
Hallo oneted,
ich kann den Kontakt zu busware.de nicht so negativ kommentieren. Die letze Antwort zu dem Thema war:
 "Das Problem liegt in der Kernel/Hardwarerevision des Raspberry, da sowohl RTC als auch EEPROM simple per I2C angeschlossen sind, also nicht vom COC ansich getrieben werden
Wir können leider nicht nach jeder neuen Raspberryhardware oder Kernelversion ein Review machen, das sollte die Community aus sich heraus lösen, so es es wirklich überhaupt nötig ist."

Das hat mich dann dazu veranlasst, das Thema Uhr und EEprom erstmal adActa zu legen und das COC-Board unter FHem in Betrieb zu nehmen. Das ist mir nun gelungen; d.h. das COC Board funktioniert.
Den Thread könnte man also jetzt abschließen.
Gruß
Gelbwichtel
cu
gelbwichtel

oneted

  • Gast
Aw: COC-Modul funktioniert
« Antwort #17 am: 15 Januar 2013, 22:51:03 »
Sehr interessant, dass hier unterschiedliche Antworten retour kommen.

aber ja, das Board funktioniert prinzipiell mit der 512MB Version.
... und die RTC wird nun auch automatisch nach einigen Modifikationen beim Starten des Betriebssystems initialisiert.

schönen Abend noch ...
 

Offline h3llsp4wn

  • Full Member
  • ***
  • Beiträge: 218
Aw: COC-Modul funktioniert
« Antwort #18 am: 27 Januar 2013, 16:06:00 »
Hi,

da ich auch einen 512er Raspi habe und aktuell einen COC bei busware bestellen wollte - darf ich fragen, was Du alles modifiziert hast, damit er unter läuft?
Bevor ich mir da unnötig Streß antue ...


Viele Grüße,

h3ll

Offline gelbwichtel

  • Jr. Member
  • **
  • Beiträge: 98
Aw: Busware COC-Modul wird nicht erkannt
« Antwort #19 am: 27 Januar 2013, 18:03:55 »
Also, nur um das nochmal richtigzustellen:
Das COC-Board für den PI der neusten Generation, bedarf keiner speziellen Anpassung, damit er unter FHEM läuft.
Es gibt lediglich ein Problem beim Abfragen der auf dem COC-Board installierten Geräte wie Eeeprom und RTC, da diese als I2C-Devices betrieben werden. Hier hat sich wahrscheinlich die Adressierung geändert. Die RTC kann man ansprechen, wenn man folgendes Kommando absetzt: echo at24 0x50 > /sys/class/i2c-adapter/i2c-1/new_device. Das Auslesen des Eeproms hat mich eigentlich auch nicht mehr interessiert, nachdem ich wusste, dass das zum Arbeiten mit FHEM nicht notwendig ist. Natürlich wäre ich auch daran interessiert zu wissen was wie an den Devices rumzubiegen ist, damit das Auslesen des Eeproms klappt. Ach ja, wenn du dein COC-Board erhältst, solltest du auf jeden Fall noch die neuste Firmware draufflashen. Der Vorgang ist bei busware.de genau beschrieben.
cu
gelbwichtel

Offline h3llsp4wn

  • Full Member
  • ***
  • Beiträge: 218
Aw: Busware COC-Modul wird nicht erkannt
« Antwort #20 am: 28 Januar 2013, 10:42:49 »
Prima! Danke für die schnelle Antwort!

Viele Grüße,

h3ll

 

decade-submarginal