Autor Thema: WeekdayTimer inactive  (Gelesen 541 mal)

Offline mfeske

  • Sr. Member
  • ****
  • Beiträge: 770
WeekdayTimer inactive
« am: 20 Januar 2020, 21:42:09 »
Glaubt mir bitte ich habe nichts verändert :-( aber zwei DOIF funktionieren nicht mehr, sie zeigen STATE inactive und nextUpdate 1970-01-01 01:00:00.
Internals:
   CHANGED   
   COMMAND   
   CONDITION 
   DEF        Elch Mo-So|06:45:00|on Mo-So|{sunrise_abs('HORIZON=-2',0,"07:15","08:40")}|off
   DEVICE     Elch
   FUUID      5c500794-f33f-a44f-63b5-6862707fa29ac78c
   GlobalDaylistSpec
   LANGUAGE   en
   NAME       ElchMorgends
   NR         60
   STATE      inactive
   STILLDONETIME 0
   TYPE       WeekdayTimer
   READINGS:
     2019-12-17 12:42:35   currValue       off
     2020-01-15 15:12:42   nextUpdate      1970-01-01 01:00:00
     2019-12-17 12:42:35   nextValue       on
     2020-01-15 15:12:42   state           inactive
   SWITCHINGTIMES:
     Mo-So|06:45:00|on
     Mo-So|{sunrise_abs('HORIZON=-2',0,"07:15","08:40")}|off
   TIMER:
     ElchMorgends_SetTimerOfDay:
       HASH       ElchMorgends
       MODIFIER   SetTimerOfDay
       NAME       ElchMorgends_SetTimerOfDay
       SETTIMERATMIDNIGHT 1
   dayNumber:
     !$we       8
     $we        7
     fr         5
     mo         1
     sa         6
     su         0
     th         4
     tu         2
     we         3
   helper:
     daysRegExp (su|mo|tu|we|th|fr|sa|\$we|\!\$we)
     daysRegExpMessage (su|mo|tu|we|th|fr|sa|$we|!$we)
     SWITCHINGTIME:
     WEDAYS:
       5          1
       6          1
   longDays:
     de:
       Sonntag
       Montag
       Dienstag
       Mittwoch
       Donnerstag
       Freitag
       Samstag
       Wochenende
       Werktags
     en:
       Sunday
       Monday
       Tuesday
       Wednesday
       Thursday
       Friday
       Saturday
       weekend
       weekdays
     fr:
       Dimanche
       Lundi
       Mardi
       Mercredi
       Jeudi
       Vendredi
       Samedi
       weekend
       jours de la semaine
     nl:
       Zondag
       Maandag
       Dinsdag
       Woensdag
       Donderdag
       Vrijdag
       Zaterdag
       weekend
       werkdagen
   profil:
     1:
       EPOCH      1579499100
       PARA       on
       TIME       06:45:00
       WE_Override 0
       TAGE:
     2:
       EPOCH      1579503401
       PARA       off
       TIME       {sunrise_abs('HORIZON=-2',0,"07:15","08:40")}
       WE_Override 0
       TAGE:
   shortDays:
     de:
       so
       mo
       di
       mi
       do
       fr
       sa
       $we
       !$we
     en:
       su
       mo
       tu
       we
       th
       fr
       sa
       $we
       !$we
     fr:
       di
       lu
       ma
       me
       je
       ve
       sa
       $we
       !$we
     nl:
       zo
       ma
       di
       wo
       do
       vr
       za
       $we
       !$we
Attributes:
   commandTemplate set $NAME  $EVENT
   room       Garten

Was kann den da schief gelaufen sein ?

Gruß
Micha
« Letzte Änderung: 21 Januar 2020, 14:13:13 von mfeske »
Hardware:
1 x Raspberry Pi Mod. B 512 MB
eq-3 2 x MAX! eTRV Heizungssteller, 1 x MAX! Fensterkontakt, 1 x MAX! Cube - LAN Gateway (ausser Betrieb)
Intertechno 1x ITZ-500, 3x ITT-1500, 9x ITR-1500, 3 x ITDL-1000, 2 x ITL-500
1 x CC1101-USB-Lite 433MHz (CUL433)  V3 1 x CC1101-USB-Lite 868MHz (CUL868)

Offline kumue

  • Sr. Member
  • ****
  • Beiträge: 999
Antw:DOIF inactive
« Antwort #1 am: 20 Januar 2020, 22:00:20 »
selbe Fehlermeldung hatte ich gestern bei ein paar Thresholds...
habe die Wochentage Mo, Die usw. durch Zahlen (0 für Sonntag, 1für Montag usw.) ersetzt, dann gings wieder...

Online Damian

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6955
Antw:DOIF inactive
« Antwort #2 am: 20 Januar 2020, 22:14:23 »
Ich glaube wir sind im falschen Film:

Zitat
  LANGUAGE   en
   NAME       ElchMorgends
   NR         60
   STATE      inactive
   STILLDONETIME 0
   TYPE       WeekdayTimer
   READINGS:
     2019-12-17 12:42:35   currValue       off
     2020-01-15 15:12:42   nextUpdate      1970-01-01 01:00:00
     2019-12-17 12:42:35   nextValue       on
     2020-01-15 15:12:42   state           inactive
Programmierte FHEM-Module: DOIF mit uiTable, DOIF-Perl, THRESHOLD, FHEM-Befehl: IF

Offline kumue

  • Sr. Member
  • ****
  • Beiträge: 999
Antw:DOIF inactive
« Antwort #3 am: 20 Januar 2020, 22:21:59 »
stimmt, es ware WD-Timer bei mir, nicht Threshold...

Online Damian

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6955
Antw:DOIF inactive
« Antwort #4 am: 20 Januar 2020, 22:24:28 »
stimmt, es ware WD-Timer bei mir, nicht Threshold...


Es handelt sich in beiden Fällen dann wohl um WeekdayTimer und nicht um das DOIF-Modul. Am besten in Automatisierung verschieben.
Programmierte FHEM-Module: DOIF mit uiTable, DOIF-Perl, THRESHOLD, FHEM-Befehl: IF

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3667
Antw:DOIF inactive
« Antwort #5 am: 20 Januar 2020, 22:25:51 »
Dann bitte Thread verschieben und umbenennen.

Gesendet von meinem Doogee S60 mit Tapatalk


Offline mfeske

  • Sr. Member
  • ****
  • Beiträge: 770
Antw:WeekdayTimer inactive
« Antwort #6 am: 21 Januar 2020, 10:30:32 »
sorry :-( umbenannt habe ich, verschieben kann bestimmt nur ein MOD ?
Hardware:
1 x Raspberry Pi Mod. B 512 MB
eq-3 2 x MAX! eTRV Heizungssteller, 1 x MAX! Fensterkontakt, 1 x MAX! Cube - LAN Gateway (ausser Betrieb)
Intertechno 1x ITZ-500, 3x ITT-1500, 9x ITR-1500, 3 x ITDL-1000, 2 x ITL-500
1 x CC1101-USB-Lite 433MHz (CUL433)  V3 1 x CC1101-USB-Lite 868MHz (CUL868)

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9267
  • eigentlich eher "user" wie "developer"
Antw:WeekdayTimer inactive
« Antwort #7 am: 21 Januar 2020, 11:01:55 »
Nein, verschieben kann man auch selbst, und WeekdayTimer gehört nach "Kalendermodule", https://forum.fhem.de/index.php/board,85.0.html, siehe MAINTAINER.txt, wie üblich (warum auch immer das schon immer so ist)...

In der Sache würde ich mal empfehlen, die Wochentagsangaben ganz rauszunehmen, also die DEF so zu ändern:
Elch 06:45:00|on {sunrise_abs('HORIZON=-2',0,"07:15","08:40")}|off(Das Phänomen scheint mit der Änderung der Wochentagssteuerung auf volle Berücksichtigung aller holiday2we-Features zusammenzuhängen.
Sobald man "sinnvolle" Differenzierungen macht, (mit $we und !$we oder "echter" Wochentagssteuerung) scheint das auch kein Thema zu sein, nur diese "immer"-Angabe durch 0-6 oder Mo-So macht Probleme).
« Letzte Änderung: 21 Januar 2020, 15:26:49 von Beta-User »
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline mfeske

  • Sr. Member
  • ****
  • Beiträge: 770
Antw:WeekdayTimer inactive
« Antwort #8 am: 21 Januar 2020, 14:14:42 »
Nein, verschieben kann man auch selbst, und WeekdayTimer gehört nach "Kalendermodule", https://forum.fhem.de/index.php/board,85.0.html, siehe MAINTAINER.txt, wie üblich (warum auch immer das schon immer so ist)...
offensichtlich bin ich blind :-( Ich gehe auf ändern, finde aber keine Option zum verschieben.
Hardware:
1 x Raspberry Pi Mod. B 512 MB
eq-3 2 x MAX! eTRV Heizungssteller, 1 x MAX! Fensterkontakt, 1 x MAX! Cube - LAN Gateway (ausser Betrieb)
Intertechno 1x ITZ-500, 3x ITT-1500, 9x ITR-1500, 3 x ITDL-1000, 2 x ITL-500
1 x CC1101-USB-Lite 433MHz (CUL433)  V3 1 x CC1101-USB-Lite 868MHz (CUL868)

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9267
  • eigentlich eher "user" wie "developer"
Antw:WeekdayTimer inactive
« Antwort #9 am: 21 Januar 2020, 14:20:43 »
offensichtlich bin ich blind :-( Ich gehe auf ändern, finde aber keine Option zum verschieben.
Na jedenfalls steht hier:
Zitat
Falls die Frage in der falschen Gruppe landen sollte, kann der Ersteller sie mit dem Button ganz unten links verschieben.
Du bist bei weitem nicht der erste, der das übersieht, aber bisher hat es dann bei den meisten, die den Button auch zunächst nicht gefunden hatten, dann am Ende doch geklappt...
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline mfeske

  • Sr. Member
  • ****
  • Beiträge: 770
Antw:WeekdayTimer inactive
« Antwort #10 am: 23 Januar 2020, 16:22:06 »
prima, morgens steht jetzt wieder auf active
Elch 06:45:00|on {sunrise_abs('HORIZON=-2',0,"07:15","08:40")}|offaber abends weigert sich noch. Ich habe leider die Zeile noch in der Zwischenablage von morgens gehabt und in abends kopiert :-( Ich weiss nicht mehr was drin stand.
Ich wollte eine Stunde vor Sonnenuntergang einschalten und um 23:30 ausschalten. Könnt ihr mir da bitte helfen ?
Gruß
Micha
Hardware:
1 x Raspberry Pi Mod. B 512 MB
eq-3 2 x MAX! eTRV Heizungssteller, 1 x MAX! Fensterkontakt, 1 x MAX! Cube - LAN Gateway (ausser Betrieb)
Intertechno 1x ITZ-500, 3x ITT-1500, 9x ITR-1500, 3 x ITDL-1000, 2 x ITL-500
1 x CC1101-USB-Lite 433MHz (CUL433)  V3 1 x CC1101-USB-Lite 868MHz (CUL868)

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9267
  • eigentlich eher "user" wie "developer"
Antw:WeekdayTimer inactive
« Antwort #11 am: 23 Januar 2020, 16:54:23 »
Ungetestet:
{sunset_abs_dat($date,"CIVIL",-HOURSECONDS,"18:00","21:00")}|on 23:30|off
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

 

decade-submarginal