Autor Thema: sysmon löscht readings ...??  (Gelesen 216 mal)

Offline dirk.k

  • Full Member
  • ***
  • Beiträge: 171
sysmon löscht readings ...??
« am: 22 Februar 2020, 22:09:28 »
Hallo zusammen,

ist das normal, oder habe ich was falsch gemacht?
Sysmon löscht bei mir readings.
Das sind einerseits userreadings (filesystem), welche eher selten aktualisiert werden. Diese sind nur dann da, wenn sie gerade erstellt wurden. In den Zyklen, in welchen die FS-Daten nicht gelesen werden, verschwinden sie.
Das Gleiche bei Daten, welche per readingswatcher auf ??? gestellt wurden, da das Gerät aus ist.
Diese werden bei jedem Durchgang gelöscht und neu erstellt. Damit funktioniert "event-on-change-reading" natürlich nicht mehr und es triggert immer.

 

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 24134
Antw:sysmon löscht readings ...??
« Antwort #1 am: 22 Februar 2020, 22:34:10 »
Das ist vom Entwickler damals so gewollt worden. Also Du machst nichts falsch, das ist so.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
Mein Dokuwiki:
https://tuxnetwiki-tuxnet.ddns.net

Offline peterk_de

  • Sr. Member
  • ****
  • Beiträge: 800
Antw:sysmon löscht readings ...??
« Antwort #2 am: 23 Februar 2020, 00:40:22 »
Patch von mir siehe https://forum.fhem.de/index.php/topic,40533.msg839530.html#msg839530

... und SYSMON danach auf die FHEM-Update-Exlude Liste packen. Wurde nämlich leider nie übernommen. Läuft bei mir damit aber schon ewig und fehlerfrei - in der Originalversion finde ich das Modul aus den gleichen Gründen wie du unbrauchbar.

LG!
FHEM auf Ubuntu-VM / 2xNUC Proxmox Cluster
UI: HomeKit, TabletUI, Grafana
IOdevs: 2xHueBridge, RaspiMatic-CCU, CUL868, 2xHarmonyHub, HomeConnect
Devices: 97xHomematic(IP), 96xPhilips Hue, 17xTECHEM, 12xBTLE, 6xSONOS, 6xRaspi-Roomnode mit CO2, VOC, lepresenced ...

 

decade-submarginal