Autor Thema: Modul IPCAM überarbeitet  (Gelesen 28318 mal)

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
IPCAM Wrong or not supported image format
« Antwort #15 am: 03 März 2014, 18:12:01 »
Hallo Leute,

versuche verzweifelt meine IPcam zum laufen zu bekommen und scheitere wie viele vor mir an dem Fehler

IPCAM Wrong or not supported image format

Habe mal alles mit debugstatements versehen und das loglevel hochgedreht,
es liegt offensichtlich daran dass  $snapshot = GetFileFromURLQuiet($camURI);
nix zurückliefert "empty answer received".
verflixte httpUtils mal wieder ;)

Falls der Fehler bei einem von euch auftritt schlage ich vor get von LWP::Simple zu verwenden:

$snapshot = get($camURI);

dann läuft alles wunderbar! Muss man ggf auf den Fritzboxen noch installieren...
FHEM auf Raspi2 & Radxa Rock

Offline JoMe

  • New Member
  • *
  • Beiträge: 30
    • http://www.joachim-mehler.de
Antw:Modul IPCAM überarbeitet
« Antwort #16 am: 23 April 2014, 21:29:37 »
Hallo,

habe den gleichen Fehler..... :(.....

Nach dem Anpassen, wie oben beschrieben....stürzt FHEM beim Versuch einen Snapshot zumachen total ab....

Gibt es da schon ein Lösung....

Ach ja....wenn die den Link für die IPCAM direkt in den in Fierfox eingebe, bekomme ich das Bild.....

Gruß,

Joachim
CubieTruck, Fhem 5.5, 2x CUL(868), FHZ1350, Wlan, FS20, HM-LAN, HM, KS300, MAX!, EM1000, Hue, LW12, Sonos

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
Antw:Modul IPCAM überarbeitet
« Antwort #17 am: 27 April 2014, 08:31:02 »
Hallo Joachim,

ist LWP::Simple installiert?
Evtl per cpan nachinstallieren oder händisch auf den den Fritzboxen.

Ansonsten, was sagt das log?
FHEM auf Raspi2 & Radxa Rock

Offline JoMe

  • New Member
  • *
  • Beiträge: 30
    • http://www.joachim-mehler.de
Antw:Modul IPCAM überarbeitet
« Antwort #18 am: 27 April 2014, 19:41:44 »
Hallo,

habe es gerade nochmal versucht.....jetzt gings....

LWP::Simple war installiert....

..ich befürchte, das ich beim 1.Versuch das "get" groß geschrieben hatte.. :(..

Vielen Dank,

gruß,

Joachim
CubieTruck, Fhem 5.5, 2x CUL(868), FHZ1350, Wlan, FS20, HM-LAN, HM, KS300, MAX!, EM1000, Hue, LW12, Sonos

Offline noanda

  • Full Member
  • ***
  • Beiträge: 193
Antw:Modul IPCAM überarbeitet
« Antwort #19 am: 01 Dezember 2014, 23:33:07 »
Mal eine blöde Frage, wo genau muss ich "$snapshot = get($camURI)" integrieren ?
Raspberry Pi - FHEM 5.5
HMLAN, RFXtrx433 , CUL 868
HM-CC-RT-DN, HM-SEC-MDIR , HM-SEC-SC-2
HM-LC-SW2-FM, ROTO_ZEL-STG-RM-FZS
ELRO440AB, Flamingo

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
Antw:Modul IPCAM überarbeitet
« Antwort #20 am: 02 Dezember 2014, 08:45:45 »
Im Modulcode, aber nur wenns Originalmodul wirklich nicht geht  ::)
FHEM auf Raspi2 & Radxa Rock

Offline td

  • Jr. Member
  • **
  • Beiträge: 59
  • FHEM-Nutzer seit 2009
Antw:Modul IPCAM überarbeitet
« Antwort #21 am: 08 Januar 2015, 11:34:57 »
Hallo,

stehe auf dem Schlauch:
Bei mir tritt das genannte Problem mit GetFileFromURLQuiet auf.
Per cpan LWP::Simple installiert.
Bei Aufruf von "get Kamera image" stürzt fhem ab: "Undefined subroutine &main::get called at /opt/fhem/FHEM/49_IPCAM.pm line 381."
Warum findet fhem "get" nicht? Kann oder muß ich den Aufruf näher qualifizieren?

Gruß
td

Offline gerhardg

  • Jr. Member
  • **
  • Beiträge: 65
Antw:Modul IPCAM überarbeitet
« Antwort #22 am: 09 Januar 2015, 14:18:13 »
aus dem Bauch raus würde ich mal vorschlagen du baust noch ein "use LWP::Simple;" ein.

Offline td

  • Jr. Member
  • **
  • Beiträge: 59
  • FHEM-Nutzer seit 2009
Antw:Modul IPCAM überarbeitet
« Antwort #23 am: 11 Januar 2015, 17:51:01 »
Danke für den Hinweis. fhem stürzt nicht ab und findet "get", aber leider tritt weiterhin auf:
"IPCAM KameraEinfahrt Wrong or not supported image format: unknown"
Die Kamera ist eine FOSCAM 9805W.

Gruß
td

Offline Michi240281

  • Hero Member
  • *****
  • Beiträge: 1163
Antw:Modul IPCAM überarbeitet
« Antwort #24 am: 11 Juli 2015, 20:12:37 »
Gibts für das Problem inzwischen eine Lösung? Bei mir ist das selbe --> Foscam 9803P.

Komme einfach nicht weiter! :-(
FHEM 5.6 auf RPi2 / HM LAN Adapter / diverse HM-Devices
FHEM-Remote-App
QNAP 419P / Onkyo TX-SR 608
DM500HD / GM Spark One
Sony 52HX905

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
Antw:Modul IPCAM überarbeitet
« Antwort #25 am: 13 Juli 2015, 08:18:57 »
... schlage ich vor get von LWP::Simple zu verwenden:

$snapshot = get($camURI);

dann läuft alles wunderbar! Muss man ggf auf den Fritzboxen noch installieren...
FHEM auf Raspi2 & Radxa Rock

Offline Michi240281

  • Hero Member
  • *****
  • Beiträge: 1163
Antw:Modul IPCAM überarbeitet
« Antwort #26 am: 13 Juli 2015, 11:26:14 »
Habe ich getan, und zwar folgendermaßen:

Zunächst mittels

cpan install LWP::Simple
die Installation auf dem RPi2 durchgeführt.

Dann habe ich

use LWP::Simple
im Code des IPCAM-Moduls oben eingefügt und dann weiter unten das

$snapshot = GetFileFromURLQuiet($camURI); durch ein "#" auskommentiert und dafür dann

$snapshot = get($camURI);
eingetragen!

Danach RPi2 neugestartet, aber das Ergebnis bleibt das gleiche!
FHEM 5.6 auf RPi2 / HM LAN Adapter / diverse HM-Devices
FHEM-Remote-App
QNAP 419P / Onkyo TX-SR 608
DM500HD / GM Spark One
Sony 52HX905

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
Antw:Modul IPCAM überarbeitet
« Antwort #27 am: 13 Juli 2015, 11:29:35 »
Logge mal $camURI und $snapshot ...
FHEM auf Raspi2 & Radxa Rock

Offline Michi240281

  • Hero Member
  • *****
  • Beiträge: 1163
Antw:Modul IPCAM überarbeitet
« Antwort #28 am: 13 Juli 2015, 11:33:44 »
Logge mal $camURI und $snapshot ...

Wie mache ich das?
FHEM 5.6 auf RPi2 / HM LAN Adapter / diverse HM-Devices
FHEM-Remote-App
QNAP 419P / Onkyo TX-SR 608
DM500HD / GM Spark One
Sony 52HX905

Offline HolyMoly

  • Full Member
  • ***
  • Beiträge: 432
Antw:Modul IPCAM überarbeitet
« Antwort #29 am: 13 Juli 2015, 11:38:24 »
Log 1, "IPCAM $name URI: $camURI";
Log 1, "IPCAM $name Snapshot: $snapshot";

FHEM auf Raspi2 & Radxa Rock