Autor Thema: CUL an Synology  (Gelesen 3435 mal)

Offline elbmarschsurfer

  • New Member
  • *
  • Beiträge: 5
CUL an Synology
« am: 03 Februar 2013, 13:54:52 »
Hallo liebe FHEM-Gemeinde,

Nachdem ich schon etwas länger FHEM auf meiner Diskstation laufen habe und einige Netzwerkdevices wie meine Fritzbox, den Yamaha-Receiver und meinen Samsung-Fernsehererfolgreich  eingebunden habe, wollte ich nun ein paar FS20-Geräte mittels CUL ansteuern. Nach langem Probieren  und Lesen trete ich nun an Euch heran: Ich habe den CUL geflasht und in die Synology mit den nötigen Perl, USB-Kernel, OpennSSL und FHEM-Packages gesteckt. Allerdings erhalte ich im Status des CUL ein" disconnected". Rereadcfg, shutdown restart, fhem-Paket aus-ein hat bisher zu keiner Lösung beigetragen. Im Log steht, dass er an USB0-6 kein TCM310 device öffnen kann. Habe ich irgendetwas Grundlegendes vergessen, oder falsch verstanden?
Bitte helft mir, meine Nerven liegen blank ;-)

Offline MisterEltako

  • Sr. Member
  • ****
  • Beiträge: 521
Aw: CUL an Synology
« Antwort #1 am: 05 Februar 2013, 09:36:59 »
Hi!

Also bei mir steckt der TCM 310 im 1. USB-Port und die Definition dazu lautet in der Fhem.cfg:

define EUL TCM 310 /dev/ttyUSB0@57600 ... und dann wird der Status "opend" angezeigt.

Ein Problem hatte ich (weswegen ich auf Homematic mit HM-LAN-Adapter umgestiegen bin): nach längerer Laufzeit und korrekter Funktion wurde trotz "Status: opend" kein Signal mehr über TCM310 gesendet. Neu initialisieren half da auch nicht. Lediglich das abziehen und wieder anstecken des TCM 310 sowie Neustart von Fhem halfen bis zum nächsten Ausfall. Aufgrund dieser Unzuverlässigkeit und der geringeren Reichweite gegenüber HM-LAN-Adapter bin ich auf Homematic umgestiegen und bisher sehr positiv davon überrascht.

MfG, MisterEltako.
HMLAN-Konfigurations-Adapter, HM-Funkjalousieaktor/HM-Dimmaktor/HM-Schaltaktor f. Markenschalter, Jalousie-/Schaltaktor von Eltako, FT4 v. Eltako, TCM310

Offline elbmarschsurfer

  • New Member
  • *
  • Beiträge: 5
Aw: CUL an Synology
« Antwort #2 am: 05 Februar 2013, 09:51:21 »
Hallo,

aber ich habe doch gar kein TCM310, warum sucht er dann bei mir danach und nicht nach dem definierten CUL? im LOG steht:

usb create starting
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB0
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB0: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB1
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB1: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB2
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB2: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB3
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB3: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB4
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB4: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB5
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB5: No such device
2013.02.05 09:41:56 3: Opening TCM310 device /dev/ttyUSB6
2013.02.05 09:41:56 3: Can't open /dev/ttyUSB6: No such device
2013.02.05 09:41:56 1: usb create end

aber in der cfg steht:

# If the above notify did not helped, then you probably have to enable some of
# the following lines.  Verify first that /dev/xxx ist correct.

#define FHZ FHZ /dev/USB0
define CUL CUL /dev/ttyACM0@9600 1234
#attr CUL rfmode HomeMatic

#define EUL TCM 310 /dev/ttyACM0@57600
#define BscBor TCM 120 /dev/ttyUSB0@9600
#define BscSmartConnect TCM 310 /dev/ttyUSB0@57600

Vielleicht noch eine andere Idee? Danke schon mal für die Anregung.

Offline MisterEltako

  • Sr. Member
  • ****
  • Beiträge: 521
Aw: CUL an Synology
« Antwort #3 am: 05 Februar 2013, 10:08:20 »
Hi!

Achso, das habe ich aus deinem 1. Posting nicht entnommen.

Dann liegt es sicher daran, das in fhem.cfg eine usb-Initialisierungsdefinition definiert ist.
Zum Beispiel soetwas:

define initialUsbCheck notify global:INITIALIZED usb create

oder so ähnlich. Da einfach ein #-Zeichen davor setzen.

(siehe: https://groups.google.com/forum/?fromgroups=#!topic/fhem-users/XI7PBDEtr64)


Kannst auch eventuell den Inhalt der ersten Fhem.cfg posten, dann kann man sicher sagen/schreiben, ob was zuviel ist.

MfG, MisterEltako
HMLAN-Konfigurations-Adapter, HM-Funkjalousieaktor/HM-Dimmaktor/HM-Schaltaktor f. Markenschalter, Jalousie-/Schaltaktor von Eltako, FT4 v. Eltako, TCM310

Offline elbmarschsurfer

  • New Member
  • *
  • Beiträge: 5
Aw: CUL an Synology
« Antwort #4 am: 05 Februar 2013, 10:21:09 »
Hallo,

danke für den Tipp, ich habe das mal ausprobiert. Klingt logisch. Jetzt habe ich das Problem wohl auch gefunden:

2013.02.05 10:12:08 3: Opening CUL device /dev/ttyACM0
2013.02.05 10:12:08 3: Can't open /dev/ttyACM0: No such file or directory

Allerdings habe ich es damit nicht gelöst. Habe im Verzeichnis mal nachgeschaut, wie bekomme ich denn nun ttyACM0 in das Verzeichnis. Kann man das irgendwo her kopieren???

Offline MisterEltako

  • Sr. Member
  • ****
  • Beiträge: 521
Aw: CUL an Synology
« Antwort #5 am: 05 Februar 2013, 14:09:28 »
Hi!

Versuch mal folgendes:

define CUL CUL /dev/ttyUSB0@9600 1234
attr CUL rfmode HomeMatic


MfG, MisterEltako.

HMLAN-Konfigurations-Adapter, HM-Funkjalousieaktor/HM-Dimmaktor/HM-Schaltaktor f. Markenschalter, Jalousie-/Schaltaktor von Eltako, FT4 v. Eltako, TCM310

Offline elbmarschsurfer

  • New Member
  • *
  • Beiträge: 5
Aw: CUL an Synology
« Antwort #6 am: 05 Februar 2013, 14:25:18 »
BINGO!!!

Das Attribut rfmode HomeMatic habe ich mal weggelassen, weil ich FS20-Geräte betreiben möchte, aber der Satus ist jetzt auf "Initialized".

Wenn ich heute abend zu Hause bin, werde ich mal versuchen, ob ich die erste Steckdose zum Schalten bekomme. Ich danke Dir schonmal sehr herzlich für Deine geduldige Unterstützung.

MfG
elbmarschsurfer

 

decade-submarginal