Autor Thema: ZWAVE Dongle Fehlermeldungen - RAZBERRY und Raspberry Pi 3 (gelöst)  (Gelesen 770 mal)

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Nach einem Neuaufsetzen von FHEM habe ich folgende PERL Warnungen. Ich verwende ein RAZBERRY Aufsteckmodul, keinen USB Stick.

# FHEM Log mit Verbose 5
2020.02.25 15:04:51 4: ZWDongle_Read ZWAVE1: rcvd 0004001f06310504220000 (request APPLICATION_COMMAND_HANDLER), sending ACK
2020.02.25 15:04:51 5: SW: 06
2020.02.25 15:04:51 5: ZWAVE1: dispatch 0004001f06310504220000
2020.02.25 15:04:51 4: CMD:APPLICATION_COMMAND_HANDLER ID:1f ARG:06310504220000 CB:00
2020.02.25 15:04:57 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 23884) line 1.
2020.02.25 15:04:57 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 23886) line 1.
2020.02.25 15:04:57 1: PERL WARNING: Argument "91 %" isn't numeric in numeric lt (<) at (eval 23887) line 1.
2020.02.25 15:04:57 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 23888) line 1.
2020.02.25 15:04:57 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 23891) line 1.
2020.02.25 15:04:57 1: PERL WARNING: Argument "97 %" isn't numeric in numeric lt (<) at (eval 23892) line 1.
2020.02.25 15:05:12 4: ZWDongle_Read ZWAVE1: rcvd 00040011033003ff (request APPLICATION_COMMAND_HANDLER), sending ACK
2020.02.25 15:05:12 5: SW: 06
2020.02.25 15:05:12 5: ZWAVE1: dispatch 00040011033003ff
2020.02.25 15:05:12 4: CMD:APPLICATION_COMMAND_HANDLER ID:11 ARG:033003ff CB:00
2020.02.25 15:05:13 4: ZWDongle_Read ZWAVE1: rcvd 00041011032001ff (request APPLICATION_COMMAND_HANDLER), sending ACK
2020.02.25 15:05:13 5: SW: 06

Leider kann ich diese Meldungen nicht interpretieren.
« Letzte Änderung: 29 Februar 2020, 19:45:37 von tom44 »
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22334
Antw:ZW Dongle Fehlermeldungen
« Antwort #1 am: 25 Februar 2020, 18:06:17 »
Bitte "attr global stacktrace" setzen, und auf weitere WARNINGs im Log hoffen.

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Antw:ZW Dongle Fehlermeldungen
« Antwort #2 am: 25 Februar 2020, 18:50:36 »
Danke, da wird nun schon einiges mehr angezeigt:

2020.02.25 18:45:04 5: ZWAVE1: dispatch 00040011032001ff
2020.02.25 18:45:04 4: CMD:APPLICATION_COMMAND_HANDLER ID:11 ARG:032001ff CB:00
2020.02.25 18:45:22 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 36606) line 1.
2020.02.25 18:45:22 1: stacktrace:
2020.02.25 18:45:22 1:     main::__ANON__                      called by (eval 36606) (1)
2020.02.25 18:45:22 1:     (eval)                              called by ./FHEM/33_readingsGroup.pm (357)
2020.02.25 18:45:22 1:     main::lookup2                       called by ./FHEM/33_readingsGroup.pm (540)
2020.02.25 18:45:22 1:     main::readingsGroup_value2html      called by ./FHEM/33_readingsGroup.pm (1109)
2020.02.25 18:45:22 1:     main::readingsGroup_2html           called by ./FHEM/33_readingsGroup.pm (1210)
2020.02.25 18:45:22 1:     main::readingsGroup_detailFn        called by ./FHEM/01_FHEMWEB.pm (2022)
2020.02.25 18:45:22 1:     main::FW_showRoom                   called by ./FHEM/01_FHEMWEB.pm (1137)
2020.02.25 18:45:22 1:     main::FW_answerCall                 called by ./FHEM/01_FHEMWEB.pm (585)
2020.02.25 18:45:22 1:     main::FW_Read                       called by fhem.pl (3764)
2020.02.25 18:45:22 1:     main::CallFn                        called by fhem.pl (756)
2020.02.25 18:45:22 1: PERL WARNING: Argument "100 %" isn't numeric in numeric lt (<) at (eval 36608) line 1.

Ich kann es allerdings noch immer nicht interpretieren.
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22334
Antw:ZW Dongle Fehlermeldungen
« Antwort #3 am: 25 Februar 2020, 19:27:42 »
Eine readingsGroup Definition/Attribut ist nicht ganz sauber, da wird in valueFormat Ausdruck ein numerischer Vergleich (<) mit dem String "100 %" durchgefuehrt.
Ich rate: ReadingsVal muss gegen ReadingsNum ausgetauscht werden, um das % wegzukriegen.

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Antw:ZW Dongle Fehlermeldungen
« Antwort #4 am: 25 Februar 2020, 21:00:30 »
Danke. Zu meinem Verständnis, da ich nur eine, nämlich folgende readingsGroup Definition gefunden habe:

#Batteriestatus aller Devices im Raum Zentral anzeigen
define ZE.Batterie readingsGroup.*:[Bb]attery\
.*:[Bb]atteryLevel
setuuid ZE.Batterie 5c4c259a-f33f-e3fe-5e0c-37f97dfdb2cbc3a7

Im Raum Zentral habe ich den Batteriestatus von 14 Devices, allesamt mit einer grafischen Darstellung (die bislang und auch jetzt funktioniert haben). Ist das damit gemeint?
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 487
Antw:ZW Dongle Fehlermeldungen
« Antwort #5 am: 25 Februar 2020, 22:33:17 »
Hallo tom44,

vermute meine Batterieüberwachung abgekupfert, sieht Ausschnitt vom List so aus, vielleicht hilft Dir
das attr. valueFormat
wenn ich auch weiter keine Ahnung habe  :(

Attributes:
   comment    Batteriestatus aller Devices im Raum Zentral anzeigen
   notime     1
   room       Alarm/Sicherheit
   valueFormat {return "0" if( $VALUE eq "low" );; return "100" if( $VALUE eq "ok" );; return "25" if( $VALUE < 25 );; return "50" if( $VALUE < 50 );; return "75" if( $VALUE < 75 );; return "100"}
   valueIcon  {'battery.0' => 'measure_battery_0@red','battery.100' => 'measure_battery_100@green','Battery.0' => 'measure_battery_0@red','Battery.100' => 'measure_battery_100@green','batteryPercent.0' => 'measure_battery_0@red','batteryPercent.25' => 'measure_battery_25@red','batteryPercent.50' => 'measure_battery_50@orange','batteryPercent.75' => 'measure_battery_75@green','batteryPercent.100' => 'measure_battery_100@green'}

Internals:
   DEF        .*:[bB]atteryState\ .*:[bB]atteryPercent
   FUUID      5c51583e-f33f-cca1-eda6-d358c4596108d8a3
   NAME       Batterieladung
   NR         262
   NTFY_ORDER 50-Batterieladung
   STATE      Initialized
   TYPE       readingsGroup
   changed    0
   mayBeVisible 1

Gruß
Hans-Jürgen

FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid,Aeotec USB Dongle Z-Wave Plus

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Antw:ZW Dongle Fehlermeldungen
« Antwort #6 am: 28 Februar 2020, 18:48:14 »
Hallo Deckoffizier, Hallo rudolfkoenig,

danke an den globalen und konkrenten Hinweis zur Lösung. Das löschen von
   valueFormat {return "0" if( $VALUE eq "low" );; return "100" if( $VALUE eq "ok" );; return "25" if( $VALUE < 25 );; return "50" if( $VALUE < 50 );; return "75" if( $VALUE < 75 );; return "100"}hat zum Erfolg geführt. Das hatte gar keinen Zusammenhang mit dem ZWAVE Aufsteckmodul, stand nur eine Zeile darunter.
Die Fehlermeldungen treten nicht mehr auf. Ich habe nuin den Batteriestatus nicht mehr visuell, sondern in Prozenten, was mir ausreicht.

Die weiteren ZWAVE Zeilen im Sekundentakt sind aber ok?
2020.02.28 18:37:06 5: ZWAVE1: dispatch 0004001f0631050422348c
2020.02.28 18:37:06 4: CMD:APPLICATION_COMMAND_HANDLER ID:1f ARG:0631050422348c CB:00
2020.02.28 18:37:15 4: ZWDongle_Read ZWAVE1: rcvd 0004001f0631050422091c (request APPLICATION_COMMAND_HANDLER), sending ACK
2020.02.28 18:37:15 5: SW: 06
2020.02.28 18:37:15 5: ZWAVE1: dispatch 0004001f0631050422091c
2020.02.28 18:37:15 4: CMD:APPLICATION_COMMAND_HANDLER ID:1f ARG:0631050422091c CB:00
2020.02.28 18:37:16 4: ZWDongle_Read ZWAVE1: rcvd 0004001f0631050422000e (request APPLICATION_COMMAND_HANDLER), sending ACK
2020.02.28 18:37:16 5: SW: 06
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Antw:ZW Dongle Fehlermeldungen
« Antwort #7 am: 28 Februar 2020, 18:57:09 »
Irgendwas stimmt da leider noch immer nicht:
2020-02-28 18:51:32 ZWDongle ZWAVE1 DISCONNECTED
2020-02-28 18:51:38 ZWDongle ZWAVE1 Initialized
2020-02-28 18:51:38 ZWDongle ZWAVE1 CONNECTED

Aus dem Log. FHEM hat mächtig viel zu tun... und ich habe keinen blasen Schimmer, was das bedeutet, außer dass es immer wieder timeouts gibt:
2020.02.28 18:51:38 4: ZWDongle *** set ZWAVE1 timeouts 100 15
2020.02.28 18:51:38 5: ZWDongle_Write 0006640f ()
2020.02.28 18:51:38 5: SW: 01050006640f97
2020.02.28 18:51:38 4: ZWDongle_ReadAnswer arg:timeouts regexp:^0106
2020.02.28 18:51:38 5: ACK received, removing 01050006640f97 from dongle sendstack
2020.02.28 18:51:38 4: ZWDongle_Read ZWAVE1: rcvd 0106640f (answer SERIAL_API_SET_TIMEOUTS), sending ACK
2020.02.28 18:51:38 5: SW: 06
2020.02.28 18:51:38 4: ZWDongle_ReadAnswer for timeouts: 0106640f
2020.02.28 18:51:38 4: ZWDongle *** set ZWAVE1 setNIF 1 2 1 0
2020.02.28 18:51:38 5: ZWDongle_Write 000301020100 ()
2020.02.28 18:51:38 5: SW: 0107000301020100f9
2020.02.28 18:51:38 1: /dev/ttyAMA0 reappeared (ZWAVE1)
2020.02.28 18:51:38 5: ACK received, removing 0107000301020100f9 from dongle sendstack
2020.02.28 18:52:05 3: ZWave got config for fibaro/fgpb101.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
2020.02.28 18:52:07 3: ZWave got config for fibaro/fgfs101zw5.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
2020.02.28 18:52:07 1: FHEMWEB SSL/HTTPS error:  SSL accept attempt failed (peer: 192.168.178.21)
2020.02.28 18:52:07 4: ZWDongle_Read ZWAVE1: rcvd 0004001103300300 (request APPLICATION_COMMAND_HANDLER), sending ACK
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22334
Antw:ZW Dongle Fehlermeldungen
« Antwort #8 am: 28 Februar 2020, 19:46:45 »
Dass bei verbose 5 viel geschrieben wird, ist normal, schliesslich ist das als Hilfe bei der Fehlersuche gedacht.

Der Ausschnitt zeigt eine Dongle-Initialisierung, und ein SSL Fehler
- die Initialisierung (mit reappered am Schluss) besagt, dass irgendetwas auf dem Weg zum Dongle nicht in Ordnung ist: entweder ist das ein USB-Problem, oder der Dongle ist kaputt, und fuehrt unmotiviert resets durch. Alternativ sind mehrere ZWDongle Instanzen mit /dev/ttyAMA0 definiert.
- SSL/HTTPS error: vmtl. versucht jemand eine nicht HTTPS Verbindung aufzubauen.

Offline tom44

  • Full Member
  • ***
  • Beiträge: 161
  • script-oldie
Antw:ZW Dongle Fehlermeldungen (gelöst)
« Antwort #9 am: 29 Februar 2020, 17:56:07 »
Dass bei verbose 5 viel geschrieben wird, ist normal, schliesslich ist das als Hilfe bei der Fehlersuche gedacht.
Der Ausschnitt zeigt eine Dongle-Initialisierung, und ein SSL Fehler
- die Initialisierung (mit reappered am Schluss) besagt, dass irgendetwas auf dem Weg zum Dongle nicht in Ordnung ist: entweder ist das ein USB-Problem, oder der Dongle ist kaputt, und fuehrt unmotiviert resets durch. Alternativ sind mehrere ZWDongle Instanzen mit /dev/ttyAMA0 definiert.
Vielen Dank Rudolf. Ich werde alt .... das Problem hatte ich schon vor einiger Zeit, konnte mich allerdings nicht mehr erinnern.
Lösung: RAZBERRY Aufsteckmodul und Raspberry Pi 3 / Bluetooth vertragen sich nicht:
Der Raspberry Pi 3 nutzt für den GPIO-Port standardmäßig den UART1 (ttyS0), während die vorherigen Raspberry Pi-Modelle noch den UART0 dafür verwendeten. Der UART0 (ttyAMA0) wird beim Pi 3 durch das neu eingeführte Bluetooth-Modul softwaremäßig belegt.
https://forum.fhem.de/index.php/topic,52161.msg439757.html#msg439757
Ich habe Bluetooth deaktiviert.

Wenn man Bluetooth weiterhin nutzen möchte, gibt es eine bessere Lösung unter:
https://wiki.fhem.de/wiki/Raspberry_Pi_3:_GPIO-Port_Module_und_Bluetooth
Hier bin allerdings ganz banal daran gescheitert, in der Raspi-config mit
sudo raspi-config
A7 Serial auf enabled setzen
In der Raspi-Config gibt es den Punkt (nicht mehr). Kann man das (vielleicht sogar ich) im Wiki korrigieren?
FHEM 17762 auf Raspberry Pi 3 Model B Rev | nanoCUL868, CUL 868 MhZ, Rolladen- Aktoren, Heizung | Z-Wave, FIBARO FGD211 Universal Dimmer 500W, Popp Plug-in Dimmer, FIBARO Wall Plug, Everspring PIR Motion Sensor, FIBARO Door Opening Sensor | Netatmo

 

decade-submarginal