FHEM - Hardware > Einplatinencomputer

Raspberry pi 3B friert ein

<< < (2/3) > >>

TheRelativ:
Danke für den Tipp.
Habs nun geschafft dank eines Backups die SD Karte wieder ans rennen zu kriegen.
Backup wiederhergestellt und FHEM Ordner+Datenbank und Zigbee Daten von der SSD rüberkopiert.

Ich habe nun die USB Geräte ohne USB Hub wieder dran, den Netatmo hab ich eine separate Stromversorgung gegeben.
-- Signalduino radino CC1101
-- Zigbee CC2531 USB Stick
-- CUL868 (für Homematic)

Im Moment scheints stabil, mal 2-3 Tage abwarten

Gernott:
Hallo

Ich habe hier komischerweise dasselbe Problem mit einem Raspi 3B mit Buster und einem Minimal-FHEM. Auf den wollte ich eigentlich meine alte Installation umziehen und lasse das Teil daher seit einigen Wochen als Test laufen. Ich habe irgendein Raspbian-Update im Verdacht, da das Teil nun das zweite Mal innerhalb von 4 Tagen  hängengeblieben ist, aber vorher wochenlang ohne Problem lief.
Die Heartbeat-LED blinkt zwar noch, aber ein Netzwerkzugriff ist nicht mehr möglich.
Der letzte Eintrag im syslog ist

--- Code: ---CRON[11137]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
--- Ende Code ---
Etwa 40 min später käme die Statistik vom rngd, die aber fehlt.
Die Neustarteinträge erfolgen mit einem Zeitstempel 14 s später als der vom letzten cron-hourly.
Das war dann wohl die letzte erfolgreiche Speicherung von der fake-hwclock.
Der letzte Logeintrag im FHEM vom Sysmon ist allerdings 32 min nach dem cron-hourly.
Muß mal schauen, ob ich noch etwas finde.

Wie läuft denn Dein System?

Gruß
G.

connormcl:
Hast du am zweiten Pi der hängt auch viel am USB?

Falls ja, hast du einen USB Spannungsmesser, um zu sehen, ob er die USB Ports abschaltet und damit deine Filesysteme bzw. die SSD mitreisst?

Das wäre schwierig zu erkennen. Ich habe das nur anhand neu hochdrehender Festplatten an einem openmediavault-Pi gemerkt.

Ich zitiere mich mal aus einem anderen Thread :)


--- Zitat ---Nur zur Sicherheit, weil ich beim NAS-Aufbau mit Pi 3B darüber gestolpert bin und das hier im Thread noch nicht gesehen habe:

Ohne besondere Einstellung schaltet der Raspberry Pi ab einer Stromentnahme von 600 mA die USB-Ports komplett ab. Die Grenze gilt nicht pro Port, sondern insgesamt! Damit ist sie ohne powered USB-Hub auch schnell erreicht.

Somit ist das auch meist keine Frage einer "besseren" 5V Versorgung, da hart nach Messwert gekappt wird!
 
Man kann über die config.txt das Limit auf 1.2A hochsetzen:

https://www.elektronik-kompendium.de/sites/raspberry-pi/2206111.htm
--- Ende Zitat ---

Otto123:
Auszug aus der Original Doku https://www.raspberrypi.org/documentation/configuration/config-txt/misc.md

--- Zitat ---This command is now deprecated. Originally certain models of Raspberry Pi limited the USB ports to a maximum of 600mA. Setting max_usb_current=1 changed this default to 1200mA. However, all firmware now has this flag set by default, so it is no longer necessary to use this option.
--- Ende Zitat ---

connormcl:

--- Zitat von: Otto123 am 14 Mai 2020, 23:06:31 ---Auszug aus der Original Doku https://www.raspberrypi.org/documentation/configuration/config-txt/misc.md

--- Ende Zitat ---

Damit stehst du nun bei 1200mA anstatt 600mA.

Problem an der Sache ist nach wie vor, dass der Wert sich aus dem Stromverbrauch über alle USB-Ports inkl. Ethernet berechnet und nicht nur für einen Port gilt.
Aber damit ist natürlich unwahrscheinlich, dass der TE das Problem hat. Das tritt erst ab ca. 2 externen Festplatten auf.

Es ist ja einfach das auszuschliessen bzw. einen Powered-HUB zu verwenden. Man muss es nur wissen, wenn plötzlich alle USB-Ports inaktiv sind und man sich wundert.

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln