Autor Thema: [gelöst]MapleCUN kein Empfang Elro FB und EV1527  (Gelesen 697 mal)

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
[gelöst]MapleCUN kein Empfang Elro FB und EV1527
« am: 06 April 2020, 21:37:14 »
Hallo Forum.

Ich habe einen MapleCul mit 433Mhz und 868Mhz Funkmodulen. Mit dem 433Mhz Modul möchte ich gerne die Signale der zwei Elro Fernbedienungen und eines Wandschalters (EV1527) empfangen.
Alle 6 Elro Steckdosen lassen sich schalten und funktionieren sehr gut.(mit FHEM und/oder Fernbedienung)
Ich habe schon einiges gelesen und versucht, bekomme es aber nicht hin, das der CUL die Funksignale der Fernbedienung empfängt. Ich glaube, dass ich am Cul etwas falsch eingestellt habe. Kann jemand der sich besser auskennt, mal drüber schauen und mir einen Wink in die richtige Richtung geben?


Hier mal ein List vom Gerät:

Internals:
   CMDS       bCFiAZNEGMKLUYRTVWXfxz
   Clients    :FS20:FHT.*:KS300:USF1000:BS:HMS:FS20V: :CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN: :ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY: :STACKABLE_CC:TSSTACKED:STACKABLE:CUL_RFR::CUL_TCM97001:CUL_REDIRECT:
   DEF        MapleCUL1.1
   FUUID      5d487c8e-f33f-b7a0-c11a-fd880c375888631a
   IODev      MapleCUL1.1
   MapleCUL1.2_MSGCNT 15
   MapleCUL1.2_TIME 2020-04-05 22:35:30
   NAME       MapleCUL1.2
   NOTIFYDEV  MapleCUL1.1
   NR         511
   NTFY_ORDER 50-MapleCUL1.2
   PARTIAL   
   RAWMSG     omD554A01A
   RSSI       -59
   STATE      Initialized
   StackLevel 2
   TYPE       STACKABLE_CC
   VERSION    V 1.26.06 a-culfw Build: 315 (2019-04-07_19-59-48) MapleCUNx4_87 (F-Band: 433MHz)
   initString X21
   MatchList:
     0:FS20V    ^81..(04|0c)..0101a001......00[89a-f]...
     1:USF1000  ^81..(04|0c)..0101a001a5ceaa00....
     2:BS       ^81..(04|0c)..0101a001a5cf
     3:FS20     ^81..(04|0c)..0101a001
     4:FHT      ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
     5:KS300    ^810d04..4027a001
     6:CUL_WS   ^K.....
     7:CUL_EM   ^E0.................$
     8:HMS      ^810e04......a001
     9:CUL_FHTTK ^T[A-F0-9]{8}
     A:CUL_RFR  ^[0-9A-F]{4}U.
     B:CUL_HOERMANN ^R..........
     C:ESA2000  ^S................................$
     D:CUL_IR   ^I............
     E:CUL_TX   ^TX[A-F0-9]{10}
     F:Revolt   ^r......................$
     G:IT       ^i......
     H:STACKABLE_CC ^\*
     I:UNIRoll  ^[0-9A-F]{5}(B|D|E)
     J:SOMFY    ^Y[r|t|s]:?[A-F0-9]+
     K:CUL_TCM97001 ^s[A-F0-9]+
     L:CUL_REDIRECT ^o+
     M:TSSTACKED ^\*
     N:STACKABLE ^\*
   READINGS:
     2020-04-05 22:41:36   ccconf          freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB
     2020-04-05 22:41:35   cmds             b C F i A Z N E G M K L U Y R T V W X f x z
     2020-04-05 22:35:14   raw             is0F0F0F0FFFF0
     2020-04-05 22:41:35   state           Initialized
     2020-04-05 21:59:39   version         V 1.26.06 a-culfw Build: 315 (2019-04-07_19-59-48) MapleCUNx4_87 (F-Band: 433MHz)
Attributes:

Vielen Dank und Gruß

beSmart
« Letzte Änderung: 20 April 2020, 09:48:24 von beSmart »

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2450
  • Es begann alles so klein ;-)
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #1 am: 07 April 2020, 09:55:51 »
Moin,
Stell mal bitte verbose auf 4, danach fhem save und dann shutdown restart.

Dann den eventmonitor mit häckchen bei log und hier posten, was bei den ersten beiden Tasten mehrfach innerhalb 30s drücken passiert.

Ich vermute: Entweder der cc1101 ist taub oder die frequenz weicht ab oder er ist dich falsch initialisert (mal raw e versucht?)

Schaun wir mal,
Gruß Arnd


Signalduino (Nano, ESP, ...), CUL (Busware, Nano, Maple, ...), Homematic (HM-MOD-UART-RPI, ESP, Maple, ...), LaCrosseGateway (LGW, ESP, ...), 1-wire, ESPEasy, Bravia, Yamaha, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #2 am: 07 April 2020, 10:50:15 »
Hallo Arnd.

Erstmal vielen Dank für deine Hilfe!

Verbösert 4 liefert folgendes log:

Elro
2020.04.07 10:18:56 4: CUL_Parse: MapleCUL1.2 i51055107 -70.5
2020.04.07 10:18:56 4: MapleCUL1.2 IT: message "i510551" (7)
2020.04.07 10:18:56 4: MapleCUL1.2 IT: msgcode "FF0F00FFFF0F" (12) bin = 010100010000010101010001
2020.04.07 10:18:56 4: MapleCUL1.2 IT: FF0F00FFFF not defined (Switch code: 0F)

EV1527
2020.04.07 10:26:10 4: CUL_Parse: MapleCUL1.2 i047E682F -50.5
2020.04.07 10:26:10 4: MapleCUL1.2 IT: message "i047e68" (7)
2020.04.07 10:26:10 4: MapleCUL1.2 IT: msgcode "" (0) bin = 000001000111111001101000
2020.04.07 10:26:10 4: MapleCUL1.2 IT: 1527x047e6 not defined (Switch code: 1000)

Mir sind 2 Dinge aufgefallen:
1. dass nur ein Tastendruck erkannt wird. Danach scheint der Cul nichts mehr zu empfangen. Ist das "normal"?

2. Bei "set MapleCUL1.2 raw e" passiert nichts! Heißt der blinkende Cursor hinter dem e verschwindet sonst passiert nichts.


Gruß


Dirk

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2450
  • Es begann alles so klein ;-)
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #3 am: 07 April 2020, 12:06:38 »
Hi,
also
1) er empfängt! Gut
2) er sollte jede Taste empfangen
3) das raw e war dann jetzt nicht nötig ;-) Ist ein „Werksreset“

Wenn Du sagst nach einer Taste kommt nichts mehr. Wie kann er dann die EV erkennen?

Das Gerät wird erst angelegt, wenn die gleiche Taste mindestens 2 mal in 60s empfangen wird und autocreate (im global device) an ist.

Also versuch mal Taste drücken, maple resetten (z.b. Usb raus und rein), gleiche taste drücken innerhalb 60s.

Gruß Arnd


Signalduino (Nano, ESP, ...), CUL (Busware, Nano, Maple, ...), Homematic (HM-MOD-UART-RPI, ESP, Maple, ...), LaCrosseGateway (LGW, ESP, ...), 1-wire, ESPEasy, Bravia, Yamaha, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #4 am: 07 April 2020, 13:07:07 »
Hallo,

entschuldige bitte, dass ich vergessen habe zu erwähnen, daß dazwischen ein shutdown restart liegt.

Es funktioniert wie gesagt nur ein Tastendruck dann ist Schluß.

Gruß Dirk

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2450
  • Es begann alles so klein ;-)
MapleCUN kein Empfang Elro FB und EV1527
« Antwort #5 am: 07 April 2020, 14:43:55 »
Hi
Also entweder der maple hängt sich auf und wird mittels close/open oder reset wieder oder Dein fhem steht!?

Also wenn der maple das Thema hat, würde ich auch mal eine neuen firmware flashen, aber zunächst mal rausbekommen ob close/open bzw. reset reicht.

Wie gesagt, dass Ziel sind 2 gleiche erkannte Tasten in 60s ohne fhem restart ;-)

Gruß Arnd


Signalduino (Nano, ESP, ...), CUL (Busware, Nano, Maple, ...), Homematic (HM-MOD-UART-RPI, ESP, Maple, ...), LaCrosseGateway (LGW, ESP, ...), 1-wire, ESPEasy, Bravia, Yamaha, ...
« Letzte Änderung: 07 April 2020, 14:51:33 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #6 am: 08 April 2020, 08:28:23 »
Guten Morgen.

Ich habe es geschaft, dass der Schalter erkannt wird und dabei einiges festgestellt.

Das Funkmodul scheint sich beim ersten Tastendruck aufzuhängen. Danach ist kein Empfang mehr möglich, senden geht ohne Probleme.
"get ccconf" liefert beim ersten Mal "FD0" oder so ähnlich wenn man "get ccconf" 2-3 mal öfters abfragt, kommt die MeldungTimeout reading answer for get C0DNach dem 3-4 Versuch wird dann die Frequenz usw. angezeigt. Vermutlich erfolgt nach der Abfrage ein Reset?
Danach wird der erste Tastendruck auch wieder empfangen, danach ist Schluss bis "geht ccconf" die Frequenz ausgibt.

Hier mal die lists von den Geräten:( vom Maple, wenn er nicht empfängt)

Internals:
  CMDS       bCFiAZNEGMKLUYRTVWXfxz
  Clients    :FS20:FHT.*:KS300:USF1000:BS:HMS:FS20V: :CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN: :ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY: :STACKABLE_CC:TSSTACKED:STACKABLE:CUL_RFR::CUL_TCM97001:CUL_REDIRECT:
  DEF        MapleCUL1.1
  FUUID      5d487c8e-f33f-b7a0-c11a-fd880c375888631a
  IODev      MapleCUL1.1
  MapleCUL1.2_MSGCNT 10
  MapleCUL1.2_TIME 2020-04-07 21:58:36
  NAME       MapleCUL1.2
  NOTIFYDEV  MapleCUL1.1
  NR         511
  NTFY_ORDER 50-MapleCUL1.2
  PARTIAL
  RAWMSG     i047E682A
  RSSI       -53
  STATE      Initialized
  StackLevel 2
  TYPE       STACKABLE_CC
  VERSION    V 1.26.06 a-culfw Build: 315 (2019-04-07_19-59-48) MapleCUNx4_87 (F-Band: 433MHz)
  initString X21
  MatchList:
    0:FS20V    ^81..(04|0c)..0101a001......00[89a-f]...
    1:USF1000  ^81..(04|0c)..0101a001a5ceaa00....
    2:BS       ^81..(04|0c)..0101a001a5cf
    3:FS20     ^81..(04|0c)..0101a001
    4:FHT      ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
    5:KS300    ^810d04..4027a001
    6:CUL_WS   ^K.....
    7:CUL_EM   ^E0.................$
    8:HMS      ^810e04......a001
    9:CUL_FHTTK ^T[A-F0-9]{8}
    A:CUL_RFR  ^[0-9A-F]{4}U.
    B:CUL_HOERMANN ^R..........
    C:ESA2000  ^S................................$
    D:CUL_IR   ^I............
    E:CUL_TX   ^TX[A-F0-9]{10}
    F:Revolt   ^r......................$
    G:IT       ^i......
    H:STACKABLE_CC ^\*
    I:UNIRoll  ^[0-9A-F]{5}(B|D|E)
    J:SOMFY    ^Y[r|t|s]:?[A-F0-9]+
    K:CUL_TCM97001 ^s[A-F0-9]+
    L:CUL_REDIRECT ^o+
    M:TSSTACKED ^\*
    N:STACKABLE ^\*
  READINGS:
    2020-04-07 21:58:29   ccconf          freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB
    2020-04-07 21:58:25   cmds             b C F i A Z N E G M K L U Y R T V W X f x z
    2020-04-07 21:56:44   raw             is00F0F11DFDDD
    2020-04-07 21:58:36   state           Initialized
    2020-04-05 21:59:39   version         V 1.26.06 a-culfw Build: 315 (2019-04-07_19-59-48) MapleCUNx4_87 (F-Band: 433MHz)
Attributes:
  group      Funkmodule
  rfmode     SlowRF
  room       Server
  verbose    4

und vom Schalter:

Internals:
  DEF        1527x047e6 1000 1010
  FUUID      5e8cd1d2-f33f-b7a0-c3ae-03ae9a7530d97e33
  IODev      MapleCUL1.2
  LASTInputDev MapleCUL1.2
  MSGCNT     8
  MapleCUL1.2_MSGCNT 8
  MapleCUL1.2_RAWMSG i047e68
  MapleCUL1.2_RSSI -53
  MapleCUL1.2_TIME 2020-04-07 21:58:36
  NAME       IT_1527x047e6
  NR         519
  STATE      on
  TYPE       IT
  XMIT       00f0f11dfd
  XMITdimdown 00
  XMITdimup  00
  XMIToff    1010
  XMITon     1000
  CODE:
    1          1527x047e6
  READINGS:
    2020-04-07 21:17:45   protocol        EV1527
    2020-04-07 21:58:36   state           on
Attributes:
  IODev      MapleCUL1.2
  model      ev1527
  room       IT


Macht es Sinn das Funkmodul auszutauschen?
Ich habe gestern mal bei eBay und Ali geschaut konnte aber nur die 868er finden. Hast du einen Tipp wo ich 433Mhz Module bekomme ?(größe Briefmarke)


Vielen Dank und Gruß


Dirk


Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2450
  • Es begann alles so klein ;-)
MapleCUN kein Empfang Elro FB und EV1527
« Antwort #7 am: 08 April 2020, 09:41:15 »
Hi,
Ich würde erstmal eine andere firmware flashen und schauen ob es wirklich am cc1101 liegt.

Könnte ja auch nur ein timing problem der firmware zum cc1101 sein.

Welche a-culfw hast du schon alles probiert?


#### 1.26.08
- MapleCUN: Fix serial2net

#### 1.26.07
- MapleCUN/CUBe: MSC bootloader
- CUBe: Bugfix HW autodetect


Vgl. https://github.com/heliflieger/a-culfw/blob/master/CHANGELOG

Gruß Arnd


Signalduino (Nano, ESP, ...), CUL (Busware, Nano, Maple, ...), Homematic (HM-MOD-UART-RPI, ESP, Maple, ...), LaCrosseGateway (LGW, ESP, ...), 1-wire, ESPEasy, Bravia, Yamaha, ...
« Letzte Änderung: 08 April 2020, 09:43:16 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #8 am: 08 April 2020, 11:19:24 »
Hallo und vielen Dank für deine Tipps. Ich werde mal versuchen eine andere Firmware zu installieren

Probiert habe ich aber noch keine andere Firmware.
Installiert ist 1.26.06 a-culfw.

Ich weiß im Augenblick auch nicht wie ich ein Update auf dem Maple mache.... Ich hatte vorher NanoCuls (USB) da wußte ich wie es geht.
Geht ein Update per LAN oder nur über USB?


Gruß Dirk


Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 2450
  • Es begann alles so klein ;-)
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #9 am: 08 April 2020, 14:25:13 »
Hi,
Ich glaube nur über usb. Schau mal hier:

https://wiki.fhem.de/wiki/MapleCUN

Gruß Arnd


Signalduino (Nano, ESP, ...), CUL (Busware, Nano, Maple, ...), Homematic (HM-MOD-UART-RPI, ESP, Maple, ...), LaCrosseGateway (LGW, ESP, ...), 1-wire, ESPEasy, Bravia, Yamaha, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #10 am: 10 April 2020, 20:44:14 »
Hallo.

Der MapleCul scheint ein Problem zu haben. Er startet pi x Daumen alle 2 Std. neu.(ohne Funkverkehr, mit öfters) Ich habe noch einen zweiten, allerdings ohne 433Mhz Modul. Der zeigt dieses Verhalten nicht. Werde mal schauen ob das Netzteil in Ordnung ist, sonst Stück für Stück die Module entfernen und mal schauen was passiert.

Habe mir aus „Resten“ einen SignalDuino gebaut.Der funktioniert ohne Probleme.


Erstmal vielen Dank für deine Unterstützung, ich melde mich wenn das Problem gelöst ist.

Gruß

Dirk

Offline beSmart

  • Full Member
  • ***
  • Beiträge: 148
Antw:MapleCUN kein Empfang Elro FB und EV1527
« Antwort #11 am: 20 April 2020, 09:47:31 »
Hallo.

Es ist nicht zu glauben..... Es lag tatsächlich am Netzteil! Habe das Netzteil ausgetauscht und jetzt funktioniert er einwandfrei.

Vielen Dank für die Unterstützung.

Gruß

Dirk

 

decade-submarginal