Autor Thema: Modul für Steuerung einer Go-ECharger Wallbox [= go-e oder go-echarger]  (Gelesen 30156 mal)

Offline LR66

  • Full Member
  • ***
  • Beiträge: 143
Für Überschussladen hast Du noch paar Wochen Zeit (wenn Deine Anlage nicht gerade riesig ist :-) ).
Schau Dir mal Deine jeweiligen states und das devStateIcon an. Das devStateIcon .* für alles unbekannte habe ich bei mir rausgenommen (kommt ja dann auch bei initialized,...).
Mein devStateIcon:
disabled.*:ev-station@darkgrey not_allowed.*:ev-station@white ready_no_car.*:ev-station@blue charging.*:ev-station@darkorange waiting_for_car.*:ev-station@pink finished.*:ev-station@lime error.*:ev-station@red
... aber kannst Du auch anpassen.
Beim stateformat wird quasi state und der Messwert angezeigt. Beim Anlegen kopiere ggf eine Kopie meines o.g .Textes mit Zeilenumbruch. Wenn Du auf edit des Attr stateFormat klickst, muss sich das Fenster mit 2 entsprechenden Zeilen zeigen.

Offline pnewman

  • Full Member
  • ***
  • Beiträge: 257
Vielen Dank für deine Hilfestellung.

Bei mir sieht es nun in den Attributen aus wie von dir beschrieben.

Das Ergebnis sieht leider nicht aus wie bei dir.

Gruß

Ralf
Raspberry Pi3B+ / Nano-Cul 868 - MAX!=Heizung, HM-Lan - Rollo+Licht, JeeLink-Clone 868 - LaCrosse, JeeLink-Clone 868 - PCA301, CUL 434 - IT-Steckdosen+Fernbedienung

Offline LR66

  • Full Member
  • ***
  • Beiträge: 143
Hi, zur Darstellung:
Lösch mal bitte das devStateIcon:   .*:ev-station@yellow
Über das .* allein führen alle nicht anders definierten state zu gelbem  Symbol, damit auch kW_charge_measured...
Also nur benannte wie 'ready_no_car' oder 'error' explizit mit Farbe für Symbol definieren.
Viele Grüße, Lutz

Offline pnewman

  • Full Member
  • ***
  • Beiträge: 257
Hi, zur Darstellung:
Lösch mal bitte das devStateIcon:   .*:ev-station@yellow

Hallo Lutz,

vielen Dank für die Hilfe.

Das löschen hat geholfen!

Nun habe auch Ich eine Verbrauchsanzeige neben dem Symbol!

Gruß
Ralf
Raspberry Pi3B+ / Nano-Cul 868 - MAX!=Heizung, HM-Lan - Rollo+Licht, JeeLink-Clone 868 - LaCrosse, JeeLink-Clone 868 - PCA301, CUL 434 - IT-Steckdosen+Fernbedienung

Offline xerion

  • Sr. Member
  • ****
  • Beiträge: 606
Moin zusammen,

ich habe seit zwei Tagen auch endlich meinen go-eCharger. Bin gerade dabei alles in FHEM einzurichten. Grundsätzlich läuft alles, aber wenn ich used_api_keys von default auf all stelle kommen nur noch zwei Readings. Ich hatte es so verstanden dass dann alles was möglich ist abgefragt wird.

Offline xerion

  • Sr. Member
  • ****
  • Beiträge: 606
Habe den "Fehler" gerade selber gefunden. Im Code steht allkeys und in der Hilfe all. Wenn man  also allkeys eingibt dann funktioniert es.

Offline LR66

  • Full Member
  • ***
  • Beiträge: 143
Oh, sorry... danke für den Hinweis auf den Fehler.
Viele Grüße,
Lutz

Offline Eckat

  • New Member
  • *
  • Beiträge: 40
Das funktioniert fast perfekt  :)

Eine Frage noch. Ich habe die svg Datei nach www/images/fhemSVG kopiert.
Mir werden die Symbole aber nicht angezeigt, nur der Text.

Jemand eine Idee?  ;D

Offline LR66

  • Full Member
  • ***
  • Beiträge: 143
Das ist der richtige Platz. Der Icon-Cache muss neu geladen werden - da gab es was, wie man das macht, weiß ich grad nicht. Wenn Dir ein Neustart nicht weh tut (gleich mit Update verbinden), sollte das auch klappen.
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline jw9

  • New Member
  • *
  • Beiträge: 37
Hallo allerseits,

ich versuche (basierend auf dem weiter oben im Thread geposteten DOIF) den Go-E in Abhängigkeit des verfügbaren Überschusses zu steuern:

## 1 ## incr
            (([SMA_Energymeter:Saldo_Wirkleistung] > (1*230)/2-1000) ## speist mehr als 690 ins Netz?
and ([GoE:car_state] == 2)                           ## beim Laden?
and ([?GoE:amp_current] < [?GoE:amp_max_wallbox]))   ## akt. Ladestrom < max?
  {Log 1,"GoE 1 state:[GoE:car_state] incr allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
  (set GoE amp_current [GoE:amp_current:d:$1+1])
##
## 2 ## decr
DOELSEIF   (([SMA_Energymeter:Saldo_Wirkleistung] < -(1*230)/2-500) # bezug
and ([?GoE:car_state] == 2)
and ([?GoE:amp_current] > 7))
  {Log 1,"GoE 2 state:[GoE:car_state] decr allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
  (set GoE amp_current [GoE:amp_current:d:$1-1])
##
## 3 ## stop
DOELSEIF   (([SMA_Energymeter:Saldo_Wirkleistung] < -(1*230)/2-500)
and ([?GoE:car_state] == 2)
and ([?GoE:amp_current] == 7))
  {Log 1,"GoE 3 state:[GoE:car_state] stop allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
  (set GoE allow_charging 0)
  {Log 1,"GoE_max_PV: PV Chg STOP @ [?VIN_des_Teslacar:battery_level]% / [?VIN_des_Teslacar:charge_limit_soc]%"}
##
## 4 ## finished
DOELSEIF (([SMA_Energymeter:Saldo_Wirkleistung] > -10000)
and ([?GoE:car_state] == 4))
##and ([?VIN_des_Teslacar:charge_limit_soc] <= [?VIN_des_Teslacar:battery_level]))
  {Log 1,"GoE 4 state:[GoE:car_state] fin  allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
##  {Log 1,"GoE_max_PV: PV Chg OK @ [?VIN_des_Teslacar:battery_level]% / [?VIN_des_Teslacar:charge_limit_soc]%"}
##
## 5 ## start
DOELSEIF (([SMA_Energymeter:Saldo_Wirkleistung:avg3] > 6*1*230-500)
and ([?GoE:car_state] > 1))
##and ([?VIN_des_Teslacar:charge_limit_soc] >= [?VIN_des_Teslacar:battery_level])
##and ([?VIN_des_Teslacar] =~ "online"))
  {Log 1,"GoE 5 state:[GoE:car_state] strt allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
  (set GoE amp_current 7)
  (set GoE allow_charging 1)
##  {Log 1,"GoE_max_PV: PV Chg START @ [?VIN_des_Teslacar:battery_level]% / [?VIN_des_Teslacar:charge_limit_soc]%"}
##
## 6 ## noCar
DOELSEIF (([SMA_Energymeter:Saldo_Wirkleistung] > -10000)
and ([?GoE:car_state] == 1))
  {Log 1,"GoE 6 state:[GoE:car_state] !car allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
##
## 7 ## wakeupCar
DOELSEIF      (([SMA_Energymeter:Saldo_Wirkleistung] > 6*1*230-500)
and ([?GoE:car_state] > 1))
##and ([?VIN_des_Teslacar:charge_limit_soc] > [?VIN_des_Teslacar:battery_level])
##and ([?VIN_des_Teslacar] !~ "online")
##and ([?PW2_SOC:pct] > 50))
##  (set VIN_des_Teslacar wakeUpCar)
  {Log 1,"GoE 7 state:[GoE:car_state] wake allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
##
## 8 ## charge
DOELSEIF (([SMA_Energymeter:Saldo_Wirkleistung] > -10000)
and ([?GoE:car_state] == 2))
  {Log 1,"GoE 8 state:[GoE:car_state] chg  allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}
##
## 9 ## wait
DOELSE
  {Log 1,"GoE 9 state:[GoE:car_state] wait allow:[GoE:allow_charging] amp_current:[GoE:amp_current]"}

Aus für mich nicht ersichtlichen Gründen will DOIF aber nicht so wie ich es gerne hätte. Im Block Nr 2 (also Ladestrom senken) wird beharrlich die letzte Bedingung "and ([?GoE:amp_current] > 7)" ignoriert. Auch wenn der Stromwert schon auf 6 steht, wird trotzdem der zweite Block ausgeführt und versucht den Stromwert weiter (auf 5) zu senken.

Irgendwas muss ich da übersehen haben. Wieso ignoriert DOIF diese Bedingung?

Offline LR66

  • Full Member
  • ***
  • Beiträge: 143
Du hast einen Kommentar #bezug mit nur einem # Zeichen, das geht m.W. schon mal schief?!

Offline jw9

  • New Member
  • *
  • Beiträge: 37
Danke! Da versteift man sich auf den Code, und es liegt am Kommentar   ???

Was ist eigentlich der Unterschied zwischen car_state==1 und car_state==3?

Klar, bei 1 ist Kabel nicht angesteckt. Aber was hindert das Auto bei 3 zu laden?

Wenn meine ZOE zwischdurch aufgehört hat zu laden (weil zB dunkle Wolken der PV den Saft abgedreht haben), dann verbleibt sie bei car_status==3 und fängt nicht wieder an zu laden.

Kurioserweise wacht sie wieder auf und fängt wieder an zu laden wenn man eine Tür öffnet. Die fängt also wieder an zu lader, wenn man losfahren will. Das haben sich die Herren Inschenöre richtig clever ausgedacht  :o

Offline Eckat

  • New Member
  • *
  • Beiträge: 40
Das ist der richtige Platz. Der Icon-Cache muss neu geladen werden - da gab es was, wie man das macht, weiß ich grad nicht. Wenn Dir ein Neustart nicht weh tut (gleich mit Update verbinden), sollte das auch klappen.
Danke!
Erstaunlicherweise musste ich relativ viel suchen um die Lösung zu finden.
Für den Fall das noch mal jemand sucht, es gibt in dem Zusammenhang zwei Befehle:
- set <FHEMWEB> clearSvgCache
- set <FHEMWEB> rereadicons
Gefällt mir Gefällt mir x 1 Informativ Informativ x 2 Liste anzeigen

Offline sigma415

  • New Member
  • *
  • Beiträge: 39
Hallo,

Hab heute 2 Stück go-E 11kW fix bekommen und im Keller mal provisorisch einphasig angeschlossen zum Konfigurieren. Das Problem, dass mit der neuen FW ein Reboot nicht mehr klappt habe ich auch. Hab schon ein Ticket offen, hab das hier zu spät gelesen. Die zweite lasse ich dann erst einmal auf der alten FW.
Ich will das Lastmanagement nutzen, da ich nur 1 Zuleitung 5x2,5 mm2 zur Garage habe, dort sollen aber gleich zwei Ladepunkte hin, wenn man die Boxen derzeit wegen KfW Förderung ja quasi für Umme bekommt.
Was mich da noch verwirrt: Beziehen sich die dort einzustellenden Werte für die Lastgruppe auf eine Phase oder auf alle drei ?

 Auto (e Soul) ist bestellt, kommt aber erst im Frühjahr, wahrscheinlich eher wie der Elektriker zum Box anschliessen, der um die Ecke wohnt.

Das Modul habe ich testweise mal angebunden, sieht so weit alles gut aus (bis auf die nicht funktionierende Hilfe). Vielen Dank schon mal an den Autor. Das Vorhandensein einer fhem-Anbindung war für mich ein KO-Kriterium bei der Produktauswahl der Wallbox.

Grüße, gagdet.


@gadget
: Hallo gadget,
hast Du das Lastmanagement für 2 Boxen bereits in FHEM realisiert ?

Ich habe das gleiche Thema (nur 3ph x 16A für 2 Boxen verfügbar) und das Cloud-Lastmanegemnt von goE scheint ja leider immer noch nicht zu funktionieren.

Falls ja: Wäre super, wenn Du deinen Code posten könntest  :)

Vielen Dank
FHEM auf ubuntu-Server, CUNO via LAN, 3x HMLAN, 2x goE

HM-SEC-RHS, LC-Sw1PBU-FM, Dis-WM55, MOD-Em-8, LC-DIM1L-CV, MOD-Re-8, LC-SW1-PL2, LC-SW4-DR, Sen-DB-PCB, ES-PMSw1-Pl, Sen-MDIR-O-2, LC-Bl1PBU-FM, CC-RT-DN, PB-2-WM55, LC-SW1-FM, LC-SW2-FM, PBI-4-FM, LC-Dim1TPBU-FM, LC-Sw1-DR, SEC-SD

Offline gadget

  • Full Member
  • ***
  • Beiträge: 277
Warte immer noch auf Elektriker, denke Ende März kann ich was sagen. Bislang nur ein E-Auto, das je nachdem wo es zum stehen kommt an der einen oder an der anderen Box geladen wird, den Bedarf gleichzeitig an beiden zu laden werde ich voraussichtlich erst nächstes Jahr haben.