Autor Thema: [gelöst] Problem mit configDB und "save"  (Gelesen 170 mal)

Offline JWRu

  • Full Member
  • ***
  • Beiträge: 305
[gelöst] Problem mit configDB und "save"
« am: 21 Mai 2020, 08:55:56 »
Ich mache einmal die Woche ein FHEM Backup und führe nachts u.a. ein "configdb dump ..." durch.
Um sicher zu gehen, dass die Konfiguration auf dem letzten Stand ist, habe ich in dem "at" vorher ein "save" durchgeführt.
Nachdem ich den Eindruck hatte, dass das "save" anscheinend nicht ausgeführt wird, habe ich etwas herumgespielt und folgendes herausgefunden:

Wenn ich den "save" Befehl in ein "at" oder ein "notify" schreibe, wird er nicht ausgeführt und das (berühmt-berüchtigte) rote Fragezeichen oben links bleibt stehen.
Gebe ich "save" in der Kommandozeile ein, wird der Befehl ausgeführt. 
« Letzte Änderung: 21 Mai 2020, 10:01:09 von JWRu »
ZBox; RasPi 3B; RasPi Zero W; Homematic; Z-Wave; EnOcean; DuoFern; Oregon-Sensoren; TFA-Sensoren; Steuerung Viessmann-Heizung; Arduinos für Strom-, Wasser-, Gaszähler, Rauchmelder und FI-Schutzschalter

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22548
Antw:Problem mit configDB und "save"
« Antwort #1 am: 21 Mai 2020, 09:46:51 »
Dieses Verhalten ist Absicht, ausgeloest wird das durch "attr global autosave 0", was wiederum automatisch gesetzt wird, falls beim FHEM-Start Fehler festgestellt wurden. Siehe auch https://forum.fhem.de/index.php/topic,78769 fuer die Entstehungsgeschichte und die Gefahren von automatischen Speicherns.

Offline JWRu

  • Full Member
  • ***
  • Beiträge: 305
Antw:Problem mit configDB und "save"
« Antwort #2 am: 21 Mai 2020, 10:00:42 »
Danke für die schnelle Antwort!
Bei der Verwendung von configDB besteht das Risiko von Datenverlust nicht, da ich ältere Versionen der Konfiguration zurückholen kann.
ZBox; RasPi 3B; RasPi Zero W; Homematic; Z-Wave; EnOcean; DuoFern; Oregon-Sensoren; TFA-Sensoren; Steuerung Viessmann-Heizung; Arduinos für Strom-, Wasser-, Gaszähler, Rauchmelder und FI-Schutzschalter

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22548
Antw:[gelöst] Problem mit configDB und "save"
« Antwort #3 am: 21 Mai 2020, 10:06:11 »
Bei der dateibasierten fhem.cfg ist das aehnlich, da vor dem save eine Kopie in restoreDir angelegt wird.