Autor Thema: [Neues Modul] Miele@Home  (Gelesen 4733 mal)

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6573
Antw:[Neues Modul] Miele@Home
« Antwort #105 am: 10 September 2020, 10:14:59 »
Das Gerät telefoniert nachts nach Hause, und wird deswegen "on" gemeldet?
FHEM 5.9 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus

Offline Florie

  • New Member
  • *
  • Beiträge: 44
Antw:[Neues Modul] Miele@Home
« Antwort #106 am: 17 September 2020, 08:42:21 »
Hi,

ich hatte direkt die 0.13.0 bei mir eingespielt, weiß nicht, ob es daran liegt oder ein anderes Problem ist.

Internals:
   FUUID      XXX
   HAS_MimeBase64 1
   NAME       MieleConnection
   NR         253
   OAUTH2_ACCESS_TOKEN DE_XXX
   OAUTH2_EXPIRES_AT 2020-09-09 08:43:04
   OAUTH2_EXPIRES_IN 2592000
   OAUTH2_REFRESH_TOKEN DE_XXX
   STATE      Initialized
   TOKEN_REFRESH_IN_PROGRESS 1
   TYPE       MieleAtHome
   VERSION    0.13.0
   OLDREADINGS:
   READINGS:
Attributes:
   DbLogExclude .*
   clientId   XXX
   country    Miele-Deutschland
   devStateIcon .*:noIcon
   login      XXX@web.de
   room       System->Server
   verbose    5


Ich bekomme leider seit 09.09. keinen aktuellen Token, im FHEM-Log steht nun das (sorry, der war ziemlich lange, habe jetzt mal "irgendwo" angefangen rauszukopieren:

<body id="mieleLoginSite">
<div class="container">
    <div class="row">
        <div class="col s12 m8 offset-m2 offset-l2 l8 center">
            <div>
                <img class="responsive-img"
                     src="/assets/images/miele_logo.svg" width="150" alt="miele.com"/>
            </div>
            <h1 class="mediumFont">Kontoverknüpfung fehlgeschlagen!</h1>
            <p>Bitte überprüfen Sie ihre Zugangsdaten.</p>
            <button class="btn waves-effect waves-light miele-red"
                    onclick="location.replace(document.referrer)"
            >Zurück</button>
            <p>Nach 5 Sekunden werden Sie automatisch zurück zum Login weitergeleitet.</p>
        </div>
    </div>
</div>
</body>
<script>
    document.ready(
        window.setTimeout(function(){
            location.replace(document.referrer);
        }, 5000)
    );
</script>
</html>

2020.09.17 08:38:06 5: MieleConnection (MieleAtHome::scrapeGrantAccessPage:732) code not found
2020.09.17 08:38:06 2: MieleConnection (MieleAtHome::MAH_onOauthLoginReply:712) Error: Bearer code not found, giving up
2020.09.17 08:38:21 4: MieleConnection (MieleAtHome::MAH_getAccessToken:1511) found local token with remaining lifetime of -690917 seconds
2020.09.17 08:38:21 5: MieleConnection (MieleAtHome::MAH_refreshAccessToken:553) called
2020.09.17 08:38:21 4: MieleConnection (MieleAtHome::MAH_getAccessToken:1511) found local token with remaining lifetime of -690917 seconds
2020.09.17 08:38:21 5: MieleConnection (MieleAtHome::MAH_refreshAccessToken:553) called
2020.09.17 08:38:21 4: MieleConnection (MieleAtHome::MAH_refreshAccessToken:561) token refresh already in progress, skipping
2020.09.17 08:38:21 5: MieleConnection (MieleAtHome::MAH_doThirdpartyLoginRequest:589) called

Auch wenn ich direkt auf https://api.mcs3.miele.com/thirdparty/login/ gehe kommt ohne die Möglichkeit etwas einzugeben direkt "Kontoverknüpfung fehlgeschlagen!". Geht das bei euch?


 

decade-submarginal