Verschiedenes > Bastelecke

Deebot Ozmo 950 [MQTT][CLOUDFREE][CLOUD][bumper][non-bumper]

<< < (26/27) > >>

ZeitlerW:
Hallo zusammen,

ich mußte wieder auf 1.7.1 zurückgehen, dann hat es bei mir funktioniert.
Python 3.5.3 auf Raspbian Stretch


p.s.
@schwatter: Vielen Dank für Deine Arbeit!

vG
Wolfgang

schwatter:
@ZeitlerW

Sehr gerne. Und jetzt auch Dank an dich. Mit 1.7.1 is alles ok.
Jetzt weiß ich auch warum es nicht mehr funktionert. Ich war
auf 1.7.1 und hatte die letzte Prerelease probiert. Da es nicht
funktioniert hat habe ich einfach die letzte stable 1.8.0 installiert
und nur getestet ob der Bot startet.

Gruß schwatter

davipet:
Moin!

Danke Wolfgang. Mit der 1.7.1 hatte ich es noch gar nicht versucht. Damit funktioniert es bei mir auch!

Ich habe das übrigens mal an den Entwickler weiter kommuniziert.

Gruß

David

schwatter:
@KölnSolar

Nabend,
nachdem der Edenhaus, der jetztige MainContributer/MainDev von der DeebotLibrary im Moment alles umkrempelt und den Client eher als optional betrachtet, bzw. keine Lust auf Support hat, dachte ich, ich schau mir nochmal das Problem mit dem Port an.

Der Port wurde beim Bot von 1883 auf 443 geändert. Um das ganze jetzt mit FhemOnly zu realisieren, bekommen wir
eine Port-Konflikt.


--- Code: ---defmod myEcovacsServer MQTT2_SERVER 443 global
attr myEcovacsServer SSL 1
attr myEcovacsServer autocreate simple
attr myEcovacsServer room Saugroboter
attr myEcovacsServer sslVersion TLSv12
--- Ende Code ---


--- Code: ---myEcovacsServer: Can't open server port at 443: Permission denied
--- Ende Code ---

An der Stelle ist das Problem mein ich Fhem selber, da es 443 blockiert? Irgendwo aufgeschnappt. Kann der Port vielleicht freigegeben werden?
Belegte Fhemports von mir sind 8083,8084 und 8085.

Alternative wäre ein anderer Headlessserver ohne irgendeinem Firlefanz in Bezug auf Port 443 (Webinterface,...,...) oder

ein Routing.

--- Code: ---iptables -A PREROUTING -t nat -i wlp0s20f3 -p tcp --dport 443 -j REDIRECT --to-port 8883
--- Ende Code ---

Aber auch da bin ich mir nicht sicher, Konflikt mit Fhem wegen dem blockieten Port?

Gruß schwatter

edit:
Oder einfach

--- Code: ---iptables -t nat -A PREROUTING -p tcp --dport 443 -j REDIRECT --to 8883
--- Ende Code ---

schwatter:
Juhu,
funktioniert, da issa wieder.


--- Code: ---Internals:
   CFGFN     
   CID        bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk
   DEF        bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk
   DEVICETOPIC MQTT2_bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk
   FUUID      616ddb0d-f33f-86cf-676e-918b2d18a445b6eb
   IODev      myEcovacsServer
   LASTInputDev myEcovacsServer
   MSGCNT     2
   NAME       MQTT2_bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk
   NR         487
   STATE      ???
   TYPE       MQTT2_DEVICE
   myEcovacsServer_MSGCNT 2
   myEcovacsServer_TIME 2021-10-18 22:37:33
   READINGS:
     2021-10-18 22:37:33   IODev           myEcovacsServer
     2021-10-18 22:37:33   body_data_code  1065
     2021-10-18 22:37:43   body_data_enable 1
     2021-10-18 22:37:33   body_data_info_1_built 1
     2021-10-18 22:37:33   body_data_info_1_index 2
     2021-10-18 22:37:33   body_data_info_1_mid 2010636970
     2021-10-18 22:37:33   body_data_info_1_name
     2021-10-18 22:37:33   body_data_info_1_status 0
     2021-10-18 22:37:33   body_data_info_1_using 1
     2021-10-18 22:37:33   body_data_info_2_built 0
     2021-10-18 22:37:33   body_data_info_2_index 3
     2021-10-18 22:37:33   body_data_info_2_mid 2010636970
     2021-10-18 22:37:33   body_data_info_2_name
     2021-10-18 22:37:33   body_data_info_2_status 0
     2021-10-18 22:37:33   body_data_info_2_using 1
     2021-10-18 22:37:43   body_data_isCharging 1
     2021-10-18 22:37:33   body_data_isHasMap 1
     2021-10-18 22:37:43   body_data_mode  slot
     2021-10-18 22:37:33   body_data_state idle
     2021-10-18 22:37:33   body_data_trigger none
     2021-10-18 22:37:43   header_fwVer    1.8.2
     2021-10-18 22:37:43   header_hwVer    0.1.1
     2021-10-18 22:37:43   header_pri      1
     2021-10-18 22:37:43   header_ts       1634589461911
     2021-10-18 22:37:43   header_tzm      480
     2021-10-18 22:37:43   header_ver      0.0.1
Attributes:
   readingList bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onRelocationState/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onMapState/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onSched/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onCachedMapInfo/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onEvt/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onCleanInfo/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onSleep/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
bb5d3df7_0ec5_4f38_b930_b6e0ed03b963_yna5xi_iElk:iot/atr/onChargeState/bb5d3df7-0ec5-4f38-b930-b6e0ed03b963/yna5xi/iElk/j:.* { json2nameValue($EVENT) }
   room       MQTT2_DEVICE
--- Ende Code ---

Funktionierte erst, nachdem ich den Bot einmal aus und wieder eingeschaltet hatte.

Gruß schwatter

edit:

Ich habe den Hinweis im ersten Post unter 2.02 hinzugefügt.

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln