Autor Thema: ZWDongle über ser2net  (Gelesen 3090 mal)

m_g_s_g

  • Gast
ZWDongle über ser2net
« am: 20 Februar 2013, 00:17:28 »
Hallo,

   Ich versuche im moment ein ZWDongle (Aeon Labs Z-Stick) über ser2net zu benutzen (unter OpenWrt). Meine Konfiguration ist:

fhem config:
define ZStick ZWDongle 127.0.0.1:27073

ser2net config (Ja, das Ding liegt im ttyUSB0, laut lsusb):
27073:raw:500:/dev/ttyUSB0:115200 NONE 1STOPBIT 8DATABITS -RTSCTS

fhem log:
2013.02.20 00:04:28 3: Opening ZStick device 127.0.0.1:27073
2013.02.20 00:04:28 3: ZStick device opened

Aber danach bekomme ich in der Konsole folgendes, und fhem stoppt:
Use of implicit split to @_ is deprecated at /opt/fhem/FHEM/00_ZWDongle.pm line 236, <$fh> line 80.
Use of implicit split to @_ is deprecated at /opt/fhem/FHEM/00_ZWDongle.pm line 257, <$fh> line 80.
Can't call method "can_dtrdsr" on an undefined value at /opt/fhem/FHEM/DevIo.pm line 251, <$fh> line 80.

Kann so was funktionieren? Was mache ich sonst falsch?

Danke!

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 20894
Aw: ZWDongle über ser2net
« Antwort #1 am: 20 Februar 2013, 09:09:45 »
>  ... ZWDongle ... über ser2net zu benutzen

Warum eigentlich?

Ich habe ZWDongle gegen einem fake tcp port getestet, und andere Probleme gefixed (und eingecheckt), das oben erwaehnte trat bei mir nicht auf.

Da die uebergabeparameter in ZWDongle_Set geprueft worden, vermute ich ein Perl-Versions Problem, oder einen korrupten 00_ZWDongle.pm

Damit ich das Problem naeher lokalisieren kann, brauche ich zusaetzliche debug-ausgaben, z.Bsp. sowas wie
Log 1, join("/", @a);
in der dritten Zeile von ZWDongle_Set.

m_g_s_g

  • Gast
Aw: ZWDongle über ser2net
« Antwort #2 am: 20 Februar 2013, 22:32:35 »
>> Warum eigentlich?

Ich habe das hier gelesen: http://www.fhemwiki.de/wiki/OpenWRT
"Wenn ein CUL-Stock am Router verwendet werden soll, dann geht dies über den Umweg ser2net, da das Device::Serial - CPAN Modul für OpenWRT nicht standardmäßig zur Verfügung steht [...]"

Wenn ich direkt define ZWDongle /dev/ttyUSB0@115200 probiere, dann kriege ich so ein Fehler "Can't locate Device/SerialPort.pm in @INC"

>> Ich habe ZWDongle gegen einem fake tcp port getestet, und andere Probleme gefixed (und eingecheckt), >> das oben erwaehnte trat bei mir nicht auf.

>> Da die uebergabeparameter in ZWDongle_Set geprueft worden, vermute ich ein Perl-Versions Problem,
>> oder einen korrupten 00_ZWDongle.pm

>> Damit ich das Problem naeher lokalisieren kann, brauche ich zusaetzliche debug-ausgaben,
>> z.Bsp. sowas wie
>> Log 1, join("/", @a);
>> in der dritten Zeile von ZWDongle_Set.

Im moment kriege ich nicht einmal ein ZWDongle log.

Aber...

Ich habe sowieso erst heute gesehen (ich sollte mehr im alten Google-Groups Forum suchen!), dass es eine Lösung gibt um das SerialPort module in Perl unter OpenWrt zu verwenden: https://groups.google.com/d/topic/fhem-users/Trlixn94b9M/discussion. Ich habe das erst gleich probiert, und es geht!!

Vielen Dank!


 

decade-submarginal