Autor Thema: [73_AutoShuttersControl.pm] Rolllos automatisiert steuern - Version 0.10  (Gelesen 15556 mal)

Offline Dreggwatz

  • New Member
  • *
  • Beiträge: 33
Kann man folgendes unterbinden: nachdem Ventilate_Pos über den Fensterkontakt gefahren wurde und danach das Fenster wieder geschlossen wird, fährt der Rolladen automatisch in die Open Position. Ich möchte aber das er wieder in die Closed Position fährt oder zumindest in der Ventilate_Pos bleibt.

Offline flummy1978

  • Full Member
  • ***
  • Beiträge: 450
Seit dem Update auf v0.10.5 wird beim Aufruf des ASC-Devices die Übersichtstabelle nicht mehr angezeigt. Ist das nur bei mir so oder kann das jemand bestätigen?

Änderungen am ASC-Device wurde nicht vorgenommen.

Seit wann hast Du nicht mehr upgedatet ? Bestätigen kann ich das so nicht, die Übersicht wird bei mir immernoch genauso angezeigt... 

Ansonsten ggf mal nach Shuttern scannen, notify neu erstellen. Wenn das nicht hilft, ASC Device löschen, neu erstellen und dann die Scans neu ausführen.

Grüße
Andreas

Offline cbl

  • Jr. Member
  • **
  • Beiträge: 94
Kann man folgendes unterbinden: nachdem Ventilate_Pos über den Fensterkontakt gefahren wurde und danach das Fenster wieder geschlossen wird, fährt der Rolladen automatisch in die Open Position. Ich möchte aber das er wieder in die Closed Position fährt oder zumindest in der Ventilate_Pos bleibt.

Es gibt doch zur Auswahl hier derzeit nur "open" und "last manual". Ich habe das derzeit nicht konfiguriert, da mir auch die einzig wichtige "last position" fehlt, wenn der zuvor geschlossene Rolladen zum Lüften auf ventilate fahren soll und danach wieder geschlossen werden soll.


Offline Typ1er

  • Full Member
  • ***
  • Beiträge: 426
Das Verhalten habe ich genau umgekehrt. Nach dem morgendlichen Hochfahren der Jalousie und dann das gekippte Fenster schließen, fährt die Jalousie wieder runter.

Offline eurofinder

  • Full Member
  • ***
  • Beiträge: 303
flummy1978:
Habe jetzt noch ein wenig rumprobiert, warum ich keine Übersicht mehr beim Aufruf von ASC angezeigt bekomme.
Wenn gerade ein Rollladen gefahren wurde, dann erhalte ich die Ansicht. Bei einem erneuten Aufruf von ASC ist die Übersicht nicht mehr da.

Das Verhalten habe ich in allen Browsern.

Gruß
eurofinder
RPI3+; Raspbian Stretch Lite; RPI-RF-MOD; Aeotec Z-Stick Gen5; piVCCU3, HMIP-eTRV-2, HmIP-SWDO, HmIP-SRH, HmIP-STHO, HmIP-SLO

Offline muede

  • New Member
  • *
  • Beiträge: 10
Hallo zusammen,
Seitdem ich auf v0.10.5 passieren komische Sachen.
Aktuell regnet es bei uns bei weniger als 10000lux. Der Markiseauslösewert ist 25000 Lux. Dennoch wurde durch das ASC ein shading in berechnet und die Markise fährt raus.
Wenn die Sonne mit über 40000 Lux scheint, bleibt die Markise hingegen drinnen.
Das ist doch unlogisch. Wer kann mir helfen?

LG,
muede

Offline flummy1978

  • Full Member
  • ***
  • Beiträge: 450
Holla,

Wenn gerade ein Rollladen gefahren wurde, dann erhalte ich die Ansicht. Bei einem erneuten Aufruf von ASC ist die Übersicht nicht mehr da.

Das Verhalten habe ich in allen Browsern.
Das ist in der Tat sehr merkwürdig ... wir sprechen aber schon von der Übersicht, oben im ASC Modul wo darüber steht "ASC Configuration and Information Summary" ?

Standard Style ? Mal die Temporären I-Net dateien gelöscht - dann F5 auf der Seite (sehr unwahrscheinlich, aber möglich) oder anderen Rechner probiert ?

Ansonsten hast Du auch zu den Sachen nichts geschrieben ;)
Seit wann hast Du nicht mehr upgedatet ? Bestätigen kann ich das so nicht, die Übersicht wird bei mir immernoch genauso angezeigt... 

Ansonsten ggf mal nach Shuttern scannen, notify neu erstellen. Wenn das nicht hilft, ASC Device löschen, neu erstellen und dann die Scans neu ausführen.

VG
Andreas

Offline eurofinder

  • Full Member
  • ***
  • Beiträge: 303
So,

die Übersicht "ASC Configuration and Information Summary" ist wieder da. Ich habe zwar immer noch keine Ahnung, woran es lag, dass nach einem Update auf ASC v0.10.5 diese nur noch sporadisch nach einer Rollladenfahrt angezeigt wurde, aber nachdem ich die fhem.cfg von vor dem Update wieder eingespielt habe, ist sie wieder vorhanden.

Shuttern scannen, notify neu erstellen, ASC Device löschen, neu erstellen und dann Scans neu ausführen hat alles nichts geholfen.

Ich hoffe das bleibt jetzt auch so:-)

Nachtrag:
Ich glaube ich habe die Ursache gefunden. Ich habe ein structure bestehend aus 3 Rollläden definiert, die in ASC integriert sind. Sobald ich diese structure anlege, verschwindet die Übersichtsanzeige. Kann man kein structure mit "ASC-Rollläden" anlegen?

Gruß
eurofinder
« Letzte Änderung: 01 August 2020, 23:50:59 von eurofinder »
RPI3+; Raspbian Stretch Lite; RPI-RF-MOD; Aeotec Z-Stick Gen5; piVCCU3, HMIP-eTRV-2, HmIP-SWDO, HmIP-SRH, HmIP-STHO, HmIP-SLO

Offline edition

  • Full Member
  • ***
  • Beiträge: 148
Guten Tag zusammen

Ich versuche jetzt seit 3 Tagen meine Rollläden mit diesem Modul zu steuern. Zustande gebracht habe ich lediglich die automatische Beschattung für das Büro und das Schlafzimmer! Öffnen am Morgen und schließen am Abend funktioniert nicht, Comfortöffnen funktioniert ebenfalls nicht. Das ASC Modul ist auf on, ebenso in den Rollläden. Die Zeiten für öffnen und schließen sind im Rollladen eingetragen, kein Partymodus, kein Hardlock, kein Holyday, kein Blocking. Wiggle funktioniert bei allen Rollläden. Trotzdem fährt hier morgens und abends nichts! Hier das Summary von heute Morgen vor dem öffnen:

Um 8:00 Uhr sollten die Rollläden öffnen. Passiert ist nichts, ausser das neue Timer erstellt wurden. Keine Fehlermeldung, etc.

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'Rolladen_Bad_nextAstroTimeEvent:  2.08.2020 - 21:37'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'state: created new drive timer'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'Rolladen_Buero_nextAstroTimeEvent:  2.08.2020 - 21:37'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'state: created new drive timer'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'Rolladen_Gaestezimmer_nextAstroTimeEvent:  2.08.2020 - 21:37'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'state: created new drive timer'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'Rolladen_Schlafzimmer_nextAstroTimeEvent:  2.08.2020 - 21:37'
        ];

2020.08.02 08:00:01 4: AutoShuttersControl (Rollladenautomatik) - Devname: Rollladenautomatik Name: Rollladenautomatik Notify: $VAR1 = [
          'state: created new drive timer'

Wo suche ich denn nun nach dem Fehler?

edition

Offline Migul47

  • New Member
  • *
  • Beiträge: 37
Hallo cbl,
Danke für deine Antwort. Bei mir hat das auch Monate mit den Wochenenden und dem Urlaub sauber funktioniert. Seit ca. zwei Wochen nun an den Wochenenden nur die Werkstagsregelung. Auch der in der Holiday Datei eingestellte Urlaub wird nicht beachtet. Sehr komisch.
Um holidaydevice habe ich nichts verändert.

LG, muede
Hallo,

hat bei mir bis Gestern auch funktioniert. Hab heute früh, nach dem Ergebnislosem Versuch mit ASC_shuttersDriveDelay etwas Zufall in meine Zeiten zu bringen alle Timer neu erstellen lassen. Dabei hate er nicht die Zeit vom WE sonden Werktags genommen. Ein IsWe liefert 1.

Offline crusader85

  • New Member
  • *
  • Beiträge: 33
Das Verhalten habe ich genau umgekehrt. Nach dem morgendlichen Hochfahren der Jalousie und dann das gekippte Fenster schließen, fährt die Jalousie wieder runter.

Ist bei mir auch so.

Offline brucky@freenet.de

  • New Member
  • *
  • Beiträge: 8
Hallo Zusammen,

seit einiger Zeit geht meine Automation nicht mehr. ich habe mir jetzt die Sache mal genauer angeschaut:

FHEM:configfile: Cannot load module AutoShuttersControl

Scheinbar fehlen alle Dateien unter lib/FHEM/Automation/…

habt Ihr eine Idee, wie ich die installiert bekommen?

Danke,
Simon

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6276
Hallo Zusammen,

seit einiger Zeit geht meine Automation nicht mehr. ich habe mir jetzt die Sache mal genauer angeschaut:

FHEM:configfile: Cannot load module AutoShuttersControl

Scheinbar fehlen alle Dateien unter lib/FHEM/Automation/…

habt Ihr eine Idee, wie ich die installiert bekommen?

Danke,
Simon

Fhem "update" ? Wenn es nicht reicht, dann "update force"?
FHEM 5.9 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus

Offline flummy1978

  • Full Member
  • ***
  • Beiträge: 450
Guten Abend alleine, edition

Bitte unbedingt das beachten: Unbedingt vor dem ersten Post lesen

Ich versuche jetzt seit 3 Tagen meine Rollläden mit diesem Modul zu steuern. Zustande gebracht habe ich lediglich die automatische Beschattung für das Büro und das Schlafzimmer! Öffnen am Morgen und schließen am Abend funktioniert nicht, Comfortöffnen funktioniert ebenfalls nicht. Das ASC Modul ist auf on, ebenso in den Rollläden. Die Zeiten für öffnen und schließen sind im Rollladen eingetragen, kein Partymodus, kein Hardlock, kein Holyday, kein Blocking. Wiggle funktioniert bei allen Rollläden. Trotzdem fährt hier morgens und abends nichts! Hier das Summary von heute Morgen vor dem öffnen:

Um 8:00 Uhr sollten die Rollläden öffnen. Passiert ist nichts, ausser das neue Timer erstellt wurden. Keine Fehlermeldung, etc.


Wo suche ich denn nun nach dem Fehler?


die Glaskugel sagt ..... Keine unterschiedlichen Positionen, die Zeiten passen nicht zu den Einstellungen (ASC_AutoModeUp/Down - ASC_Down/Up usw oder kein localisation Device beim Versuch über Sonnenstand zu fahren )  und und und und mist nu is die Glaskugel kapputt  ;)
Sprich man muss schon wissen, was Du alles gemacht hast Wiki & Commandref studiert ? Komisch dass die Beschattung angeblich funktioniert und der Rest quasi gar nicht - Sicher dass die Beschattung vom ASC kommt ? (oder noch alte leichen aus anderen Modulen / Selbstbauten ? )
Bitte lists jeweils vom ASC Modul und den Rollos oder zumindest einem. Wenn eines fährt, werden die anderen sicherlich auch schnell zum laufen gebracht.

Auch wenn ich selbst sicherlich noch kein Profi bin, alles zu finden woran es liegt... möchte ich helfen und versuche es auch. Aber ohne Infos ist das Ganze dann doch sehr schwierig.... und nur mal ein Tipp von mir (weil das Modul so mächtig ist, dass man sich selbst schnell ein Beinchen stellt:
Zitat
Rollladen eingetragen, kein Partymodus, kein Hardlock, kein Holyday, kein Blocking. Wiggle funktioniert bei allen Rollläden
Speziell als Anfänger (aber eigentlich gar)NICHT alles auf einmal probieren zu aktivieren. Imho wäre mein Vorschlag Block / Lock etc erst mal außenvor zu lassen. Dann Zeiten / Beschattung etc einstellen und dann erst Funktion für Funktion in Betrieb nehmen

Viele Grüße
Andreas

Offline ms_steini

  • Full Member
  • ***
  • Beiträge: 239
Guten Morgen zusammen,
alle Rollos sind soweit eingerichtet,
ASC 2
ASC_BrightnessSensor Brightness_Sensor
ASC_Down brightness
ASC_Mode_Down always
ASC_Mode_Up always
ASC_Pos_Reading pct
ASC_Time_Down_Early 20:00
ASC_Time_Down_Late 23:00
ASC_Time_Up_Early 06:00
ASC_Time_Up_Late 09:15
ASC_Time_Up_WE_Holiday 09:00
ASC_Up brightness

jetzt möchte ich gerne das die 2 Kinderzimmer-Rollos in den Schulferien auch erst um 09:00 Uhr hochfahren.
Ich habe dazu ohne ASC immer eine "ical url http://xxxxx.xxxxx.com/export/Schulferien_2020.ics" benutzt und dazu folgendes DoIf
..........
DOELSEIF
([[DUMMY_Rollo.Gruppe_4:auf_WE]]
and [[DUMMY_Rollo.Gruppe_4:auf_WE]|WE]
or [[DUMMY_Rollo.Gruppe_4:auf_WE]]and [NRW_Schulferien:Ferientag] eq "Ja")
(set [DUMMY_Rollo.Gruppe_4:Rollos] auf)
.........

Wie stelle ich die 2 Kinderzimmer-Rollos in ASC ein, damit die in den Schulferien erst um 09:00 Uhr hochfahren?

Das gleiche gilt auch für die 2 Schlafzimmer-Rollos, die erst um 14:00 Uhr hochfahren sollen wenn ich Nachtdienst hatte.
Dienstplan ebenfalls als "ical url http://xxxxx.xxxxx.com/Schichtplan.ics 10800" vorhanden.

Besten Dank

 

decade-submarginal