Autor Thema: Issue with multiple TCMs  (Gelesen 1506 mal)

Offline tomaszG

  • New Member
  • *
  • Beiträge: 32
Issue with multiple TCMs
« am: 18 August 2020, 14:42:19 »
Dear all,

I am trying to use several TCMs on a single RPi and it is not working for me.
I connected to TCM 310 on a RPi3 with FHEM and create the devices with usb create command. Until there it looks fine, both TCM are initialized after a reboot
I can pair  no problem on the first TCM TCM_ESP3_0 some devices (EEP A5-20-04 Manufacturer: Holter Regelarmaturen GmbH) and it is working fine. But on the second TCM TCM_ESP3_1, it fails with the following log messages

2020.08.18 14:32:30 3: TCM TCM_ESP3_1 set teach 60
2020.08.18 14:32:36 1: EnOcean Unknown device with SenderID 019A9B25 and SMLRNREQ telegram, please define it.
2020.08.18 14:32:36 2: autocreate: define EnO_019A9B25 EnOcean 019A9B25 EnOcean:1:C6:F845A520040000000000:019A9B25:0F:03FFFFFFFF3400
2020.08.18 14:32:36 2: EnOcean define EnO_019A9B25 EnOcean 019A9B25 EnOcean:1:C6:F845A520040000000000:019A9B25:0F:03FFFFFFFF3400
2020.08.18 14:32:36 2: EnOcean define FileLog_EnO_019A9B25 FileLog ./log/EnO_019A9B25-%Y.log EnO_019A9B25
2020.08.18 14:32:36 1: MKDIR restoreDir/save/2020-08-18
2020.08.18 14:32:36 1: opendir ./restoreDir/save: No such file or directory
2020.08.18 14:33:22 3: TCM TCM_ESP3_1 set teach 60
2020.08.18 14:33:28 1: EnOcean Unknown device with SenderID 0193E4E3 and SMLRNREQ telegram, please define it.
2020.08.18 14:33:28 2: autocreate: define EnO_0193E4E3 EnOcean 0193E4E3 EnOcean:1:C6:F845A520040000000000:0193E4E3:0F:03FFFFFFFF3100
2020.08.18 14:33:28 2: EnOcean define EnO_0193E4E3 EnOcean 0193E4E3 EnOcean:1:C6:F845A520040000000000:0193E4E3:0F:03FFFFFFFF3100
2020.08.18 14:33:28 2: EnOcean define FileLog_EnO_0193E4E3 FileLog ./log/EnO_0193E4E3-%Y.log EnO_0193E4E3

It is not recognizing the kind of device apparently. The same device I try to pair on 2nd TCM can be paired on 1st TCM so the problem is not the device but the TCM.

Any ideas what to do to debug / solve the issue ? Any known problems with multiple TCMs ?

Offline tomaszG

  • New Member
  • *
  • Beiträge: 32
Antw:Issue with multiple TCMs
« Antwort #1 am: 24 August 2020, 17:38:03 »
I am still looking for hints on this. Please point me to anything useful.

Offline krikan

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7028
Antw:Issue with multiple TCMs
« Antwort #2 am: 24 August 2020, 19:24:03 »
I believe that there is no simple solution. As far as I know, enocean is not designed for multi-transmitter operation.
Some hints can be found in the (german) thread: https://forum.fhem.de/index.php/topic,35118.0.html

Offline tomaszG

  • New Member
  • *
  • Beiträge: 32
Antw:Issue with multiple TCMs
« Antwort #3 am: 25 August 2020, 15:37:25 »
Hi,

Thanks for the input. I think this points me in the right direction, but it indeed seems problematic.
I will recap because I am not certain I got exactly all the details of the discussion between klaus.shauer and Schmitzkatze.
What I understand is there seems to be a problem in having several TCMs on the same RPi due to confusion in identifying which transmitter should be used to receive and/or send messages.
For incoming messages, this was partly solved thanks to the fingerprint feature from thread https://forum.fhem.de/index.php/topic,75291.0.html
But for bidirectional devices (like mine), there is a more important problem.
I did not really get if some extra manual configuration could help solving this though.

 

decade-submarginal