Autor Thema: Zwave - Error, nonce reveived but no stored command for encryption found  (Gelesen 161 mal)

Offline th0nix

  • New Member
  • *
  • Beiträge: 9
Hi zusammen,

ich hatte nun zwei mal das Problem das die Kommunikation über verschlüsseltes ZWave bei mehreren Geräte nach einem FHEM Neustart nicht mehr ging.
Ich denke das könnte die Ursache sein:
Error, nonce reveived but no stored command for encryption foundDurch eine exclusion und neu inclusion ging das dann wieder.

Das kann ja aber nicht die Lösung sein.....
Device ist ein raspberry mit zberry1 Modul.

Hat jemand eine Idee wie ich das ohne neue ex-/inclusion wieder hinbekommen - bzw wie ich das zukünfig verhindern kann?
Im Anfänger Forum gab es hierzu leider keinen Hinweis (https://forum.fhem.de/index.php/topic,114125.0.html), daher versuche ich es hier noch einmal

die Logs. Hier war noch alles OK.
2020.09.08 15:10:48 1: Including fhem.cfg
2020.09.08 15:10:48 3: WEB: port 8083 opened
2020.09.08 15:10:48 2: eventTypes: loaded 165 events from ./log/eventTypes.txt
2020.09.08 15:10:48 3: WEBapi: port 8084 opened
2020.09.08 15:10:48 3: Opening ZWAVE1 device /dev/serial0
2020.09.08 15:10:48 3: Setting ZWAVE1 serial parameters to 115200,8,N,1
2020.09.08 15:10:50 3: ZWAVE1 device opened
2020.09.08 15:10:50 1: Including ./log/fhem.save
2020.09.08 15:10:50 0: Featurelevel: 6
2020.09.08 15:10:50 0: Server started with 38 defined entities (fhem.pl:21056/2020-01-26 perl:5.028001 os:linux user:fhem pid:25542)
2020.09.08 15:10:50 3: ZWave got config for eurotronic/eur_spiritz.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
2020.09.08 15:10:50 2: AttrTemplates: got 127 entries
2020.09.08 15:10:55 3: ZWave set Wohnen.Fenster.HZ.TS desired-temp 10
2020.09.08 15:10:55 3: ZWave set Wohnen.Sofa.HZ.TS desired-temp 10
2020.09.08 15:10:55 3: ZWave set Bad.HZ.TS desired-temp 21
2020.09.08 15:11:02 3: Wohnen.Fenster.HZ.TS: secStart older than 6 seconds detected, secUnlock will call Zwave_secEnd
2020.09.08 15:13:10 3: ZWave set Wohnen.Fenster.HZ.TS desired-temp 10
2020.09.08 15:13:42 3: ZWave set Wohnen.Sofa.HZ.TS desired-temp 10
2020.09.08 15:17:47 0: Server shutdown
Dann habe ich neu gestartet um Parameter zu testen
2020.09.08 15:17:48 1: Including fhem.cfg
2020.09.08 15:17:48 3: WEB: port 8083 opened
2020.09.08 15:17:48 2: eventTypes: loaded 174 events from ./log/eventTypes.txt
2020.09.08 15:17:48 3: WEBapi: port 8084 opened
2020.09.08 15:17:48 3: Opening ZWAVE1 device /dev/serial0
2020.09.08 15:17:48 3: Setting ZWAVE1 serial parameters to 115200,8,N,1
2020.09.08 15:17:49 3: ZWAVE1 device opened
2020.09.08 15:17:49 1: Including ./log/fhem.save
2020.09.08 15:17:49 0: Featurelevel: 6
2020.09.08 15:17:49 0: Server started with 41 defined entities (fhem.pl:21056/2020-01-26 perl:5.028001 os:linux user:fhem pid:26008)
2020.09.08 15:17:50 3: ZWave got config for eurotronic/eur_spiritz.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
2020.09.08 15:17:50 2: AttrTemplates: got 127 entries
2020.09.08 15:17:55 3: ZWave set Wohnen.Sofa.HZ.TS desired-temp 10
2020.09.08 15:17:55 3: ZWave set Wohnen.Fenster.HZ.TS desired-temp 10
2020.09.08 15:17:55 3: ZWave set Bad.HZ.TS desired-temp 10
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: no stored commands in Internal secMsg found
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: Error, nonce reveived but no stored command for encryption found
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: no stored commands in Internal secMsg found
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: Error, nonce reveived but no stored command for encryption found
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: no stored commands in Internal secMsg found
2020.09.08 15:17:58 1: Wohnen.Sofa.HZ.TS: Error, nonce reveived but no stored command for encryption found
2020.09.08 15:18:00 2: ZWave: No ACK from Wohnen.Fenster.HZ.TS after 5s for sentset:13170298402506
2020.09.08 15:18:00 1: Wohnen.Fenster.HZ.TS: NO_ACK received during secured command: 430101220064 set Wohnen.Fenster.HZ.TS desired-temp 10, command will be removed from security stack
2020.09.08 15:18:00 2: ZWave: No ACK from Bad.HZ.TS after 5s for sentset:13150298402508
2020.09.08 15:18:00 1: Bad.HZ.TS: NO_ACK received during secured command: 430101220064 set Bad.HZ.TS desired-temp 10, command will be removed from security stack
2020.09.08 15:18:00 2: ERROR: cannot SEND_DATA to Wohnen.Sofa.HZ.TS: transmit queue overflow
2020.09.08 15:18:02 2: ERROR: cannot SEND_DATA to Wohnen.Sofa.HZ.TS: transmit queue overflow
2020.09.08 15:18:32 0: Server shutdown
Nachdem dann die Fehler kamen habe ich nochmal neu gestartet ....
2020.09.08 15:18:32 1: Including fhem.cfg
2020.09.08 15:18:32 3: WEB: port 8083 opened
2020.09.08 15:18:32 2: eventTypes: loaded 176 events from ./log/eventTypes.txt
2020.09.08 15:18:32 3: WEBapi: port 8084 opened
2020.09.08 15:18:32 3: Opening ZWAVE1 device /dev/serial0
2020.09.08 15:18:32 3: Setting ZWAVE1 serial parameters to 115200,8,N,1
2020.09.08 15:18:33 3: ZWAVE1 device opened
2020.09.08 15:18:34 1: Including ./log/fhem.save
2020.09.08 15:18:34 0: Featurelevel: 6
2020.09.08 15:18:34 0: Server started with 41 defined entities (fhem.pl:21056/2020-01-26 perl:5.028001 os:linux user:fhem pid:26090)
2020.09.08 15:18:34 3: ZWave got config for eurotronic/eur_spiritz.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
2020.09.08 15:18:34 2: AttrTemplates: got 127 entries
2020.09.08 15:18:39 3: ZWave set Wohnen.Fenster.HZ.TS desired-temp 10
2020.09.08 15:18:39 3: ZWave set Wohnen.Sofa.HZ.TS desired-temp 10
2020.09.08 15:18:39 3: ZWave set Bad.HZ.TS desired-temp 10
2020.09.08 15:18:43 2: ZWAVE1 transmit NO_ACK for CB 06, target Wohnen.Sofa.HZ.TS
2020.09.08 15:18:44 2: ZWave: No ACK from Wohnen.Fenster.HZ.TS after 5s for sentset:13170298402504
2020.09.08 15:18:44 1: Wohnen.Fenster.HZ.TS: NO_ACK received during secured command: 430101220064 set Wohnen.Fenster.HZ.TS desired-temp 10, command will be removed from security stack
2020.09.08 15:18:44 2: ZWave: No ACK from Wohnen.Sofa.HZ.TS after 5s for sentset:13160298402506
2020.09.08 15:18:44 1: Wohnen.Sofa.HZ.TS: NO_ACK received during secured command: 430101220064 set Wohnen.Sofa.HZ.TS desired-temp 10, command will be removed from security stack
2020.09.08 15:18:44 2: ZWave: No ACK from Bad.HZ.TS after 5s for sentset:13150298402508
2020.09.08 15:18:44 1: Bad.HZ.TS: NO_ACK received during secured command: 430101220064 set Bad.HZ.TS desired-temp 10, command will be removed from security stack
2020.09.08 15:18:46 1: Bad.HZ.TS: no stored commands in Internal secMsg found
2020.09.08 15:18:46 1: Bad.HZ.TS: Error, nonce reveived but no stored command for encryption found
2020.09.08 15:18:47 1: Wohnen.Sofa.HZ.TS: no stored commands in Internal secMsg found
2020.09.08 15:18:47 1: Wohnen.Sofa.HZ.TS: Error, nonce reveived but no stored command for encryption found

Vielen Dank schon mal !

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22810
Um des Problem zu verfolgen brauche ich ein "attr ZWDongle verbose 5" FHEM-Log-Auszug im Problemfall, noch besser mit _zusaetzlich_ aktivierten "attr global verbose 5".
Leider bin ich nicht der "ZWave-Security-Experte", deswegen koennte sich die Fehlersuche hinziehen...

Offline th0nix

  • New Member
  • *
  • Beiträge: 9
@rudolfkoenig vielen Dank. Jedoch hat sich der Fehler nach setzten des verbose Levels und Neustart erst einmal aufgelöst.
Wenn es nochmal auftritt, werde ich die Daten zur Verfügung stellen.

 

decade-submarginal