FHEM - Hardware > Einplatinencomputer

Alle 90 Sekunden Server shutdown und Server startet [gelöst]

(1/2) > >>

Marlon:
Heute habe ich im LOG festgestellt, dass mein FHEM-Server auf Raspberry 4B seit 5 Tagen alle 90 Sekunden einen Server shutdown und einen Neustart ausführt.
Alle 90 Sekunden wird dann folgendes ins LOG geschrieben:

--- Zitat ---2020.09.23 16:30:45 0: Server started with 19 defined entities (fhem.pl:22726/2020-09-03 perl:5.028001 os:linux user:fhem pid:28134)
2020.09.23 16:32:15 0: Server shutdown
2020.09.23 16:32:15 1: Including fhem.cfg
2020.09.23 16:32:15 3: WEB: port 8083 opened
2020.09.23 16:32:16 2: eventTypes: loaded 37 events from ./log/eventTypes.txt
2020.09.23 16:32:16 3: Opening myCUL device /dev/ttyACM0
2020.09.23 16:32:16 3: Setting myCUL serial parameters to 9600,8,N,1
2020.09.23 16:32:16 3: myCUL: Possible commands: ABbCeFGhiKkLlMmNRTtUuVWXxYZ
2020.09.23 16:32:16 3: myCUL device opened
2020.09.23 16:32:16 2: Switched myCUL rfmode to WMBus_T
2020.09.23 16:32:16 3: WMBUS_SEN_21133475_104_7: I/O device is myCUL
2020.09.23 16:32:16 1: Including ./log/fhem.save
2020.09.23 16:32:16 0: Featurelevel: 6
2020.09.23 16:32:16 0: Server started with 19 defined entities (fhem.pl:22726/2020-09-03 perl:5.028001 os:linux user:fhem pid:28136)
2020.09.23 16:33:45 0: Server shutdown
--- Ende Zitat ---
Dies würde ich gerne abstellen und wäre für jeden Tipp dankbar, wie ich dies erreichen kann.
Das Problem tauchte auf, als ich die fhem.cfg-Datei vom PC auf den Raspi kopiert habe.
Angepasst habe ich darin nur die Parameter der seriellen Schnittstelle für den CUL.

Marlon:
Die Ursache des Problems habe ich nun selbst gefunden:
Wenn man die fhem.cfg vom PC kopiert gibt es mehrere Unterschiede gegenüber der auf Raspi kreierten Originaldatei.
Auf dem PC wird in der fhem.cfg z.B. "attr global nofork 1" definiert, was beim Raspi entfällt.
Wenn man das löscht, verschwinden die Server shutdowns alle 90 Sekunden.

Wenn man fhem vom PC auf Raspi umzieht, kann man die fhem.cfg also prinzipiell kopieren.
Zusätzlich sind dann aber folgende Änderungen sinnvoll:
1. Entfernen von attr global nofork 1
2. Ausführen des Patches "define initialUsbCheck notify global:INITIALIZED usb create", "attr initialUsbCheck disable 1"
3. Ggf. ändern der seriellen Schnittstelle des CUL (z.B. zu "define myCUL CUL /dev/ttyACM0@9600 0000")

Aufgefallen ist mir noch, dass ohne "attr global nofork 1" auch die nervigen "connection lost, trying a reconnect every 5 seconds" Meldungen entfallen.

Wernieman:

--- Code: ---define initialUsbCheck notify global:INITIALIZED usb create", "attr initialUsbCheck disable 1"
--- Ende Code ---
Dabei wird bei jedem Start von FHEM das initialUsbCheck disabled. Darf eigentlich nicht nötig sein. Also einmal setzen und speichern. Wenn das nicht funktioniert, nach Fehlerursache suchen.

Es gibt übrigens noch ein "Problem" zwischen Windows/Pi. Windos-Editoren setzen (meistens) andere Zeichenenden als Unix. Also besser ... nicht so machen!

guhu:
.. Du meinst sicher Zeilenenden. Das ist aber nicht so schlimm, bspw. wird beim Übertragen mit ftp im ASCII-Modus das automatisch gewandelt. Alternativ ein Programm wie dos2unix nutzen.

Marlon:
Die unterschiedlichen Zeilenenden sind ja eher eine Sache der Betriebssysteme als von fhem.
Es ist dennoch richtig sie vollständigkeitshalber an dieser Stelle zu erwähnen.
Das fhem-Verzeichnis des Raspi habe ich mit Samba bereitgestellt, so dass ich es unter Windows als normales Netzlaufwerk sehe.
Dann habe ich die fhem.cfg von Windows mit notepad++ geöffnet, im Bearbeiten-Menü die Zeilenenden auf Unix (LF) umgestellt und im fhem-Verzeichnis des Raspi gespeichert.
Ebenso bin ich mit der Zähler-log-Datei verfahren.
Schließlich habe ich noch den Owner der Dateien mit chown fhem:dialout <Dateiname> und deren Rechte mit chmod 777 <Dateiname> geändert.

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln