Autor Thema: Probleme nachdem der Cube alle Geräte verloren hat  (Gelesen 2320 mal)

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 404
Probleme nachdem der Cube alle Geräte verloren hat
« am: 24 Oktober 2020, 12:32:01 »
Hallo liebe Community,

auch mich hat es wohl mal erwischt und als die Heizperiode wieder los ging, hatte ich das Pech, dass mein Cube alle Geräte verloren hat...
6 x Max Thermostate
8 x Fensterkontakt
5 x Wandthermostat

Ich habe die Geräte in FHEM unberührt gelassen und einfach über die Max Software anschließend wieder neu hinzugefügt, indem ich die Anlerntaste für 3 Sekunden gedrückt habe und in der Software auf Gerät hinzufügen bin.

Scheinbar war das aber nicht die richtige Vorgehensweise, die MAX Geräte wieder einzubinden, oder?
Denn ich habe jetzt z.B.: folgende Probleme habe:

1. Im Bad will das Wandthermostat ums verrecken nicht im Auto Modus bleiben. Irgendwas sorgt dafür, dass er irgendwann auf den Modus manuell springt. Habe über weekprofile also nach dem erneuten Hinzufügen das Wochenprofil über FHEM geladen und am Wandthermostat auf Auto gesetzt. aber da bleibt er nicht.
Wenn ich z.B.: in FHEM von manuell auf auto setze, springt er nach ein paar Sekunden wieder auf manuell zurück. Auch die Option keepAuto = 1 bringt da nichts.

2. Wenn ich die Heizung über Alexa und alexa-fhem steuer und sage z.B.: im Büro "Alexa, schalte die Heizung im Büro ein", schaltet er mir auch die Heizung im Wohnzimmer ein. Gleiches beim Ausschalten. Völlig strange.

Gibt es eine Anleitung, wie man bereits bestehende Gerät in FHEM nach einem "Vergessen" des Cubes wieder zum alten Zustand zurückbringt?

Gruß
sTaN
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4570
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #1 am: 24 Oktober 2020, 13:35:20 »
Einfach FHEM zuerst links liegen lassen und alles über das Webinterface des Cube machen.
Der sorgt dann auch durch deine Raumaufteilung dafür das die Geräte die richtige groupid bekommen und alle  Peerings stimmen und ausgeführt sind. Wenn alles im Cube wieder beisammen ist kannst du anfangen mit FHEM  die Wochenprogramme Stück für Stück wieder herstellen.
IMHO war dein Weg über FHEM den Cube wieder schlau zu machen keine gute Idee.
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 404
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #2 am: 27 November 2020, 14:29:07 »
Einfach FHEM zuerst links liegen lassen und alles über das Webinterface des Cube machen.

Hallo Wut,

danke für deine Rückmeldung, die mir leider durch die Lappen gegangen ist!
Genau was du beschreibst, habe ich ja durchgeführt bzw. ebenfalls so beschrieben:

Zitat
Ich habe die Geräte in FHEM unberührt gelassen und einfach über die Max Software anschließend wieder neu hinzugefügt, indem ich die Anlerntaste für 3 Sekunden gedrückt habe und in der Software auf Gerät hinzufügen bin.

Hätte ich die ganzen MAX devices inkl. Cube device in FHEM vorher löschen müssen?
Könnte ich das Settings noch mal recht simpel zurücksetzen ohne gleich alles zu verlieren?

Also einfach noch mal über die MAX Software alles löschen und über die Taste 3 Sekunden gedrückt erneut anlernen?

Was ich momentan zum Beispiel einfach nicht verstehe ist, dass mein Thermostat im Schlafzimmer angeht, sobald das Wandthermostat im Badezimmer das Auto Programm startet, obwohl Wandthermostat und Heizthermostat im Badezimmer laut FHEM die GroupID 5 haben und Schlafzimmer die GroupID 4. Auch in der Max Software ist alles schön dem entsprechenden Raum zugeordnet.

Die Teile machen mich aktuell echt wahnsinnig  :o

EDIT: und wenn ich Alexa sage, schalte die Heizung im Wohnzimmer an, geht die Heizung in der ganzen Wohnung an...Also auch Alexa-Fhem kommt hier scheinbar nicht mehr klar damit...
« Letzte Änderung: 27 November 2020, 14:47:05 von sTaN »
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4570
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #3 am: 27 November 2020, 16:20:14 »
Hätte ich die ganzen MAX devices inkl. Cube device in FHEM vorher löschen müssen?
nein, das macht keinen Sinn. Bei der Anfrage des CUBE liefert der eh alles was er hat & kennt, FHEM sortiert nur ein.
Da du die Geräte vorher nicht zurückgesetzt hast sondern direkt wieder mit dem Cube gepairt hast stimmen nun offensichtlich bestimmte Zuordnungen nicht mehr. Um das im Detail wieder aufzudröseln müsste man zusätzlich einen CUL ins Spiel bringen der den kompletten Telegrammverkehr zwischen Device und Cube mitschneidet und dann das Ganze von Hand anlaysieren.
In der Theorie hast du vllt. die Räume nicht in der Reihenfolge definiert wie zuvor. D.h. selbst wenn ein Raum heute den Namen Bad wie früher hat kann sich doch eine andere Group ID dahinter verstecken als damals. Ich befürchte um da wieder Ordung rein zu bringen bleibt dir nur der ganz harte Weg:
a. alle Geräte in der MAX Software entfernen
b. Werksrest der Geräte
c. Raum für Raum die Geräte neu anlegen bzw pairen. Und das würde ich wirklich langsam Raum für Raum machen und jedesmal gründlich testen ob die Kommunikation für diesen Raum zu 100% passt und kein anderer da plötzlich mitmischt.
 
Ich habe dieses elende Spiel damals genau zweimal mitgemacht und mir danach für ein paar Euro einen CUL gekauft. Der Wechsel ist einfach und mit den aktuellen Infos und Modulen in ein paar Minuten erledigt. Ganz Mutige flashen sofort den Cube neu, aber wenn dabei etwas schief geht hat man ersteinmal garnichts mehr.
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 404
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #4 am: 29 Dezember 2020, 11:19:17 »
Hallo Wzut,

ich war diesem Thread noch eine finale Antwort schuldig und ja, nachdem ich alle Geräte in der MAX Software erneut gelöscht und neu angelernt hatte (ohne Werksreset), könnte ich die Geräte nach und nach erneut anlernen und es lief wieder soweit. Nun habe ich, wie du, das zweite mal die Amnesie des Cube erleben müssen und bin nach Weihnachten echt frustriert.

Habe hierzu allerdings einen neuen Thread gestartet:
https://forum.fhem.de/index.php/topic,117155.msg1115236.html#msg1115236

Du meintest ein Umstieg auf einen CUL is in wenigen Minuten gemacht. Gibt es hierzu ein Set by Step HowTo für Dummys, diesen Umzug zu vollziehen? Dann würde ich mich über einen Post in dem anderen Thread freuen.

Ebenfalls über die Empfehlung eines neuen CUL. (sicher diesen hier http://shop.busware.de/product_info.php/cPath/1_35/products_id/29

Eventuell könnte ich dann gleich meinen aktuellen CUL mit kleiner Lambda micro Antenne gegen einen neuen mit größerer Antenne für bessere Reichweite tauschen?!
Ich hoffe ich bekomme das bis 04.01. alles hin, da mein Urlaub dann endet und die Zeit wieder knapp wird.  :(

Gruß
sTaN
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4570
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #5 am: 29 Dezember 2020, 19:10:28 »
Eventuell könnte ich dann gleich meinen aktuellen CUL mit kleiner Lambda micro Antenne gegen einen neuen mit größerer Antenne für bessere Reichweite tauschen?!
Ich habe mit diesen externen Antennen keine Erfahrung mein CUL hat den 8cm Draht Mäuseschwanz genau wie der Cube unter seiner Abdeckung.
Ich würd keine allzugroße Hoffnung in eine externe Antenne setzen, eher mal hinterfragen wie der Draht heute ausgerichtet ist ( senkrecht/waagerecht/geneigt  | - / )
Mein klarer Favorit genau wie bei Homematic : Multi IO !
D.h. ein CUL via USB wenn der FHEM Server günstig steht und einen oder zwei via LAN im Haus verteilt. Bei HM gibt es auch die WLAN Variante, allerdings habe ich die bisher unter MAX noch nicht getestet da bei meinem schlechten WLAN das eh nicht allgemein gültig wäre.
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4570
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #6 am: 29 Dezember 2020, 19:17:24 »
und sage z.B.: im Büro "Alexa, schalte die Heizung im Büro ein", schaltet er mir auch die Heizung im Wohnzimmer ein. Gleiches beim Ausschalten. Völlig strange.
Geräte wurden in einer anderen Reihenfolge am Cube angelernt als zuvor und nun stimmt interne GroupID nicht mit der RoomId des Cube überein -> https://forum.fhem.de/index.php/topic,117004.0.html
Lösung : Geräte zuvor einem Werksreset unterziehen oder Reihenfolge in der die Räume erzeugt wurden aufschreiben und beim nächsten mal peinlich genau einhalten.
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline JimKnopf

  • Developer
  • Full Member
  • ****
  • Beiträge: 136
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #7 am: 10 Januar 2022, 18:19:27 »
Hi!

Ich hänge mich hier mal an, da ich ein änliches Problem habe.
Auch bei mir lag beim Cube Alzheimer vor, also wie weiter oben erwähnt alles neu über den Cube angelernt.
Wenn ich jetzt über FHEM die Temperatur im Vorraum ändere, ändern sich auch die Thermostate in einem anderen Raum.
Wenn das direkt über den Cube gemacht wird passiert nichts, da hat auch ausschließlich das Webinterface Zugriff auf den Cube.
Wenn die Temperatur über eine andere Anwendung geändert wird, ändert sich ebenfalls der andere Raum.
Offensichtlich greift hier FHEM ein.
Ich habe schon reichlich deassociate getestet, alle Geräte in beide Richtungen. Habe gerade die Geräte im Cube gelöscht, die Geräte resettet und neu angelernt, gleiches Verhalten.
Hat da jemand eine Idee? Das treibt mich langsam in den Wahnsinn ......

Gruß,
Burkhard
FHEM,LaCrosse,PCA301,Revolt,MAX!,HM,FS20, MQTT2, ebusd 3.4.v3.4-96-g96d5623, ebus Adapter 3.0 mit 20201219-offset , Wolf  CGB (-K)-20, Wolf ISM7, Wolf Solar SM, Speicher/WR E3DC S10, eGolf, Keba P30, Phoenix Contact EV, OpenWB

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 404
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #8 am: 10 Januar 2022, 19:07:04 »
Genau was du beschreibst hat mich auch dazu bewegt auf einen CUL umzusteigen und den Cube zu eliminieren...Das hat mich wahnsinnig gemacht.
Seitdem habe ich Ruhe und die Sache läuft zuverlässig und ohne Alzheimer...
Ich kann nur sagen, es lohnt sich!

Gruß sTaN
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline JoSi

  • New Member
  • *
  • Beiträge: 5
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #9 am: 10 Januar 2022, 19:23:44 »
Hi, wenn du maxlan benützt wird alles über den Cube konfiguriert. Da darf Fhem nicht mitspielen bis nicht alles am Cube über die Maxi software eingerichtet ist. Ausserdem scheinen bei dir in Fhem groupid's vergeben worden sein. Setze die am besten mal auf 0.  Ich würde an deiner Stelle auf einen Cul umsteigen , oder wenn du keine Fensterkontakte benützt deinen Cube umflashen. 

Offline JimKnopf

  • Developer
  • Full Member
  • ****
  • Beiträge: 136
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #10 am: 11 Januar 2022, 14:01:34 »
Hi!

Danke für Eure Antworten und Tips.
In der Tat sind RaumIDs vergeben worden, aber ich dachte, das kommt auch vom Cube?
Ich werde die mal auf 0 setzten.
Die Anlage ist nicht bei un Zuhause, sondern in unserem Gemeindehaus.
Ich werde da später mal hinfahren und noch ein paar Versuche unternehmen (manuelles Verstellen am Thermostat mit und ohne laufendem FHEM).
Die Cubes, es sind zwei, sollen in der Tat umgeflasht werden, dazu muss ich aber erst noch FHEM per HTTP besser steuern können.

Gruß,
Burkhard
FHEM,LaCrosse,PCA301,Revolt,MAX!,HM,FS20, MQTT2, ebusd 3.4.v3.4-96-g96d5623, ebus Adapter 3.0 mit 20201219-offset , Wolf  CGB (-K)-20, Wolf ISM7, Wolf Solar SM, Speicher/WR E3DC S10, eGolf, Keba P30, Phoenix Contact EV, OpenWB

Offline JimKnopf

  • Developer
  • Full Member
  • ****
  • Beiträge: 136
Antw:Probleme nachdem der Cube alle Geräte verloren hat
« Antwort #11 am: 11 Januar 2022, 16:08:38 »
Nachtrag: Das setzten der GroupID auf 0 hat das Problem gelöst. Hab das jetzt in allen 14 Räumen geändert.
Danke für die Hilfe!

Gruß,
Burkhard
FHEM,LaCrosse,PCA301,Revolt,MAX!,HM,FS20, MQTT2, ebusd 3.4.v3.4-96-g96d5623, ebus Adapter 3.0 mit 20201219-offset , Wolf  CGB (-K)-20, Wolf ISM7, Wolf Solar SM, Speicher/WR E3DC S10, eGolf, Keba P30, Phoenix Contact EV, OpenWB

 

decade-submarginal