Autor Thema: [ENGLISH] NanoCUL for connecting with max!  (Gelesen 684 mal)

Offline haajee

  • New Member
  • *
  • Beiträge: 5
[ENGLISH] NanoCUL for connecting with max!
« am: 22 November 2020, 20:52:09 »
Hi everyone,

Sorry that i open this post in English but that's for me the best way to communicate. My German is more bad. ;)

Yesterday i received in my postbox a CC1101 868MHz. Like these one. Connect to a Arduino Nano clone 16MHz with this pinout.  I downloaded the firmware from here.

My configuration file is this:[
code]attr global userattr cmdIcon devStateIcon:textField-long devStateStyle icon sortby webCmd webCmdLabel:textField-long widgetOverride
attr global autoload_undefined_devices 1
attr global autosave 0
attr global logfile ./log/fhem-%Y-%m.log
attr global modpath .
attr global motd
attr global statefile ./log/fhem.save
attr global verbose 3

define WEB FHEMWEB 8083 global
setuuid WEB 5fba7b1e-f33f-8807-fc8f-828987194cf50773

# Fake FileLog entry, to access the fhem log from FHEMWEB
define Logfile FileLog ./log/fhem-%Y-%m.log fakelog
setuuid Logfile 5fba7b1e-f33f-8807-05af-2d00fb93d03c6bcd

define autocreate autocreate
setuuid autocreate 5fba7b1e-f33f-8807-9679-8704cda086bb48b5
attr autocreate filelog ./log/%NAME-%Y.log

define eventTypes eventTypes ./log/eventTypes.txt
setuuid eventTypes 5fba7b1e-f33f-8807-8de4-3ac2c5d33efe3779

# Disable this to avoid looking for new USB devices on startup
#### CUL Definition, MAX!Cube
define CUL0 CUL /dev/ttyUSB0@38400 1234
setuuid CUL0 5fbab98c-f33f-8807-8fb9-fbc09c3882d432f5
attr CUL0 rfmode MAX
define cm CUL_MAX 123456
setuuid cm 5fbab98f-f33f-8807-7db8-c248e242d20c415b
attr cm IODev CUL0
[/code]

In the log i read this:
2020.11.22 20:47:16 1: Including fhem.cfg
2020.11.22 20:47:16 3: WEB: port 8083 opened
2020.11.22 20:47:16 2: eventTypes: loaded 27 events from ./log/eventTypes.txt
2020.11.22 20:47:16 3: Opening CUL0 device /dev/ttyUSB0
2020.11.22 20:47:16 3: Setting CUL0 serial parameters to 38400,8,N,1
2020.11.22 20:47:19 3: CUL0: Possible commands: ABCEeFfGhiKklMmRTtUVWXxYZz
2020.11.22 20:47:19 3: CUL0 device opened
2020.11.22 20:47:19 2: Switched CUL0 rfmode to MAX
2020.11.22 20:47:19 3: CUL_MAX_Check: Detected firmware version 167 of the CUL-compatible IODev
2020.11.22 20:47:20 1: Including ./log/fhem.save
2020.11.22 20:47:20 0: Featurelevel: 6
2020.11.22 20:47:20 0: Server started with 7 defined entities (fhem.pl:21056/2020-01-26 perl:5.030000 os:linux user:fhem pid:85734)

But sadly it receives nothing from the max! wall thermostat. Even if i say set cm pairmode 45.

Strange enough when i open CUL0 and click on get ccconf i read this: CUL0 ccconf => freq:800.000MHz bWidth:203KHz rAmpl:33dB sens:8dB 800MHz???? I have flashed some other hex files but it stays.

Who could help me please?

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 23456
Antw:[ENGLISH] NanoCUL for connecting with max!
« Antwort #1 am: 23 November 2020, 09:25:49 »
You can change the frequency with the "set CUL0 freq 868.3" command, but the readout with 800MHz shows, that something in the hardware is broken: either the EEPROM, or some parts of the CC1101. I would try first to reset the eeprom to factory reset with "set CUL0 raw e". I hope that the nanocul firmware is the same in this respect as the "original" CUL firmware.

Offline haajee

  • New Member
  • *
  • Beiträge: 5
Antw:[ENGLISH] NanoCUL for connecting with max!
« Antwort #2 am: 23 November 2020, 22:31:34 »
Hmm when i add the configuration back from 0 it''s all ok on correct frequency. Only when i switch RFMode to max it change the frequency to a totally different frequency. Really strange. I think it's a configuration issue becaue the rest works perfect. Directly after i change rfmode to MAX! it give the wrog frequency.

Offline haajee

  • New Member
  • *
  • Beiträge: 5
Antw:[ENGLISH] NanoCUL for connecting with max!
« Antwort #3 am: 24 November 2020, 16:09:20 »
Update: i got it working. The problem with the strange frequencies (sometime 3.3GHz??)  stopped after i flashed the 433MHz cul and then flashed the 868MHz back. Then i has also no detection and pair with Max! devices. But the bandwith was on 303KHz and i changed it to 101KHz and voila it works! I could also nowhere found the official bandwith of the Max!.

Anyway thank you all