Autor Thema: Temperatur-Scanner für MAX-Thermostate  (Gelesen 371242 mal)

Offline Bonzon

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #450 am: 05 Dezember 2013, 14:09:25 »
Hi John,

der Chartplot war nut für dich als zusatz, der log hängt oben drüber. Die Datei log.txt  :)

Ich hab sie dir noch einmal angehängt.
Raspberry Pi Typ B, 512 MB mit CUL V3.4 (Firmware 1.57 CUL868) für Homatic und CUL V3.4 (Firmware 1.57 CUL868) für MAX!
MAX!: Heizkörperthermostate, Wandthermostat WT+
Homatic: HM-LC-SW1-FM
Netatmo Wetterstation: Indoor-Modul, Outdoor-Modul

Offline John

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1426
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #451 am: 05 Dezember 2013, 14:31:23 »
Hi Stan,
Zitat
2013.12.05 13:23:03 2: CUL_MAX_SendQueueHandler: Not enough credit! credit10ms is 93, but we need 121. Waiting 28 seconds.
2013.12.05 13:23:33 2: CUL_MAX_SendQueueHandler: Not enough credit! credit10ms is 2, but we need 121. Waiting 119 seconds.

Das kommt relativ häufig beim Hochfahren, hast du eine Erklärung ?
Der Scanner gibt je jeden Befehl explizit aus.

Die Thermostate werden mit 3 Minuten sehr häufig gescanned, da muss ich nochmal in mich gehen.

Wichtig wäre eine Log-Datei, wenn es nicht klappt bei einem Schaltpunkt.
So sieht alles ziemlich ok aus.

John
CubieTruck CULV3 MAX HM  Logo  ESP8266 MQTT PID20 HourCounter MaxScanner KostalPiko

Offline Bonzon

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #452 am: 05 Dezember 2013, 14:37:22 »
Hi John,

ja da gebe ich dir recht. Die credits sind immer recht schnell aufgebraucht und er brauch dann immer eine Weile, bis er die Warteschlange abgarbeitet hat.

Es ist schon einmal gut, dass alles okay aussieht. Ich würde jetzt vorschlagen, ich stelle den Scanner für das BZ wieder ein und logge auf verbose 4. Sollte er dann irgendwann nicht schalten, dann würde ich hier noch einmal einen Log posten.

Vielleicht kommen wir so dem Fehler ein wenig auf die Spur.

Vielen Dank, das du dich meiner angenommen hast.

Viele Grüße,

Stan
Raspberry Pi Typ B, 512 MB mit CUL V3.4 (Firmware 1.57 CUL868) für Homatic und CUL V3.4 (Firmware 1.57 CUL868) für MAX!
MAX!: Heizkörperthermostate, Wandthermostat WT+
Homatic: HM-LC-SW1-FM
Netatmo Wetterstation: Indoor-Modul, Outdoor-Modul

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #453 am: 05 Dezember 2013, 17:06:54 »
Hallo John,

Zitat
Die Thermostate werden mit 3 Minuten sehr häufig gescanned, da muss ich nochmal in mich gehen.
Ich habe 7 gescannte Thermostate (3 im Wohnzimmer, 1 davon gescannt), die bei der automatischen Berechnung der Scanzeit auf ca. 9 min kommen. Da mir das zu kurz war, habe ich bei mir die Zeile 400 so geändert:
my $numWorkIntervall =  int(  60/int($numTXPerMinutes /$numValidThermos)*1.5 );Damit komme ich auf eine Umschaltzeit von ca. 15 min. Die Temperaturkurven sehen so ganz prima aus, weil die Änderungen ja nicht so schnell sind.

Viele Grüße

Harald
Ach ja, gegen 16:00 habe ich mit dem ECO-Taster rumprobiert.
« Letzte Änderung: 05 Dezember 2013, 17:13:15 von Harald »
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline hobu

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #454 am: 05 Dezember 2013, 18:23:48 »
Ich habe 7 gescannte Thermostate (3 im Wohnzimmer, 1 davon gescannt), die bei der automatischen Berechnung der Scanzeit auf ca. 9 min kommen. Da mir das zu kurz war, habe ich bei mir die Zeile 400 so geändert:
my $numWorkIntervall =  int(  60/int($numTXPerMinutes /$numValidThermos)*1.5 );Damit komme ich auf eine Umschaltzeit von ca. 15 min. Die Temperaturkurven sehen so ganz prima aus, weil die Änderungen ja nicht so schnell sind.

In Zeile 346 kann man ein Intervall einstellen (Default war 3):
my $numBaseIntervall=15;        # min. pollrate in minuten, vorgegeben durch firmware der thermosHat das evtl. den gleichen Effekt wie Deine Änderung in der Formel oder wofür wird dieses Intervall verwendet?
Raspberry Pi (Model B)
HM-CFG-USB, HM-CC-RT-DN, HM-LC-SW1-FM, HM-Dis-WM55, HM-FK-SCO

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #455 am: 05 Dezember 2013, 19:34:37 »
Hm, da bin ich mir nicht sicher, wie sich eine Erhöhung dieses MinIntervalls auf Johns Berechnungen auswirkt. Meine Änderung fügt sich in diese Berechnungen ein und bewirkt halt eine lineare Erhöhung der aktuellen Intervallzeit.

Da kann John sicherlich genaueres dazu sagen.

Viele Grüße

Harald
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline Bonzon

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #456 am: 06 Dezember 2013, 11:29:52 »
Hi John,

so nachdem es gestern ganz gut aussah, hat das Thermostat im Wohnzimmer gestern abend leider erneut falsch geschalten.
Ich weiß echt nicht woran es liegt, aber er will nicht das machen was ich will. Ich füge dir nochmal alles an.

Es geht speziell um den Schaltpunkt um 22:00 Uhr von 22°C auf 17°C

my $eco = 17;;\
fhem("set HT_BZ_Thermostat weekProfile Mon $eco,7:00,23,10:00,21,22:00,$eco Tue $eco,7:00,23,10:00,21,22:00,$eco Wed $eco,7:00,23,10:00,21,22:00,$eco Thu $eco,7:00,23,10:00,21,22:00,$eco Fri $eco,7:00,23,10:00,21,22:00,$eco Sat $eco,8:00,23,11:00,21,22:00,$eco Sun $eco,8:00,23,11:00,21,22:00,$eco");;\
fhem("set HT_WZ_Thermostat weekProfile Mon $eco,7:00,22,22:00,$eco Tue $eco,7:00,22,22:00,$eco Wed $eco,7:00,22,22:00,$eco Thu $eco,7:00,22,22:00,$eco Fri $eco,7:00,22,22:00,$eco Sat $eco,8:00,22,22:00,$eco Sun $eco,8:00,22,22:00,$eco");;\
fhem("set HT_AZ_Thermostat weekProfile Mon $eco,7:00,21,22:00,$eco Tue $eco,7:00,21,22:00,$eco Wed $eco,7:00,21,22:00,$eco Thu $eco,7:00,21,22:00,$eco Fri $eco,7:00,21,22:00,$eco Sat $eco,10:00,21,22:00,$eco Sun $eco,10:00,21,22:00,$eco");;\

Achso nicht wundern. Ich laufe derzeit auf einem anderen Wochenprofil als gestern. Ich habe das gestern gegen 14:00 Uhr umgestellt.

Ich habe dir das Logfile, ein Bild von dem Wochenprofil im FHEM und ein Plot angehängt.

Ich hoffe du kannst villeicht den Fehler finden.

Gruß,

Stan
Raspberry Pi Typ B, 512 MB mit CUL V3.4 (Firmware 1.57 CUL868) für Homatic und CUL V3.4 (Firmware 1.57 CUL868) für MAX!
MAX!: Heizkörperthermostate, Wandthermostat WT+
Homatic: HM-LC-SW1-FM
Netatmo Wetterstation: Indoor-Modul, Outdoor-Modul

Offline stgeran

  • Hero Member
  • *****
  • Beiträge: 1052
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #457 am: 06 Dezember 2013, 15:48:01 »
Ich habe den gleichen Fehler um 22:00 von 22°C auf 17°C. Wenn nötig schicke ich heute Abend den Teil des logs von gestern und den Auszu des Wochenprofils.

Gruß Gerhard
FHEM auf Raspberry
CSM 866MHz für EM1010 mit Strom und Gaszähler
CUL 866MHz für MAX! Radiator Thermostat 
CUL 433MHz für Innen und Aussen Temp
HMLAN für HM-LC-Sw1-PI-2

Offline John

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1426
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #458 am: 06 Dezember 2013, 16:52:39 »
Ich hatte noch keine Zeit die Logfiles zu checken.
Aber: auch ich habe den Fehler.

Wochenprofil wird korrekt dargestellt.
ein
set <thermsotat> desiredTemperatur auto
setzt den Sollwert falsch, also nicht auf den Wert des Wochenprofils

Bitte prüft das bei euren Thermostaten nach.
Wenn dem so ist, ist das ein Thema für Matthias.

John
« Letzte Änderung: 06 Dezember 2013, 23:24:54 von John »
CubieTruck CULV3 MAX HM  Logo  ESP8266 MQTT PID20 HourCounter MaxScanner KostalPiko

Offline stgeran

  • Hero Member
  • *****
  • Beiträge: 1052
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #459 am: 06 Dezember 2013, 17:52:37 »
So sieht es im "Umbruch" bei mir aus:
2013-12-05_22:00:57 Hzg_WZ1 mode: manual
2013-12-05_22:00:57 Hzg_WZ1 battery: ok
2013-12-05_22:00:57 Hzg_WZ1 desiredTemperature: 22.0
2013-12-05_22:00:57 Hzg_WZ1 temperature: 23.8
2013-12-05_22:00:57 Hzg_WZ1 valveposition: 45
2013-12-05_22:00:57 Hzg_WZ1 22.0 °C
2013-12-05_22:01:25 Hzg_WZ1 desiredTemperature auto
2013-12-05_22:01:27 Hzg_WZ1 mode: auto
2013-12-05_22:01:27 Hzg_WZ1 battery: ok
2013-12-05_22:01:27 Hzg_WZ1 desiredTemperature: 17.0
2013-12-05_22:01:27 Hzg_WZ1 valveposition: 45
2013-12-05_22:01:27 Hzg_WZ1 17.0 °C
FHEM auf Raspberry
CSM 866MHz für EM1010 mit Strom und Gaszähler
CUL 866MHz für MAX! Radiator Thermostat 
CUL 433MHz für Innen und Aussen Temp
HMLAN für HM-LC-Sw1-PI-2

defnoyz

  • Gast
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #460 am: 06 Dezember 2013, 18:36:27 »
ich hatte das exakt gleiche problem

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #461 am: 06 Dezember 2013, 19:36:10 »
Auch ich habe dieses Verhalten beobachtet. Allerdings dachte ich, das käme von meinem rumprobieren mit Betriebsmodus, ECO-Taster, Hand/Auto usw. Deshalb habe ich mich auch nicht gemeldet.

Viele Grüße

Harald
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #462 am: 07 Dezember 2013, 10:46:35 »
So, nun etwas genauer:

Mein ECO-Taster ist wie meine Ventile am Cube angemeldet. Die gesamte Heizungssteuerung läuft darüber. FHEM liest die Parameter aus und zeigt sie an.

Wenn ich mittels des Tasters auf ECO schalte, wird dieser Befehl an den Cube gesendet und dieser gibt das an die Ventile weiter. Die Modusänderung erscheint praktisch sofort auf den Ventilanzeigen.
Es ist schon öfter vorgekommen, dass am Heizkörper ordnungsgemäß manual und die entprechende ECO-Temperatur angezeigt wurde, aber in FHEM für ein oder mehrere Ventile auto und die entsprechende auto-Temperatur stehen blieben. Manchmal wurde nach unterschiedlich langer Zeit (bis zu 1 Std und mehr) dann doch noch auf ECO umgeschaltet. Das gleiche passiert auch im umgekehrten Falle. Zu bemerken ist noch, dass bei allen Versuchen MaxScan in Betrieb war.

Ich habe im Logfile folgende Fehlermeldung gefunden, die NICHT zeitlich zu o.g. Problem passen
2013.12.07 04:14:57 1: MAXLAN_ReadSingleResponse: timeout while reading from socket, disconnecting
2013.12.07 04:14:57 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.12.07 04:14:57 3: set Kueche desiredTemperature auto 17.0 : MAXLAN_Write: MAXLAN_Connect: MAXLAN_ExpectAnswer: Error while waiting for answer H:
2013.12.07 05:03:20 1: MAXLAN_ReadSingleResponse: timeout while reading from socket, disconnecting
2013.12.07 05:03:20 1: MAXLAN_ExpectAnswer: Error while waiting for answer H:
Zu der Zeit habe ich geschlafen und ganz sicher nicht den PC und somit die FHEM-Weboberflächen laufen gehabt.

Ich habe immer gedacht, dass diese Unregelmäßigkeiten von meinen Spielereien kämen. Da aber auch andere solche Erscheinungen haben, möchte ich das nun doch ausschließen.

Viele Grüße

Harald
« Letzte Änderung: 07 Dezember 2013, 11:18:40 von Harald »
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #463 am: 07 Dezember 2013, 12:02:27 »
So, der nächste Test:

MaxScan habe ich abgeschaltet. Die Abfragezeit von MAXLAN steht auf 540 sec = 9 min. Etwa in der Mitte der Abfragezeit wurde der ECO-Taster betätigt, um von auto auf eco und zurück zuschalten. Bei allem 7 durchgeführten Schaltzyklen wurden die Einstellungen jeweils sofort von den Ventilen übernommen und beim nächsten MAXLAN-Abfrageinterval auch brav richtig in FHEM angezeigt.

Nach Einschalten von MaxScan wurde sofort beim 1. Zyklus bei 2 Ventilen die falsche Solltemperatur angezeigt. Die anderen waren richtig.
Beim nächsten Zyklus von MaxScan haben 4 Ventile die richtige Auto-Soll-Temperatur und Modus manual, was richtig ist bei auto/man-Umschaltung. Die anderen 3 (Wohnzimmer) habe die ECO-Soll-Temperatur, obwohl die Anlage nicht in ECO-Mode geschaltet ist und auto-Mode. Es sieht z.Z. so aus, als wenn das Wohnzimmer im ECO-Modus stünde und die anderen im Normalbetrieb.

Kann es sein, dass sich der MaxScantakt und der MAXLAN-Zyklus irgendwie ins Gehege kommen? Oder habe ich bei meinen Versuchen ein Fehler gemacht?

Viele Grüße

Harald
« Letzte Änderung: 07 Dezember 2013, 12:21:47 von Harald »
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline John

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1426
Antw:Temperatur-Scanner für MAX-Thermostate
« Antwort #464 am: 07 Dezember 2013, 12:16:27 »
Hallo Harald,
ECO-Taster ist ja beim Scanner noch nicht berücksichtigt.
Überleg dir nochmal die Konsequenzen von langen Pollzeiten bei MAXLAN.
Daraus ergibt sich die max. Verzögerung, mit der der Scanner von den neuen Gegebenheiten informiert wird.
Aber das ist ein anderes Thema.

Wir haben ein klares Problem bei den Weekprofiles.
Siehe
http://forum.fhem.de/index.php/topic,17231.0.html

Kannst du das bitte mit deinem Cube auch mal testen, um zu sehen ob das Problem nur bei CUL oder auch bei CUBE auftritt.
(Bitte vorher den Scanner für das Thermostat wie scanTemp=0 deaktivieren)
Das Testverfahren ist beschrieben. Bitte weitere Antworten zum Weekprofile dort im Betrag hinterlegen.

@Bonzon
Das Problem mit den WeekProfiles hat unmittelbar mit deinem Problem zu tun.
Du hast im Weekprofile 3 Bereiche und das Problem tritt stets im 3. Bereich auf.

John
« Letzte Änderung: 07 Dezember 2013, 12:25:09 von John »
CubieTruck CULV3 MAX HM  Logo  ESP8266 MQTT PID20 HourCounter MaxScanner KostalPiko