Autor Thema: fhempy: googlecast  (Gelesen 24789 mal)

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #210 am: 09 Februar 2021, 20:24:52 »
Das kannst du vorerst auch bei fhempy machen. Einfach im BindingIo Device restart ausführen.
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline KOAL

  • Jr. Member
  • **
  • Beiträge: 60
  • Smarthome, spart Geld
Antw:fhempy: googlecast
« Antwort #211 am: 13 Februar 2021, 12:12:44 »
Hallo,

anscheinend gab es ein Update auf meinem System welches mir das "fhempy" zerschossen hat.


root@FHEM-SERVER:~# journalctl -u fhempy.service -f
-- Logs begin at Fri 2021-02-12 19:38:33 UTC. --
Feb 13 11:06:47 FHEM-SERVER systemd[44430]: fhempy.service: Failed to determine user credentials: No such process
Feb 13 11:06:47 FHEM-SERVER systemd[44430]: fhempy.service: Failed at step USER spawning /home/pi/.local/bin/fhempy: No such process
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Main process exited, code=exited, status=217/USER
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Failed with result 'exit-code'.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Service RestartSec=100ms expired, scheduling restart.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Scheduled restart job, restart counter is at 5.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: Stopped FHEM PythonBinding.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Start request repeated too quickly.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: fhempy.service: Failed with result 'exit-code'.
Feb 13 11:06:47 FHEM-SERVER systemd[1]: Failed to start FHEM PythonBinding.


Ein Update vom fhempy...

root@FHEM-SERVER:~# pip3 install --upgrade fhempy

  error: Can not find Rust compiler

  ----------------------------------------
  Failed building wheel for cryptography
  Running setup.py clean for cryptography
Failed to build cryptography

    error: Can not find Rust compiler

    ----------------------------------------
  Can't roll back cryptography; was not uninstalled
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-_lhvgl2a/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-g5wdvc74/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-_lhvgl2a/cryptography/




In FHEM sieht das ganze nun so aus:

Module failed to load: googlecast
Maybe you need to update fhempy on this or remote peer.

Stacktrace:
Traceback (most recent call last):
  File "/opt/fhem/.local/lib/python3.7/site-packages/fhempy/lib/fhem_pythonbinding.py", line 253, in _onMessage
    functools.partial(importlib.import_module, pymodule)
  File "/opt/fhem/.local/lib/python3.7/site-packages/fhempy/lib/utils.py", line 32, in run_blocking
    return await asyncio.get_event_loop().run_in_executor(pool, function)
  File "/usr/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/opt/fhem/.local/lib/python3.7/site-packages/fhempy/lib/googlecast/googlecast.py", line 20, in <module>
    from pychromecast.controllers.bubbleupnp import BubbleUPNPController
ModuleNotFoundError: No module named 'pychromecast.controllers.bubbleupnp'


Bitte um Hilfe, DANKE!

LG
KOAL
« Letzte Änderung: 13 Februar 2021, 12:28:05 von KOAL »
1X DEBAIN 11 ESXI VM, Openvpn-Server, FHEM, DHCP, HM-LAN W, USB-Enocean, Smartvisu V3.X
1X UBUNU 20.X LTS ESXI VM, AUTO-SERVER, Openvpn-Backup Server
1X UBUNU 20.X LTS ESXI VM, MAILSERVER, CLOUD
1X Lockerstor 4, NAS + APC CS650
1X WIN-10 ESXI VM, BLUEIRIS CAM Server

Offline KOAL

  • Jr. Member
  • **
  • Beiträge: 60
  • Smarthome, spart Geld
Antw:fhempy: googlecast
« Antwort #212 am: 13 Februar 2021, 12:31:48 »
UPDATE:


Nach einem Update auf Rust 1.50.0, mit dem Befel:
curl -sf -L https://static.rust-lang.org/rustup.sh | sh
Ging das Update von fhempy durch, aber in FHEM selbst funktioniert es noch immer nicht

root@FHEM-SERVER:~# pip3 install --upgrade fhempy
Requirement already up-to-date: fhempy in /usr/local/lib/python3.7/dist-packages (0.1.48)
Requirement already satisfied, skipping upgrade: websockets>=8.1 in /usr/local/lib/python3.7/dist-packages (from fhempy) (8.1)
Requirement already satisfied, skipping upgrade: cryptography>=3.3.1 in /usr/local/lib/python3.7/dist-packages (from fhempy) (3.4.4)
Requirement already satisfied, skipping upgrade: importlib-metadata>=3.3.0 in /usr/local/lib/python3.7/dist-packages (from fhempy) (3.4.0)
Requirement already satisfied, skipping upgrade: zeroconf>=0.28.6 in /usr/local/lib/python3.7/dist-packages (from fhempy) (0.28.6)
Requirement already satisfied, skipping upgrade: cffi>=1.12 in /usr/local/lib/python3.7/dist-packages (from cryptography>=3.3.1->fhempy) (1.14.5)
Requirement already satisfied, skipping upgrade: zipp>=0.5 in /usr/local/lib/python3.7/dist-packages (from importlib-metadata>=3.3.0->fhempy) (3.4.0)
Requirement already satisfied, skipping upgrade: typing-extensions>=3.6.4; python_version < "3.8" in /usr/local/lib/python3.7/dist-packages (from importlib-metadata>=3.3.0->fhempy) (3.7.4.3)
Requirement already satisfied, skipping upgrade: ifaddr>=0.1.7 in /usr/local/lib/python3.7/dist-packages (from zeroconf>=0.28.6->fhempy) (0.1.7)
Requirement already satisfied, skipping upgrade: pycparser in /usr/local/lib/python3.7/dist-packages (from cffi>=1.12->cryptography>=3.3.1->fhempy) (2.20)
root@FHEM-SERVER:~#


Ich kann jedoch fhempy nicht starten:

root@FHEM-SERVER:~# journalctl -u fhempy.service -f
-- Logs begin at Sat 2021-02-13 11:22:05 UTC. --
Feb 13 11:27:22 FHEM-SERVER systemd[2233]: fhempy.service: Failed to determine user credentials: No such process
Feb 13 11:27:22 FHEM-SERVER systemd[2233]: fhempy.service: Failed at step USER spawning /home/pi/.local/bin/fhempy: No such process
Feb 13 11:27:22 FHEM-SERVER systemd[1]: fhempy.service: Main process exited, code=exited, status=217/USER
Feb 13 11:27:22 FHEM-SERVER systemd[1]: fhempy.service: Failed with result 'exit-code'.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: fhempy.service: Service RestartSec=100ms expired, scheduling restart.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: fhempy.service: Scheduled restart job, restart counter is at 5.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: Stopped FHEM PythonBinding.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: fhempy.service: Start request repeated too quickly.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: fhempy.service: Failed with result 'exit-code'.
Feb 13 11:27:23 FHEM-SERVER systemd[1]: Failed to start FHEM PythonBinding.

System: (uodate/ugrade alles auf akuellem Stand)
root@FHEM-SERVER:~# cat /etc/issue
Debian GNU/Linux 10 \n \l

Fhem-Version:
6.0.23723

Pychromecast Verion:
root@FHEM-SERVER:~# sudo -u fhem pip3 show pychromecast
Name: PyChromecast
Version: 7.5.1
Summary: Python module to talk to Google Chromecast.
Home-page: https://github.com/balloob/pychromecast
Author: Paulus Schoutsen
Author-email: paulus@paulusschoutsen.nl
License: MIT
Location: /usr/local/lib/python3.7/dist-packages
Requires: casttube, protobuf, zeroconf, requests
Required-by:





Hmm :/
hat jemand die gleichen Problem?
« Letzte Änderung: 13 Februar 2021, 12:47:28 von KOAL »
1X DEBAIN 11 ESXI VM, Openvpn-Server, FHEM, DHCP, HM-LAN W, USB-Enocean, Smartvisu V3.X
1X UBUNU 20.X LTS ESXI VM, AUTO-SERVER, Openvpn-Backup Server
1X UBUNU 20.X LTS ESXI VM, MAILSERVER, CLOUD
1X Lockerstor 4, NAS + APC CS650
1X WIN-10 ESXI VM, BLUEIRIS CAM Server

Offline JF Mennedy

  • Full Member
  • ***
  • Beiträge: 188
Antw:fhempy: googlecast
« Antwort #213 am: 13 Februar 2021, 12:45:29 »
Hi,

auf nem FHEM System, also kein remote peer, solltest Du fhempy gar nicht per pip installieren. Das geschieht alles automatisch mit der Definition des BindingsIO define local_pybinding BindingsIo Python
Gruss Jan

Offline KOAL

  • Jr. Member
  • **
  • Beiträge: 60
  • Smarthome, spart Geld
Antw:fhempy: googlecast
« Antwort #214 am: 13 Februar 2021, 13:04:02 »
UPDATE:

erstmal danke für die Antwort "JF Mennedy".
Somit ist es voll OK wenn FHEMPY nicht läuft und ich kann es auch wieder deinstallieren am Hauptserver?

Ich konnte das Problem nun "lösen" bzw. umgehen...keine Ahnung ob das Ok ist.
Eventuell kann das jemand bestätigen nicht das ich mir so einen Sicherheitslücke geschaffen habe.

Lösung:

sudo pip install git+https://github.com/dominikkarall/pychromecast.git

dadurch wurde PyChromecast von Version 8.1.0 auf 7.1.1 downgegraded, und schwups war es in FHEM wieder OK.
Successfully built PyChromecast
Installing collected packages: PyChromecast
  Found existing installation: PyChromecast 8.1.0
    Uninstalling PyChromecast-8.1.0:
      Successfully uninstalled PyChromecast-8.1.0
Successfully installed PyChromecast-7.1.1

Google spricht wieder mit mir :) FHEM:
CASTNAME: Wohnzimmer
DEF: googlecast "Wohnzimmer"
IODev: local_pybinding
NAME: Wohnzimmer.chromecast
NR: 2157
PYTHONTYPE: googlecast
STATE: online
TYPE: PythonModule
Denk das Problem ist behoben.
DANKE
« Letzte Änderung: 13 Februar 2021, 15:34:18 von KOAL »
1X DEBAIN 11 ESXI VM, Openvpn-Server, FHEM, DHCP, HM-LAN W, USB-Enocean, Smartvisu V3.X
1X UBUNU 20.X LTS ESXI VM, AUTO-SERVER, Openvpn-Backup Server
1X UBUNU 20.X LTS ESXI VM, MAILSERVER, CLOUD
1X Lockerstor 4, NAS + APC CS650
1X WIN-10 ESXI VM, BLUEIRIS CAM Server

Offline benm

  • New Member
  • *
  • Beiträge: 15
Antw:fhempy: googlecast
« Antwort #215 am: 13 Februar 2021, 13:25:22 »
Hallo zusammen,

hat jemand fhempy in Docker am laufen? Bei mir bleibt local_pybinding immer auf disconnected stehen.

Im fhempy.log steht folgendes:
2021-02-13 13:19:12,690 - INFO     - __main__: Attempting install of fhempy>=0.1.12
2021-02-13 13:19:57,641 - ERROR    - __main__: Unable to install package fhempy>=0.1.12: Failed building wheel for cryptography
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-bafee938/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-n22o6ttk/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-bafee938/cryptography/
2021-02-13 13:19:57,642 - ERROR    - __main__: Failed to install fhempy, exit now...

Und im fhem.log steht das hier und wiederholt sich ständig:
2021.02.13 13:22:43.799 3: Pythonbinding_15733: read: end of file reached while sysread
2021.02.13 13:22:43.799 3: Pythonbinding_15733: stopped
2021.02.13 13:22:43.808 3: Pythonbinding_15733: starting
2021.02.13 13:22:43.812 3: Pythonbinding_15733: using logfile: ./log/fhempy-2021-02-13.log
2021.02.13 13:22:43.813 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:22:55.607 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:08.625 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:21.734 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:32.358 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)

Jemand eine Idee, was ich falsch mache?

Grüße, Benjamin

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #216 am: 13 Februar 2021, 18:22:30 »
UPDATE:

erstmal danke für die Antwort "JF Mennedy".
Somit ist es voll OK wenn FHEMPY nicht läuft und ich kann es auch wieder deinstallieren am Hauptserver?

Ich konnte das Problem nun "lösen" bzw. umgehen...keine Ahnung ob das Ok ist.
Eventuell kann das jemand bestätigen nicht das ich mir so einen Sicherheitslücke geschaffen habe.

Lösung:

sudo pip install git+https://github.com/dominikkarall/pychromecast.git

dadurch wurde PyChromecast von Version 8.1.0 auf 7.1.1 downgegraded, und schwups war es in FHEM wieder OK.
Successfully built PyChromecast
Installing collected packages: PyChromecast
  Found existing installation: PyChromecast 8.1.0
    Uninstalling PyChromecast-8.1.0:
      Successfully uninstalled PyChromecast-8.1.0
Successfully installed PyChromecast-7.1.1

Google spricht wieder mit mir :) FHEM:
CASTNAME: Wohnzimmer
DEF: googlecast "Wohnzimmer"
IODev: local_pybinding
NAME: Wohnzimmer.chromecast
NR: 2157
PYTHONTYPE: googlecast
STATE: online
TYPE: PythonModule
Denk das Problem ist behoben.
DANKE

Hi,
mein pychromecast Repository ist schon ziemlich alt. Da sollte schon 8.x verwendet werden.

2 Fragen
 - Lässt du fhempy bewusst als root User laufen? Das solltest du nicht machen, fhempy benötigt kein root und sollte daher als pi oder ähnlicher User laufen. fhempy ist somit OHNE sudo zu installieren.
 - cryptography dürfte das Problem sein. Installiere bitte nochmals die apt Pakete hier: https://github.com/dominikkarall/fhempy#console danach starte nochmals neu.

Mach bitte auch ein "sudo pip3 install --upgrade pychromecast" damit du wieder die letzte Version hast.
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #217 am: 13 Februar 2021, 18:23:36 »
Hallo zusammen,

hat jemand fhempy in Docker am laufen? Bei mir bleibt local_pybinding immer auf disconnected stehen.

Im fhempy.log steht folgendes:
2021-02-13 13:19:12,690 - INFO     - __main__: Attempting install of fhempy>=0.1.12
2021-02-13 13:19:57,641 - ERROR    - __main__: Unable to install package fhempy>=0.1.12: Failed building wheel for cryptography
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-bafee938/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-n22o6ttk/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-bafee938/cryptography/
2021-02-13 13:19:57,642 - ERROR    - __main__: Failed to install fhempy, exit now...

Und im fhem.log steht das hier und wiederholt sich ständig:
2021.02.13 13:22:43.799 3: Pythonbinding_15733: read: end of file reached while sysread
2021.02.13 13:22:43.799 3: Pythonbinding_15733: stopped
2021.02.13 13:22:43.808 3: Pythonbinding_15733: starting
2021.02.13 13:22:43.812 3: Pythonbinding_15733: using logfile: ./log/fhempy-2021-02-13.log
2021.02.13 13:22:43.813 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:22:55.607 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:08.625 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:21.734 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:32.358 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)

Jemand eine Idee, was ich falsch mache?

Grüße, Benjamin

Dürfte ebenfalls das cryptography package sein. Kannst du bitte auch nochmals per apt alles installieren: https://github.com/dominikkarall/fhempy#console
Danach bitte nochmals testen.
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline benm

  • New Member
  • *
  • Beiträge: 15
Antw:fhempy: googlecast
« Antwort #218 am: 13 Februar 2021, 21:15:47 »
Dürfte ebenfalls das cryptography package sein. Kannst du bitte auch nochmals per apt alles installieren: https://github.com/dominikkarall/fhempy#console
Danach bitte nochmals testen.

Danke für deine schnelle Antwort...hatte vergessen zu schreiben, dass ich das auch schon gemacht habe. Hab mein Container aber noch mal ohne irgendwelche Parameter gestartet und nur die Installation für fhempy durchgeführt.

Leider wieder das gleiche Ergebnis:
2021-02-13 21:05:05,192 - INFO     - __main__: Attempting install of fhempy>=0.1.12
2021-02-13 21:06:25,724 - ERROR    - __main__: Unable to install package fhempy>=0.1.12: Failed building wheel for cryptography
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-7_4zn6dv/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-cvz5l3ym/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-7_4zn6dv/cryptography/
2021-02-13 21:06:25,725 - ERROR    - __main__: Failed to install fhempy, exit now...

Keine Ahnung ob das hilft, ich bin gerade dabei meine FHEM Installation in Docker neu aufzusetzen, deshalb habe ich noch nichts anderes installiert. Ich nutze diese FHEM Docker:
https://github.com/fhem/fhem-docker

Mein Container habe ich bisher so erzeugt:
sudo docker run -d --name fhem -p 8083:8083 -p 15733:15733 --restart always -v /opt/fhem:/opt/fhem --device=/dev/serial/by-id/usb-FTDI_FT232R_USB_UART_AL021S0E-if00-port0:/dev/serial/by-id/usb-FTDI_FT232R_USB_UART_AL021S0E-if00-port0 -e TZ=Europe/Berlin -e APT_PKGS="python3 python3-pip python3-dev libffi-dev libssl-dev libjpeg-dev zlib1g-dev autoconf build-essential libglib2.0-dev libdbus-1-dev bluez libbluetooth-dev" -e CPAN_PKGS="Protocol::WebSocket" --add-host host.docker.internal:host-gateway fhem/fhem
Nach deinem Hinweis habe ich mein Container noch mal so erstellt:
docker run -d --name fhem -p 8083:8083 -v /opt/fhem:/opt/fhem fhem/fhemund dann per apt installiert.

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #219 am: 13 Februar 2021, 22:41:30 »
Kannst du mal im Container ein
sudo -u fhem pip3 install cryptographymachen und mir die Ausgabe posten.
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline Keichi

  • New Member
  • *
  • Beiträge: 18
Antw:fhempy: googlecast
« Antwort #220 am: 14 Februar 2021, 00:04:03 »
Hallo zusammen,

hat jemand fhempy in Docker am laufen? Bei mir bleibt local_pybinding immer auf disconnected stehen.

Im fhempy.log steht folgendes:
2021-02-13 13:19:12,690 - INFO     - __main__: Attempting install of fhempy>=0.1.12
2021-02-13 13:19:57,641 - ERROR    - __main__: Unable to install package fhempy>=0.1.12: Failed building wheel for cryptography
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-bafee938/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-n22o6ttk/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-install-bafee938/cryptography/
2021-02-13 13:19:57,642 - ERROR    - __main__: Failed to install fhempy, exit now...

Und im fhem.log steht das hier und wiederholt sich ständig:
2021.02.13 13:22:43.799 3: Pythonbinding_15733: read: end of file reached while sysread
2021.02.13 13:22:43.799 3: Pythonbinding_15733: stopped
2021.02.13 13:22:43.808 3: Pythonbinding_15733: starting
2021.02.13 13:22:43.812 3: Pythonbinding_15733: using logfile: ./log/fhempy-2021-02-13.log
2021.02.13 13:22:43.813 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:22:55.607 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:08.625 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:21.734 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)
2021.02.13 13:23:32.358 1: BindingsIo: ERROR local_pybinding - error while connecting: 127.0.0.1: Connection refused (111)

Jemand eine Idee, was ich falsch mache?

Grüße, Benjamin

Da schließ ich mich mal an.. Selber Fehler auf nen RPI 3B+ mit aktuellen Buster.. Bei mir scheitert der auch am Cryptomodul.

Kannst du mal im Container ein
sudo -u fhem pip3 install cryptographymachen und mir die Ausgabe posten.

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages (2.6.1)

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #221 am: 14 Februar 2021, 08:52:06 »
Bitte dann folgendes testen:
sudo -u fhem pip3 install --upgrade cryptography
sudo -u fhem pip3 install --upgrade fhempy
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline Keichi

  • New Member
  • *
  • Beiträge: 18
Antw:fhempy: googlecast
« Antwort #222 am: 14 Februar 2021, 09:18:29 »
Bitte dann folgendes testen:
sudo -u fhem pip3 install --upgrade cryptography
sudo -u fhem pip3 install --upgrade fhempy

Bleibt dabei.. Alles auf dem neusten Stand.

pi@fhem:~ $ sudo -u fhem pip3 install --upgrade cryptography
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: cryptography in /opt/fhem/.local/lib/python3.7/site-packages (3.4.5)
Requirement already satisfied, skipping upgrade: cffi>=1.12 in /opt/fhem/.local/lib/python3.7/site-packages (from cryptography) (1.14.5)
Requirement already satisfied, skipping upgrade: pycparser in /opt/fhem/.local/lib/python3.7/site-packages (from cffi>=1.12->cryptography) (2.20)
pi@fhem:~ $ sudo -u fhem pip3 install --upgrade fhempy
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: fhempy in /opt/fhem/.local/lib/python3.7/site-packages (0.1.48)
Requirement already satisfied, skipping upgrade: websockets>=8.1 in /opt/fhem/.local/lib/python3.7/site-packages (from fhempy) (8.1)
Requirement already satisfied, skipping upgrade: importlib-metadata>=3.3.0 in /opt/fhem/.local/lib/python3.7/site-packages (from fhempy) (3.4.0)
Requirement already satisfied, skipping upgrade: zeroconf>=0.28.6 in /opt/fhem/.local/lib/python3.7/site-packages (from fhempy) (0.28.6)
Requirement already satisfied, skipping upgrade: cryptography>=3.3.1 in /opt/fhem/.local/lib/python3.7/site-packages (from fhempy) (3.4.5)
Requirement already satisfied, skipping upgrade: typing-extensions>=3.6.4; python_version < "3.8" in /opt/fhem/.local/lib/python3.7/site-packages (from importlib-metadata>=3.3.0->fhempy) (3.7.4.3)
Requirement already satisfied, skipping upgrade: zipp>=0.5 in /opt/fhem/.local/lib/python3.7/site-packages (from importlib-metadata>=3.3.0->fhempy) (3.4.0)
Requirement already satisfied, skipping upgrade: ifaddr>=0.1.7 in /opt/fhem/.local/lib/python3.7/site-packages (from zeroconf>=0.28.6->fhempy) (0.1.7)
Requirement already satisfied, skipping upgrade: cffi>=1.12 in /opt/fhem/.local/lib/python3.7/site-packages (from cryptography>=3.3.1->fhempy) (1.14.5)
Requirement already satisfied, skipping upgrade: pycparser in /opt/fhem/.local/lib/python3.7/site-packages (from cffi>=1.12->cryptography>=3.3.1->fhempy) (2.20)
pi@fhem:~ $

Offline dominik

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2905
Antw:fhempy: googlecast
« Antwort #223 am: 14 Februar 2021, 09:25:50 »
Und wenn du jetzt fhempy startest kommt trotzdem der Fehler? Kannst du das bitte nochmals testen.
fhempy -  https://github.com/dominikkarall/fhempy: GoogleCast, UPnP, Ring, EQ3BT, Nespresso, Xiaomi, Spotify, Object Detection, ...
Kaffeespende: https://paypal.me/todominik

Offline Keichi

  • New Member
  • *
  • Beiträge: 18
Antw:fhempy: googlecast
« Antwort #224 am: 14 Februar 2021, 09:35:16 »
Und wenn du jetzt fhempy startest kommt trotzdem der Fehler? Kannst du das bitte nochmals testen.

Okay.. Nun läufts... Wieso auch immer, der hat doch nichts neues installiert  :o Na, dann erstmal weitermachen und die Minis in Fhem integrieren, dann seh ich ja was geht und was nicht.

Edit: Super, nun sind beide Minis auch wieder in Fhem. Du solltest aber vielleicht noch in der Readme erwähnen das <NAME> für den Namen aus der Google Home App steht.. Da braucht ich echt ne Minute um zu kapieren was gemeint war.
« Letzte Änderung: 14 Februar 2021, 10:10:28 von Keichi »

 

decade-submarginal