Autor Thema: FHEM blockiert: Accept failed (WEB: Too many open files)  (Gelesen 5574 mal)

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 817
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #15 am: 07 März 2022, 13:03:33 »
Ok, ich warte auf den nächste Vorfall - und hoffe, dass ich dann auch wieder gleich rankomme.

Danke Dir
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Offline Wernieman

  • Developer
  • Hero Member
  • ****
  • Beiträge: 8521
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #16 am: 07 März 2022, 14:05:25 »
Noch ein kleiner Hinweis wegen "Files" und Netzwerk:
Unter Unix als alles ein File. Also kann durchaus wegen Netzwerkverbindungsanzahl es zu solchen Problemen kommen. Aber auch andere Hardware, wie z.B. Serielle Schnittstellen.
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 817
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #17 am: 14 Mai 2022, 08:44:02 »
"Endlich" habe ich mal wieder den Zustand. Diesmal leider besonders hartnäckig wiederholt seit über einer Woche. Seltsamerweise genau seit ich das Haus verlassen habe für einen Kurzurlaub und immer dann, wenn die Nachbarin die Anwesenheitskontrolle aktiviert. Damit konnte ich das jetzt sogar eindeutig reproduzieren. Seltsam ist allerdings, dass ich ganz sicher seit längerem diesbezüglich nichts geänedrt habe und auch kein Update durchgeführt hatte. Das hatte ich erst vor wenigen Tagen, als der Fehler wieder auftauchte, gemacht.

Ich füge mal zwei Ausgaben aus lsof bei. Das erste ohne den Fehler, das zweite von gerade jetzt, als ich den Fehler bewusst provoziert habe. Muss aber sagen: Ich sehe zwar den Unterschied in Form der gehäuften TCPs, mir sagt das gar nichts.
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25852
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #18 am: 14 Mai 2022, 11:17:32 »
Von den 1024 Filedeskriptoren sind 170 FileLogs, 8 TCP Serverports, 13 hergestellte Client-Verbindungen, eine ist beim Schliessen, 4 beim vergeblichen Herstellen der Verbindung, und 820 (die mit protocol: TCP) in "gar keinem" Zustand.

Nach laengerem experimentieren: ein "protocol: TCP" Eintrag kann auch auftreten, wenn HttpUtils_NonblockingGet mit keepalive=1 aufgerufen wurde, ohne die Verbindung danach selber zu schliessen. Heisst nicht, dass das auch hier der Fall ist.

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 817
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #19 am: 14 Mai 2022, 13:36:02 »
Danke Dir für die schnelle Antwort. Da habe ich mindestens mal einen neuen Ansatz. Hab‘ da als erstes die Alexa-Schiene unter Verdacht, auch wenn diese aktuell gar nicht aufgerufen werden sollte. Aber ursprünglich kamen die Probleme erst einige Zeit, nachdem dies eingerichtet wurde.
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 817
Antw:FHEM blockiert: Accept failed (WEB: Too many open files)
« Antwort #20 am: 16 Mai 2022, 22:53:47 »
Jetzt habe ich AMAD unter Verdacht. Mein Flur-Tablet hatte offensichtlich kurz nach unserem Urlaubsantritt einen Fehler und hat sich aufgehangen. Wenn jetzt die Nachbarin vor der Tür stand, um zu öffenen, sollte am Tablet über AMAD eine Ansage kommen. Die vier vergeblichen TCP-Verbindungsversuche sind auch alle an das Tablet pere AMAD gerichtet. Und als ich jetzt zuhause war und alles wieder vernünftig zum Laufen bringen wollte, giung das erst, als ich AMAD in der Config manuell auskommentiert habe. Dann alles gestartet (FHEM und das Tablet), die Kommentarzeichen wieder entfernt, rereadcfg eingegeben und im Moment läuft es wieder. Ist jetzt keine Dauerlösung, klar. Muss AMAD nochmal im Auge behalten.
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

 

decade-submarginal