FHEM - Hardware > Einplatinencomputer

Fernzugriff auf Raspberry PI OS lite

<< < (3/3)

tyrolean:
...darf ich nach längerer Zeit das Thema nochmals aufgreifen.

Also das mit dem Reverse SSH Tunnel funktioniert prinzipiell sehr gut.
Baue das über diesen Befehl auf:


--- Code: ---ssh -R öffentlicheIPLinux:8090:127.0.0.1:8083 username@öffentlicheIPLinux
--- Ende Code ---

damit werde ich über den öffentlichen Linux Server wenn ich über Port 8090 zugreife auf meinem FHEM Server weitergeleitet.
Allerdings hätte ich gerne ein wenig mehr Sicherheit, also dass nicht jeder der die öffentliche IP kennt einfach über den Port 8090 weitergeleitet wird.
Gedacht hätte ich daran dass man vorher selbst einen "normalen" SSH Tunnel zu dem öffentlichen Server aufbauen muss damit das Ganze funktioniert.
Könnte mir da jemand einen Tipp geben wie das funktioniert.

Gruß und Danke für eure Hilfe

Wernieman:
In dem Du, anstatt der Öffentlichen IP, den Reverse Tunnel nur auf localhost lauschen lässt.

Ungetestet:

--- Code: ---ssh -R 127.0.0.1:8090:127.0.0.1:8083 username@öffentlicheIPLinux
--- Ende Code ---

Wenn Du jetzt einen ssh-Tunnel zu Server aufbaust (ungetestet)

--- Code: ---ssh -L 127.0.0.1:8090:127.0.0.1:8090 username@öffentlicheIPLinux
--- Ende Code ---
Wird der (client)localhost:8090 über den Tunnel zum Server geschickt und dort über (server)localhost:8090 zum (ziel)localhost:8083

Ich muß aber gestehen, das ich dafür beinahe, wie betateilchen, nur direkt auf ssh setzen Würde. Also den reverse ssh-Tunnel nur zum ssh-Tunneln verwenden und darüber dann http abfackeln. Kling Kompliierter, ist aber praktisch einfacher .... da ich über ssh mehr machen kann als "nur" http/s

tyrolean:
Danke für die Antwort,

also ich habe es jetzt genau so wie vorgeschlagen versucht, also:

--- Code: ---Am "FHEM Pi"
ssh -R 127.0.0.1:8090:127.0.0.1:8083 username@öffentlicheIPLinux
Auf meinem Mac:
ssh -L 127.0.0.1:8090:127.0.0.1:8090 username@öffentlicheIPLinux

--- Ende Code ---

Wenn ich jetzt am Mac in Safari öffentlicheIPLinux:8090 eingebe habe ich Zugriff auf mein FHEM bei
127.0.0.1:8090 kommt jedoch in der geöffneten SSH Session:

--- Code: ---channel 3: open failed: connect failed: Connection refused
--- Ende Code ---
und ich habe keinen Zugriff.

Habe ich da einen prinzipiellen Fehler (Parameter bei ssh -L vergessen) oder wie kann ich der Sache auf den Grund gehen?

Wernieman:
Was sagen die sonstigen Logfiles? kern.log/syslog

Muß jetzt gestehen, das ich hier nichts zum testen oder nachbauen habe .. wie geschrieben, war "ungetestet"

Wenn Du auf dem öffentlicheIPLinux bist, kannst Du dann mit wget/curl/lynx/w3m oder sonstigen textbrowser auf die Webside 127.0.0.1:8083

Navigation

[0] Themen-Index

[*] Vorherige Sete

Zur normalen Ansicht wechseln