Autor Thema: Orignal MAX!/ELV/e3Q Software unter Linux  (Gelesen 1003 mal)

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4533
Orignal MAX!/ELV/e3Q Software unter Linux
« am: 24 Januar 2021, 14:11:46 »
aus aktuellem Anlass benötige ich die Orignal MAX! Software, aber ich habe schon seit Jahren kein Windoof mehr auf meinem PC.
Um die Original MAX! Software (JAVA) unter Linux zu starten gibt es ein tolles Installations Skript : https://github.com/shawn-ogg/maxapp_linux_installer
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline rbm78bln

  • New Member
  • *
  • Beiträge: 4
  • 😎
Antw:Orignal MAX!/ELV/e3Q Software unter Linux
« Antwort #1 am: 24 Januar 2021, 16:22:55 »
...gerade ins script geschaut und komme mir ein Bisschen dumm vor: Warum habe ich krampfhaft versucht, die Windows-Variante unter Alpine ans laufen zu bringen und nicht die für'n Mac?!  ::)

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4533
Antw:Orignal MAX!/ELV/e3Q Software unter Linux
« Antwort #2 am: 24 Januar 2021, 17:23:42 »
ja vor meiner FHEM Zeit (2013) hatte ich schon mal das ganze JAVA Geraffel unter Linux, aber das war damals mit erheblichen Aufwand verbunden bis das lief.
Das Skript jetzt musste noch ein paar fehlende Pakete ziehen dann lief die MAX!App quasi aus dem Stand, ich war echt positiv überrascht :)
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Orignal MAX!/ELV/e3Q Software unter Linux
« Antwort #3 am: 13 März 2021, 13:49:13 »
Hallo Wzut,

läuft das Skript  https://github.com/shawn-ogg/maxapp_linux_installer auch auf dem RasPi? Oder muß da noch zusätzlich etwas nachinstalliert werden? ExaGear ist gestartet. Wenn ich /opt/MAX_APP/start.sh im Terminal ausführe, erscheint die Anzeige auf dem Desktop "MAX! Anwendung im Browser starten". Der Balken wechselt bei Anklicken die Farbe und im Terminal lauten die letzten Zeilen:

at java.desktop/java.awt.EventDispatchThead.pumpEvents(EventDispachThred.Java:109)
at java.desktop/java.awt.EventDispatchThead.pumpEvents(EventDispachThred.Java:101)
at java.desktop/java.awt.EventDispatchThead.run(EventDispachThred.Java:90)

Danach geht es nicht mehr weiter, ganz gleich was ich versuche  außer ich klicke auf das "X" oben rexhrts im MAX!-Bild. Dann wird start.sh beendet und das MAX!-Bild geschlossen.

Achja, MAX-Qube mit 6 Thermostatventilen, einem Wandthermostat und ECO-Taster funktionieren unter Windows sowie Linunx-Mint und -Pepermint einwandfrei.

Gibt es eine Möglichkeit die MAX-APP auf dem RasPi zum Laufen zu bringen?

Ich würde mich sehr freuen, wenn du mir weiterhelfen würdest.

Mit freundlichen Grüßen

Harald
« Letzte Änderung: 13 März 2021, 14:02:46 von Harald »
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4533
Antw:Orignal MAX!/ELV/e3Q Software unter Linux
« Antwort #4 am: 13 März 2021, 14:16:31 »
Oh sorry, auf allen meinen Himbeeren ist kein X installiert, ich habe X nur auf meinem Desktop PC unter Debian.
Aber von der Logik spricht normalerweise nichts gegen den RPi, man müsste nur mal ins install Skript schauen, nicht das da Pakete gezogen werden die nicht zum Prozessor passen (Intel vs. ARM) Wenn sonst niemand mit Wissen beitragen kann würde ich einfach einen Request in dem git Repro aufmachen,
der Autor müsste eh die meiste Ahnung haben.   
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline Harald

  • Sr. Member
  • ****
  • Beiträge: 656
Antw:Orignal MAX!/ELV/e3Q Software unter Linux
« Antwort #5 am: 13 März 2021, 15:21:28 »
Hallo Wzut,

danke für die schnelle Reaktion. Das Problem mit Intel/Arm soll ja angeblich mit ExaGear behoben sein.
Leider blicke ich bei Github nicht so richtig durch. Aber das ist schon ein guter Hinweis.
Ich habe das wohl falsch verstanden. Ich dachte, DU hast das Installprogram entwickelt. Des halb hier die Frage. Dann werde ich mich mal an den Autor wenden.
Nochmals vielen Dank, schönes Wochenende und bleibt alle gesund

Harald
Router:AVM7590 1&1 FW:FRITZ!OS 07.01 Anbindung:1&1 50/10 Mb/s, WLAN-Repeater 300E OS 6.04
ELV MAX!Cube, 7xThermostat, ECO, RasPi B mit Wheezy auf Festplatte,
CUL V 1.67, JeeLink v3_10.1c, nanoCUL, 1xS300TH, 4xHMS100T, 4xELRO, 1xTFA, 1xMAX_FK
ELV MAX!1.4.5, MAX!Buddy, -Backup, FHEM 5.7 auf RasPi

 

decade-submarginal