Verschiedenes > Bastelecke

eBUS Adapter 3.0 Inbetriebnahme

<< < (74/76) > >>

Reinhart:
also der Adapter und der RPI-Connector sieht gut aus, aber du hast immer noch den Jumper auf eth gesetzt (der blaue), der muss raus!

Ansonsten checke ob der ttyAMA0 wirklich auf PL011 gemappt ist.


--- Code: ---pi@raspberrypi4:~ $ dmesg| grep tty
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M cma=256M  smsc95xx.macaddr=DC:A6:32:05:9C:3A vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=a26e8757-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[    0.000698] console [tty1] enabled
[    0.837722] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2
[    0.841036] fe215040.serial: ttyS0 at MMIO 0x0 (irq = 36, base_baud = 62500000) is a 16550
[    8.736928] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
[    8.743027] usb 1-1.3: ch341-uart converter now attached to ttyUSB0
[    8.753030] cdc_acm 1-1.4:1.2: ttyACM1: USB ACM device
[    8.755760] cdc_acm 1-1.4:1.4: ttyACM2: USB ACM device

--- Ende Code ---

Ansonsten sollte die /boot/config.txt so aussehen:

--- Code: ---[all]
enable_uart=1
dtoverlay=disable-bt
--- Ende Code ---
also interne serielle Schnittstelle ein und Bluetooth deaktiveren das der die serielle nicht belegt.

Bitte aufpassen, dass du den Adapter nicht auf den Raspi drückst, vielleicht mit Klebeband unten etwas abkleben damit es zu keinem Kurzschluss kommen kann. Wir liefern die RPI mit einem Abstandhalter aus, welcher in das Loch am Adapter gesteckt wird. Kannst vielleicht auch eine M3 Kunstoffschraube im Loch befestigen.

LG

z1marco:
Hallo Reinhart,

super für die Beobachtung. Ich hab den blauen Jumper entfernt und nun klappt es. Ich hab nur den Bereich der Anleitung Raspi geschaut und nicht den vom Ehternet. Dann wäre mir das aufgefallen.
Vielen lieben Dank auch für Euren tollen Einsatz. Ich werde jetzt mal weiter testen und basteln.

Reinhart:
... deshalb ist ein Foto immer besser weil man sich ein besseres Bild machen kann.

Wenn du keinen Abstandhalter hast, dann nimm einfach eine Plastikschraube mit zwei Muttern.

Freut mich das dein Adapter nun funktioniert!

LG

Reinhart:
hier mal ein Beispiel wie man einfache Graphen mit DOIF in Fhem realisieren kann.


--- Code: ---define di_Vorlauf DOIF ##
{package ui_Table;;}
card([Vorlauf:Vorlauf:col12],"Vorlauf","temp_outside",20,60,undef,undef,"°C",\&temp_hue,undef,180)|

card([VorlaufSoll:VorlaufSoll:col12],"VorlaufSoll","temp_outside",20,60,undef,undef,"°C",\&temp_hue,undef,180)

card([Ruecklauf:Ruecklauf:col12],"Rücklauf","temp_outside",20,60,undef,undef,"°C",\&temp_hue,undef,180)|

card([HMS100T_9163:temperature:col12],"Vorlauf EG","temp_outside",20,60,undef,undef,"°C",\&temp_hue,undef,180)|
--- Ende Code ---

LG

tho-mas:
Inbetriebnahme esera Bus-Adapter (USB)
Hallo,

ich wurde aus einer anderen Diskussion auf diese hier verwiesen. Aber ich habe das Fertigprodukt von esera (https://www.esera.de/produkte/ebus/135/1-wire-hub-platine?c=20) und nicht das Selbstbauprojekt. Nach Installation vom ebusd sehe ich Werte:


--- Code: ---pi@pi4:/usr/bin $ ebusctl info
version: ebusd 21.3.v21.3
update check: OK
device: /dev/ttyUSB0
signal: acquired
symbol rate: 23
max symbol rate: 277
min arbitration micros: 1516
max arbitration micros: 1516
min symbol latency: 5
max symbol latency: 6
reconnects: 1
masters: 3
messages: 643
conditional: 3
poll: 0
update: 10
address 03: master #11
address 08: slave #11, scanned "MF=Vaillant;ID=BAI00;SW=0407;HW=7603", loaded "vaillant/bai.308523.inc", "vaillant/08.bai.csv"
address 10: master #2
address 15: slave #2, scanned "MF=Vaillant;ID=72000;SW=0122;HW=7703", loaded "vaillant/15.720.csv"
address 31: master #8, ebusd
address 36: slave #8, ebusd

pi@pi4:/usr/bin $ ebusctl scan
done

pi@pi4:/usr/bin $ ebusctl r -f HcHours
706


--- Ende Code ---
 

Allerdings wundere ich mich, das ich bei "ebusctl find" fast nur "no data storred" als Antwort bekomme, da haben mir auch die 370 Beiträge dieser Diskussion nicht weitergeholfen. Letztendlich möchte ich so eine Anzeige wie von Reinhard in Beitrag 10 bzw. 368 gezeigt auch für meine Theme nutzen.

Die Seite https://wiki.fhem.de/wiki/EBUS-MQTT2 zeigt ja viele Schritte an, aber bei mir tauchen viele Fragen dazu auf:

- ist mqtt notwendig oder nur Option um so eine anzeige wie von Reinhard zu bekommen? (FHEM läuft)

- Zitat: "Beides wird vermutlich am Raspberry der FHEM Hauptinstanz sein, also die IP-Adresse des Raspberry einsetzen."

also die reale IP (192.168.xxx.xxx) oder geht auch localhost bzw. 127.0.0.1? Weil die reale IP könnte sich ja ändern...

- "mit erweiterten JSON-Optionen erstellen wollen" Was ist JSON? Ich kenne das nur als NAS-bezogenen Begriff, was hat das hier zu suchen?

- "müssen entweder diese Geräte nach dem Deaktivieren des autocreate am IO gelöscht, oder zumindest die readingList entsprechend bereinigt oder gelöscht werden." = Bahnhof...


- "FHEM-Interner Server. Wer keinen Mosquitto installiert hat kann diese Konfiguration wählen. Dazu wird einfach der MQTT2-SERVER definiert." Also in der FHEM-Befehlszeile eingeben?

- "dass die CID dem Basispfad des Topic-trees entspricht" = CID??? Topic-Tree????


- "Auf das Device MQTT2_ebusd wird nun folgendes Template angwendet:" (das Bild darunter): Einfach Eintippen? Wo? Das Bild zeigt jedenfalls nicht eine FHEM-Standart-Installation - die ist gelb-grün...

- "Zur Kontrolle bitte prüfen ob hier auch die „bridgeRegexp“ vom Template richtig gesetzt wurde." Das folgende Bild sowie die Codezeile darunter ergeben für mich keinen Zusammenhang. Wofür sind die 3 Zeilen? Was soll damit passieren?

- " IO-Device" - mir schwirrt der Kopf, vielleicht habe ich den roten Faden verloren, aber was ist jetzt IO-Device?

- "setzen wir auf dem MQTT2_SERVER oder dem MQTT2_CLIENT ( je nachdem welcher verwendet wurde) das Attribut „autocreate“ auf „complex“." Das Bild darunter sieht FHEM-ähnlich aus, aber was soll es mir sagen?

- "Es kann aber in der Zwischenzeit noch die Timer gesteuerte Abfrage definiert werden." Nur zur Sicherheit: In die Kommandozeile von FHEM eintippen (kopieren)?

- Ist das von Reinhard erwähnte Bild/Anzeige nach dieser Anleitung erstellt worden oder nach einer anderen Verfahrensweise?

- In Beitrag 10 (vom 7.2.2021) wird eine "Tabletui3" angesprochen.

Schon mal Danke für die Antworten..

Thomas

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln